[SOLVED] PVE Webinterface nicht erreichbar

Atom_Smasher_00

New Member
May 18, 2021
3
1
3
22
Germany
Hallo liebe Proxmox Community,

ich habe vor kurzem die Systempaket von meinem Server aktualisiert, nun kann ich das Webinterface (https://ip-adresse:8006) von Proxmox nicht mehr aufrufen. (siehe auf folgendem Bild)
Ich habe schon einiges probiert und bin bisher zu keiner Lösung gekommen.

Fehlermeldung Firefox Webinterface vforum.jpg

PVE funktioniert auch ohne Probleme den aktuell habe ich 3 aktive Virtuelle Server laufen und diese sind komplett erreichbar und funktionsfähig.

Die wichtigsten Services für Proxmox lauf ohne Probleme. (siehe Bild)

Services status.jpg

Soweit ich feststellen konnte ist der Port 8006 leider nur für IPv6 freigegeben, weshalb ich hier den Fehler vermute. (siehe Bild)
Vor dem Systemupdate konnte ich der Server über https://IPv4:8006 erreichen, nun nicht mehr.

Portfreigabe pveproxy Fehler nur IPv6.jpg

Der Server ist sonst noch über andere Services erreichbar (Putty, Webserver (apache) usw.), deswegen gehe ich davon aus, dass die Netzwerkeinstellungen unter /etc/hosts richtig eingestellt ist.
Diese Stelle ich nicht mit einem Bild zur verfügung, da es sich hierbei um öffentliche IP Adressen handelt, falls dies trozdem gewünscht wird, würde ich diese dann anonymisiert übermitteln.

Zum Schluss noch eine übersicht der PVE Paketversion. (siehe Bild.)

pveversion.jpg

Ich hoffe ich konnte schon viele wichtig Hinweise und Informationen zusammentragen, damit mir schnell geholfen werden kann.
Sollten trotzdem noch Fragen aufkommen versuche ich so gut es mir möglich ist, die Infomationen zusammen zu tragen.

Ich freue mich über schnelle Antworten.

Mit feundlichen Grüßen
Brian
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,230
1,137
164
hm - bitte noch folgende infos posten:
* `ss -tlnp` (das output ist ein wenig informativer als `netstat` - bzw. bin ich es mittlerweile eher gewohnt)
* `sysctl -a |grep bindv6` (siehe hierzu auch die Dokumentation zu LISTEN_IP in https://pve.proxmox.com/pve-docs/pveproxy.8.html)

danke!
 

Atom_Smasher_00

New Member
May 18, 2021
3
1
3
22
Germany
hm - bitte noch folgende infos posten:
* `ss -tlnp` (das output ist ein wenig informativer als `netstat` - bzw. bin ich es mittlerweile eher gewohnt)
* `sysctl -a |grep bindv6` (siehe hierzu auch die Dokumentation zu LISTEN_IP in https://pve.proxmox.com/pve-docs/pveproxy.8.html)

danke!

Hier sind die gewünschten Informationen.

zu ss -tlnp | grep 8006 und ss -tlnp | grep pveproxy

Portfreigabe pveproxy Fehler nur IPv6 v2.jpg

und zu sysctl -a |grep bindv6

pveproxy IPv6 bindv6only.jpg

Ich hoffe diese Informationen helfen weiter.

Mit freundlichen grüßen
Brian
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,230
1,137
164
Ich hoffe diese Informationen helfen weiter.
Ja das tun sie :) (Wenn möglich das nächste mal bitte dennoch als text in code-tags, anstatt als screenshot posten, da sich das weit leichter lesen lässt).

die bindv6only sysctl ist auf 1 gesetzt, wodurch pveproxy nur connections von IPv6 addressen akzeptiert (siehe auch die Doku zu LISTEN_IP in [0]):
* die sysctl einfach deaktivieren ist wahrscheinlich die beste Option (`grep -r bindv6only /etc/sysctl*` sollte zeigen wo die sysctl gesetzt wird)
* falls die sysctl bewusst gesetzt wurde und auch auf 1 bleiben soll (wie in der Dokumentation beschrieben - ist das kein weit verbreitetes Szenario und keines, das wir testen) - dann würde ich die LISTEN_IP konfigurieren

Ich hoffe das hilft!

[0] https://pve.proxmox.com/pve-docs/pveproxy.8.html
 

Atom_Smasher_00

New Member
May 18, 2021
3
1
3
22
Germany
Ja das tun sie :) (Wenn möglich das nächste mal bitte dennoch als text in code-tags, anstatt als screenshot posten, da sich das weit leichter lesen lässt).

die bindv6only sysctl ist auf 1 gesetzt, wodurch pveproxy nur connections von IPv6 addressen akzeptiert (siehe auch die Doku zu LISTEN_IP in [0]):
* die sysctl einfach deaktivieren ist wahrscheinlich die beste Option (`grep -r bindv6only /etc/sysctl*` sollte zeigen wo die sysctl gesetzt wird)
* falls die sysctl bewusst gesetzt wurde und auch auf 1 bleiben soll (wie in der Dokumentation beschrieben - ist das kein weit verbreitetes Szenario und keines, das wir testen) - dann würde ich die LISTEN_IP konfigurieren

Ich hoffe das hilft!

[0] https://pve.proxmox.com/pve-docs/pveproxy.8.html

Hallo,
vielen dank für die Hilfe, das war der richtig Tipp nun kann ich das Webinterface problemlos wieder über den Browser aufrufen.

Mit freundlichen grüßen
Brian
 
  • Like
Reactions: Stoiko Ivanov

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!