pve pvestatd: could not activate storage zfs error: import by numeric ID instead

ERNC

New Member
May 14, 2017
3
0
1
40
Greets.

Updated and rebooted pve. Now getting logs full of these. Sparse information on the googles. Most seems more oriented to someone in the rarefied zfs guru realms. Me? I'm not even sure where to start.

Help?

<lots-and-lots-of-these>

May 13 14:07:59 pve pvestatd[2036]: could not activate storage 'vm-disks', zfs error: import by numeric ID instead
May 13 14:08:08 pve pvestatd[2036]: could not activate storage 'zfs-containers', zfs error: import by numeric ID instead
May 13 14:08:10 pve pvestatd[2036]: could not activate storage 'vm-disks', zfs error: import by numeric ID instead
May 13 14:08:18 pve pvestatd[2036]: could not activate storage 'zfs-containers', zfs error: import by numeric ID instead
May 13 14:08:19 pve pvestatd[2036]: could not activate storage 'vm-disks', zfs error: import by numeric ID instead
May 13 14:08:29 pve pvestatd[2036]: could not activate storage 'vm-disks', zfs error: import by numeric ID instead

<lots-and-lots-more-of-these>
 

ERNC

New Member
May 14, 2017
3
0
1
40
found this:
<well, ok it didn't like my external link...whatever...>

<aitch-tee-tee-pee-etc> ubuntuforums.org/archive/index.php/t-2087726.html


However, there are no pools...

root@pve: # zpool list
no pools available
root@pve: # zpool status
no pools available
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
5,497
906
163
found this:
<well, ok it didn't like my external link...whatever...>

<aitch-tee-tee-pee-etc> ubuntuforums.org/archive/index.php/t-2087726.html


However, there are no pools...

root@pve: # zpool list
no pools available
root@pve: # zpool status
no pools available

what does "zpool import" say? the error mesage in your first post indicates that you have multiple pools with the same name, so you need to specify which of them you want to import by giving the numerical ID instead of the name. I suggest giving your pools unique names (you can use "zpool import oldname newname" to rename a pool which is currently not imported).
 

ERNC

New Member
May 14, 2017
3
0
1
40
Thank you for the reply and pointing me in the right direction. I saw that I had one failed drive from the pve status panel and ordered a replacement, but still expected the pool to come up. I didn't know I had two messed up drives; no wonder it doesn't want to play nice.

# zpool import
pool: zfs1
id: 6049159161468664829
state: UNAVAIL
status: One or more devices contains corrupted data.
action: The pool cannot be imported due to damaged devices or data.

config:

zfs1 UNAVAIL insufficient replicas
raidz1-0 UNAVAIL insufficient replicas
sdb ONLINE
sdc FAULTED corrupted data
sdc ONLINE
sde UNAVAIL
logs
sda4 ONLINE
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!