PVE 5.4.1 and ceph

oz1cw7yymn

Well-Known Member
Feb 13, 2019
89
12
48
Hi,

I am testing the new version of PVE together with ceph and I am having some problems.

These are my steps:

1. Burn 5.4 release 1 iso with Etcher
2. Install on SSD (USB) with ext4
3. Disable enterprise repo, enable no-sub repo, run dist-upgrade
4. Run wipefs -a on all ceph drives
5. install ceph-luminous from GUI
6. set public ip to be ip of pve node and CIDR 16, first ceph monitor is pve node
7. create OSDs for 4 drives, bluestore and no separate journal
8. Create pool "rbd" , size 3, min size 2, crush rule "replicated", pg=16, add storage=yes
9. download CT template ubuntu 18.04
10. create CT 8 GB drive on rbd
ERR - unable to create drive >> TASK ERROR: unable to create CT 200 - error with cfs lock 'storage-rbd': rbd error: got lock timeout - aborting command

11. deleted the pool and created a new pool with 128 pgs
12. tried to create a new ct - failed as the node timed out trying to list content of the local storage
12. tried to delete the CT - failed, tried to reboot in gui - failed, tried to shutdown in gui - failed, used virtual console to press ctrl-alt-delete - node rebooted
13. deleted the CT
14. created a new ct on the new rbd
ERR - same error >> TASK ERROR: unable to create CT 100 - error with cfs lock 'storage-rbd': rbd error: got lock timeout - aborting command

15. Open storage rbd - content - communication failure

Ideas?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!