Proxmox2 & Dell MD3220i

t-m

New Member
Mar 27, 2012
24
0
1
France
Dear members,

I'm configuring Proxmox on 2 DELL R610 servers. Seems to work well.
Now I try to install an Isci storage array DELL MD3220i.

- (GUI) I added and shared the iscsi target on the 1st server (proxmox1)
- (GUI) I see 2 iscsi storages, one for each server.
- (GUI) I can see details on promox1 : [summary : enable=yes active=yes ISCI=yes] [Content : LUN2 and LUN3]
- (GUI) I can't see details on Node 'proxmox2' : [summary : enable=yes active=no ISCI=yes] [Content : storage MD3200 is not online (500)]

Someone could explain me how to check my configuration ?
I follow the same steps on the 2 servers, but seems not to work with proxmox2. The ethernet link between MD3220i and proxmox2 is ok (ping).

Thanks for your contribution.
 

t-m

New Member
Mar 27, 2012
24
0
1
France
thanks for your reply.

In /var/log/syslog :
Code:
Sep  4 08:26:45 proxmox2 pvestatd[2068]: WARNING: storage 'md3200-1' is not online
Sep  4 08:26:55 proxmox2 pvestatd[2068]: WARNING: storage 'md3200-1' is not online
Sep  4 08:27:05 proxmox2 pvestatd[2068]: WARNING: storage 'md3200-1' is not online
Sep  4 08:27:15 proxmox2 pvestatd[2068]: WARNING: storage 'md3200-1' is not online
Sep  4 08:27:25 proxmox2 pvestatd[2068]: WARNING: storage 'md3200-1' is not online
Sep  4 08:27:35 proxmox2 pvestatd[2068]: WARNING: storage 'md3200-1' is not online
 

t-m

New Member
Mar 27, 2012
24
0
1
France
About the multipath command
Code:
root@proxmox1:~# multipath -l
36d4ae5200099eac7000003063e291db8 dm-3 DELL,MD32xxi
size=500G features='0' hwhandler='0' wp=rw
|-+- policy='round-robin 0' prio=-1 status=enabled
| `- 3:0:0:2 sdb 8:16 failed undef running
`-+- policy='round-robin 0' prio=-1 status=active
  `- 4:0:0:2 sdc 8:32 active undef running
36d4ae5200099eac7000003083e291df5 dm-4 DELL,MD32xxi
size=1.5T features='0' hwhandler='0' wp=rw
|-+- policy='round-robin 0' prio=-1 status=enabled
| `- 3:0:0:3 sdd 8:48 failed undef running
`-+- policy='round-robin 0' prio=-1 status=active
  `- 4:0:0:3 sde 8:64 active undef running
I think I have to discover why ''failed undef running''

Code:
root@proxmox2:~# multipath –l
root@proxmox2:~#
Nothing on proxmox2.
Is it possible there is some specific instructions to be the second node recongnized by the MD3220 array ?
 
Last edited:

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,797
445
103
I personally do not know the MD32320 in detail but maybe you need to enable something on the box to allow access from different boxes?
 

t-m

New Member
Mar 27, 2012
24
0
1
France
I configured the array MD32320i with 4 subnet IP's and added the hosts in the DELL GUI (MDSM), and then created a group "proxmox". After that I create 2 shared volume groups for KVM machines and 2 volumes for vz containers. Nothing more because I found this error on the proxmox GUI.

Do you think I had to follow this how-to before ? http://pve.proxmox.com/wiki/ISCSI_Multipath
 
Last edited:

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,797
445
103
yes, check the howto.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!