Proxmox VE 5.1 released!

martin

Proxmox Staff Member
Staff member
Apr 28, 2005
641
364
63
We are very happy to announce the final release of our Proxmox VE 5.1 - based on the latest Debian 9.2 and a modern Linux Kernel 4.13 with ZFS 0.7.2.

With Proxmox VE 5.1 Ceph Luminous is finally production-ready and fully supported by the Proxmox support team. The new BlueStore storage backend for Ceph boosts performance (in some cases up to 2x for writes), got full data checksumming and built-in compression - BlueStore is the new default for OSDs.

And as always we have included countless bugfixes and improvements on a lot of places.

Release notes
https://pve.proxmox.com/wiki/Roadmap#Proxmox_VE_5.1

Download
https://www.proxmox.com/en/downloads
Alternate ISO download:
http://download.proxmox.com/iso/

Source Code
https://git.proxmox.com

Bugtracker
https://bugzilla.proxmox.com

FAQ
Q: Can I install Proxmox VE 5.1 on top of Debian Stretch?
A: Yes, see https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Stretch

Q: Can I dist-upgrade Proxmox VE 4.4 to 5.1 with apt dist-upgrade?
A: Yes, see https://pve.proxmox.com/wiki/Upgrade_from_4.x_to_5.0

Q: I am running Ceph Server on V4.4 in a production setup - should I plan the upgrade now?
A: Yes. Ceph packages in Proxmox VE 5.1 are based on the latest Ceph Luminous release, please follow these wiki article - https://pve.proxmox.com/wiki/Ceph_Jewel_to_Luminous and https://pve.proxmox.com/wiki/Upgrade_from_4.x_to_5.0

Many thank you's to our active community for all feedback, testing, bug reporting and patch submissions!

__________________
Best regards,

Martin Maurer
Proxmox VE project leader
 

MisterY

Member
Oct 10, 2016
87
1
8
32
An user of another forum said that he heard something about not loading the rpool from time to time. I asked him to be more specific, but I didn't get an answer...
 

Leole

New Member
May 19, 2017
20
2
3
56
Hello,

an cat /etc/debian_version still shows 9.1

I made (inside PVE 5.0)
apt-get update
apt-get dist-upgrade

did i something wrong ?

thanks
Leo
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,646
420
83
Hello,

an cat /etc/debian_version still shows 9.1

I made (inside PVE 5.0)
apt-get update
apt-get dist-upgrade

did i something wrong ?

thanks
Leo
This is small bug/wrong info from a Debian package (a future update will fix this)
 

J.Carlos

New Member
Oct 23, 2017
21
2
3
26
Hi,

For me ZFS isn´t working... system crash at startup, solution was downgrade zfs packets and use old kernel, waiting a update.

Best regards.
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,646
420
83
Hi,

For me ZFS isn´t working... system crash at startup, solution was downgrade zfs packets and use old kernel, waiting a update.

Best regards.
Please open a new thread for your problem, include all details about your hardware, the config and all needed logs.
Without telling details no one can help.

This thread should NOT be used to post all problems with updates.

So far there no major known issue with ZFS and the new kernel, only VERY old hardware got problems with the 4.13 kernel, hopefully this can be fixed soon.
 
  • Like
Reactions: soroush

J.Carlos

New Member
Oct 23, 2017
21
2
3
26
How did you downgrade it all?

Thanks
Hi Flexyz,

At startup on grub you should select the old kernel (4.10.17-23), when the system is up do:

apt-get install libzpool2linux=0.6.5.11-pve17~bpo90
apt-get install libnvpair1linux=0.6.5.11-pve17~bpo90
apt-get install libuutil1linux=0.6.5.11-pve17~bpo90
apt-get install libzfs2linux-dev=0.6.5.11-pve17~bpo90
apt-get install zfs-initramfs=0.6.5.11-pve17~bpo90
apt-get install zfsutils-linux=0.6.5.11-pve17~bpo90
apt-get install spl=0.6.5.11-pve10~bpo90

Then reboot and select old kernel again, zfs will work and you can boot up your vm

Best regards.
 
Nov 4, 2015
65
2
8
good morning my friends,
my sources.list are
Code:
deb http://ftp.it.debian.org/debian stretch main contrib

# security updates
deb http://security.debian.org stretch/updates main contrib

##Proxmox VE pvetest
deb http://download.proxmox.com/debian/pve stretch pvetest

#Proxmox Ceph test
deb http://download.proxmox.com/debian/ceph-luminous stretch test
for updating to 5.1 no subscription is this right?

Code:
deb http://ftp.debian.org/debian stretch main contrib

# PVE pve-no-subscription repository provided by proxmox.com,
# NOT recommended for production use
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription

# security updates
deb http://security.debian.org stretch/updates main contrib
is correct to remove the ceph line? I read that ceph is now integrated into pve repository but not sure how to upgrade from pvetest5.0+ceph luminous to pve5.1 no sub and ceph.
thnaks!
 

Diego Aguirre

New Member
Apr 7, 2016
4
1
3
40
After upgrading from 5.0 to 5.1 cannot start any VM...
Erro Message:

Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
TASK ERROR: start failed: command '/usr/bin/kvm -id 100 -chardev 'socket,id=qmp,path=/var/run/qemu-server/100.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -pidfile /var/run/qemu-server/100.pid -daemonize -smbios 'type=1,uuid=e9993974-746e-47f6-bd69-201afa6752a7' -name vm05.i -smp '2,sockets=1,cores=2,maxcpus=2' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vga std -vnc unix:/var/run/qemu-server/100.vnc,x509,password -cpu kvm64,+lahf_lm,+sep,+kvm_pv_unhalt,+kvm_pv_eoi,enforce -m 2048 -k pt-br -device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' -device 'pci-bridge,id=pci.2,chassis_nr=2,bus=pci.0,addr=0x1f' -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -chardev 'socket,path=/var/run/qemu-server/100.qga,server,nowait,id=qga0' -device 'virtio-serial,id=qga0,bus=pci.0,addr=0x8' -device 'virtserialport,chardev=qga0,name=org.qemu.guest_agent.0' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:9a26b53c4e90' -drive 'if=none,id=drive-ide2,media=cdrom,aio=threads' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/dev/pve/vm-100-disk-1,if=none,id=drive-virtio0,format=raw,cache=none,aio=native,detect-zeroes=on' -device 'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown,vhost=on' -device 'virtio-net-pci,mac=3A:65:31:34:37:35,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300'' failed: exit code 1

I try to modprobe kvm-intel without success:


root@vmdes02:~# modprobe kvm-intel
modprobe: ERROR: could not insert 'kvm_intel': Input/output error
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,646
420
83
After upgrading from 5.0 to 5.1 cannot start any VM...
Erro Message:

Could not access KVM kernel module: No such file or directory
failed to initialize KVM: No such file or directory
TASK ERROR: start failed: command '/usr/bin/kvm -id 100 -chardev 'socket,id=qmp,path=/var/run/qemu-server/100.qmp,server,nowait' -mon 'chardev=qmp,mode=control' -pidfile /var/run/qemu-server/100.pid -daemonize -smbios 'type=1,uuid=e9993974-746e-47f6-bd69-201afa6752a7' -name vm05.i -smp '2,sockets=1,cores=2,maxcpus=2' -nodefaults -boot 'menu=on,strict=on,reboot-timeout=1000,splash=/usr/share/qemu-server/bootsplash.jpg' -vga std -vnc unix:/var/run/qemu-server/100.vnc,x509,password -cpu kvm64,+lahf_lm,+sep,+kvm_pv_unhalt,+kvm_pv_eoi,enforce -m 2048 -k pt-br -device 'pci-bridge,id=pci.1,chassis_nr=1,bus=pci.0,addr=0x1e' -device 'pci-bridge,id=pci.2,chassis_nr=2,bus=pci.0,addr=0x1f' -device 'piix3-usb-uhci,id=uhci,bus=pci.0,addr=0x1.0x2' -device 'usb-tablet,id=tablet,bus=uhci.0,port=1' -chardev 'socket,path=/var/run/qemu-server/100.qga,server,nowait,id=qga0' -device 'virtio-serial,id=qga0,bus=pci.0,addr=0x8' -device 'virtserialport,chardev=qga0,name=org.qemu.guest_agent.0' -device 'virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3' -iscsi 'initiator-name=iqn.1993-08.org.debian:01:9a26b53c4e90' -drive 'if=none,id=drive-ide2,media=cdrom,aio=threads' -device 'ide-cd,bus=ide.1,unit=0,drive=drive-ide2,id=ide2,bootindex=200' -drive 'file=/dev/pve/vm-100-disk-1,if=none,id=drive-virtio0,format=raw,cache=none,aio=native,detect-zeroes=on' -device 'virtio-blk-pci,drive=drive-virtio0,id=virtio0,bus=pci.0,addr=0xa,bootindex=100' -netdev 'type=tap,id=net0,ifname=tap100i0,script=/var/lib/qemu-server/pve-bridge,downscript=/var/lib/qemu-server/pve-bridgedown,vhost=on' -device 'virtio-net-pci,mac=3A:65:31:34:37:35,netdev=net0,bus=pci.0,addr=0x12,id=net0,bootindex=300'' failed: exit code 1

I try to modprobe kvm-intel without success:


root@vmdes02:~# modprobe kvm-intel
modprobe: ERROR: could not insert 'kvm_intel': Input/output error
Seems you run a very old CPU - which model?
 

limone

Member
Aug 1, 2017
61
0
6
25
So apt upgrade && apt upgrade and i'm done?
No need to reboot, no need to stop/restart all VMs/CTs?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!