Proxmox VE 2.1 released!

martin

Proxmox Staff Member
Staff member
Apr 28, 2005
644
372
63
Hi all!

We just released Proxmox VE 2.1, including a lot of bug fixes the new Virtual Machine Startup and Shutdown Behavior.

A big Thank-you to our active community for all feedback, testing, bug reporting and patch submissions.

Release notes

  • simplify GUI for users without permissions
  • implemented startup/shutdown ordering
  • improved task logs on node startup/shutdown
  • added Russian, Italian and Turkish translation
  • updated corosync cluster stack to 1.4.3
  • update LVM to 2.02.95 (fixes snapshot problems)
  • bug fixes

Download
http://www.proxmox.com/downloads/proxmox-ve/17-iso-images

Upgrade from 2.0
Just run 'aptitude update && aptitude full-upgrade'

Upgrade from 1.9 to 2.1
http://pve.proxmox.com/wiki/Upgrade_from_1.9_to_2.0

__________________
Best regards,

Martin Maurer
Proxmox VE project leader
 

AndreU

New Member
Apr 23, 2012
11
0
1
THIS IS GREAT! Thanks to the Proxmox Team, you doing an amazing good job!
 

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
16,508
320
83
Austria
www.proxmox.com
Last edited:

andrea68

Member
Jun 30, 2010
101
0
16
WoW! Great work!

Do you think can I upgrade from 2.0 easily?
(is an upgraded 1.9 without grub update...)
 

Digdug

New Member
Mar 31, 2012
18
0
1
Great! Thanks a lot for the startup-shutdown feature!
And the bug-fix for LVM snapshots!

Upgrading from 2.0 to 2.1 worked without any issues.
 

tag

New Member
Apr 30, 2012
3
0
1
Thanks for the update. I upgraded from 2.0 to 2.1 using apt-get update && apt-get upgrade, I see the version changed in the management webpage but I can't see the new options (start/shutdown order) only "start at boot". Can this problem be related to the fact that I had a VM running at the time of upgrade? (It was the firewall and I couldn't shut it down because without it I can't reach internet - well, not without modifying whole network settings).
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,696
435
83
try reloading the admin gui (browser reload)
 

tag

New Member
Apr 30, 2012
3
0
1
try reloading the admin gui (browser reload)
Hi, sorry for the late reply. I tried reloading, deleting temporary internet files etc but only the VM has the new options (start/shutdown order, delay etc)... the CTs still have only "start at boot".
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,696
435
83
Yes, read the wiki page.
 

tag

New Member
Apr 30, 2012
3
0
1
Hi, I don't know how I skipped the note regarding CTs :) Thank you for your response.
 

diden05

New Member
Mar 20, 2012
1
0
1
Problem upgrade 2.0 -> 2.1

aptitude update && aptitude full-upgrade
Hit http://mirror.hetzner.de squeeze Release.gpg
Ign http://mirror.hetzner.de/debian/packages/ squeeze/contrib Translation-en
Ign http://mirror.hetzner.de/debian/packages/ squeeze/contrib Translation-en_US
Ign http://mirror.hetzner.de/debian/packages/ squeeze/main Translation-en
Ign http://mirror.hetzner.de/debian/packages/ squeeze/main Translation-en_US
Ign http://mirror.hetzner.de/debian/packages/ squeeze/non-free Translation-en
Ign http://mirror.hetzner.de/debian/packages/ squeeze/non-free Translation-en_US
Hit http://mirror.hetzner.de squeeze/updates Release.gpg
Ign http://mirror.hetzner.de/debian/security/ squeeze/updates/contrib Translation-en
Ign http://mirror.hetzner.de/debian/security/ squeeze/updates/contrib Translation-en_US
Ign http://mirror.hetzner.de/debian/security/ squeeze/updates/main Translation-en
Ign http://mirror.hetzner.de/debian/security/ squeeze/updates/main Translation-en_US
Ign http://mirror.hetzner.de/debian/security/ squeeze/updates/non-free Translation-en
Ign http://mirror.hetzner.de/debian/security/ squeeze/updates/non-free Translation-en_US
Hit http://mirror.hetzner.de squeeze Release
Hit http://mirror.hetzner.de squeeze/updates Release
Hit http://security.debian.org squeeze/updates Release.gpg
Ign http://security.debian.org/ squeeze/updates/contrib Translation-en
Ign http://security.debian.org/ squeeze/updates/contrib Translation-en_US
Ign http://security.debian.org/ squeeze/updates/main Translation-en
Ign http://security.debian.org/ squeeze/updates/main Translation-en_US
Ign http://security.debian.org/ squeeze/updates/non-free Translation-en
Ign http://security.debian.org/ squeeze/updates/non-free Translation-en_US
Hit http://download.proxmox.com squeeze Release.gpg
Ign http://download.proxmox.com/debian/ squeeze/pve Translation-en
Ign http://download.proxmox.com/debian/ squeeze/pve Translation-en_US
Hit http://security.debian.org squeeze/updates Release
Hit http://mirror.hetzner.de squeeze/main amd64 Packages
Hit http://mirror.hetzner.de squeeze/contrib amd64 Packages
Hit http://mirror.hetzner.de squeeze/non-free amd64 Packages
Hit http://download.proxmox.com squeeze Release
Hit http://security.debian.org squeeze/updates/main Sources
Hit http://security.debian.org squeeze/updates/contrib Sources
Hit http://security.debian.org squeeze/updates/non-free Sources
Hit http://security.debian.org squeeze/updates/main amd64 Packages
Hit http://security.debian.org squeeze/updates/contrib amd64 Packages
Hit http://security.debian.org squeeze/updates/non-free amd64 Packages
Hit http://download.proxmox.com squeeze/pve amd64 Packages
Hit http://ftp.at.debian.org squeeze Release.gpg
Ign http://ftp.at.debian.org/debian/ squeeze/contrib Translation-en
Ign http://ftp.at.debian.org/debian/ squeeze/contrib Translation-en_US
Hit http://backports.debian.org squeeze-backports Release.gpg
Ign http://backports.debian.org/debian-backports/ squeeze-backports/main Translation-en
Ign http://backports.debian.org/debian-backports/ squeeze-backports/main Translation-en_US
Hit http://mirror.hetzner.de squeeze/updates/main amd64 Packages
Hit http://mirror.hetzner.de squeeze/updates/contrib amd64 Packages
Hit http://mirror.hetzner.de squeeze/updates/non-free amd64 Packages
Ign http://ftp.at.debian.org/debian/ squeeze/main Translation-en
Ign http://ftp.at.debian.org/debian/ squeeze/main Translation-en_US
Hit http://ftp.at.debian.org squeeze Release
Hit http://backports.debian.org squeeze-backports Release
Hit http://ftp.at.debian.org squeeze/main amd64 Packages
Hit http://backports.debian.org squeeze-backports/main amd64 Packages/DiffIndex
Hit http://ftp.uni-bayreuth.de squeeze Release.gpg
Ign http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze/contrib Translation-en
Hit http://ftp.at.debian.org squeeze/contrib amd64 Packages
Ign http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze/contrib Translation-en_US
Ign http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze/main Translation-en
Hit http://backports.debian.org squeeze-backports/main amd64 Packages
Ign http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze/main Translation-en_US
Ign http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze/non-free Translation-en
Ign http://ftp.uni-bayreuth.de/linux/Debian/debian/ squeeze/non-free Translation-en_US
Hit http://ftp.uni-bayreuth.de squeeze Release
Hit http://ftp.uni-bayreuth.de squeeze/main Sources
Hit http://ftp.uni-bayreuth.de squeeze/non-free Sources
Hit http://ftp.uni-bayreuth.de squeeze/contrib Sources
Hit http://ftp.uni-bayreuth.de squeeze/main amd64 Packages
Hit http://ftp.uni-bayreuth.de squeeze/non-free amd64 Packages
Hit http://ftp.uni-bayreuth.de squeeze/contrib amd64 Packages

The following partially installed packages will be configured:
linux-image-2.6.32-5-amd64
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Setting up linux-image-2.6.32-5-amd64 (2.6.32-41squeeze2) ...
Running depmod.
Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.32-5-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.32-5-amd64 /boot/vmlinuz-2.6.32-5-amd64
run-parts: executing /etc/kernel/postinst.d/zz-lilo 2.6.32-5-amd64 /boot/vmlinuz-2.6.32-5-amd64
Warning: Not updating LILO; /etc/lilo.conf not found
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.32-5-amd64 /boot/vmlinuz-2.6.32-5-amd64
Generating grub.cfg ...
/usr/sbin/grub-probe: error: no such disk.
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-5-amd64.postinst line 799.
dpkg: error processing linux-image-2.6.32-5-amd64 (--configure):
subprocess installed post-installation script returned error exit status 2
configured to not write apport reports
Errors were encountered while processing:
linux-image-2.6.32-5-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up linux-image-2.6.32-5-amd64 (2.6.32-41squeeze2) ...
Running depmod.
Running update-initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.32-5-amd64
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8105e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168e-1.fw for module r8169
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.32-5-amd64 /boot/vmlinuz-2.6.32-5-amd64
run-parts: executing /etc/kernel/postinst.d/zz-lilo 2.6.32-5-amd64 /boot/vmlinuz-2.6.32-5-amd64
Warning: Not updating LILO; /etc/lilo.conf not found
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.32-5-amd64 /boot/vmlinuz-2.6.32-5-amd64
Generating grub.cfg ...
/usr/sbin/grub-probe: error: no such disk.
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-5-amd64.postinst line 799.
dpkg: error processing linux-image-2.6.32-5-amd64 (--configure):
subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
linux-image-2.6.32-5-amd64
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
13,696
435
83
seems you run an unsupported mix of packages - e.g. linux-image-2.6.32-5-amd64 is not part of a Proxmox VE system and obviously, the script does not know your customization.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!