proxmox und WLAN geht das?

saeft_3004

Member
Mar 4, 2019
43
1
8
32
Hallo,

Ich würde gerne proxmox auf einem NUC8I3BEK installieren. Leider gibt es kein LAN dort wo ich diesen aufstellen will.

Gibt es die Möglichkeit auch proxmox über WLAN zu betreiben? Falls ja gibt es dazu eine Anleitung?

Würde mich sehr freuen wenn ihr mir weiterhelfen könntet...
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,937
330
83
Hi

Gibt es die Möglichkeit auch proxmox über WLAN zu betreiben?
Ja das kann man machen.

Falls ja gibt es dazu eine Anleitung?
Nein gibt es nicht, da das im professionellen Umfeld nicht gebraucht wird.
Aber du kannst im Forum suchen, da gibt es mehrere Threads die das beschreiben.
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
Hi


Ja das kann man machen.


Nein gibt es nicht, da das im professionellen Umfeld nicht gebraucht wird.
Aber du kannst im Forum suchen, da gibt es mehrere Threads die das beschreiben.

Danke für deine Antwort. Das ist schon mal gut dass das geht.

Ich hab hier eine „offizielle“ Anleitung im wiki gefunden wo es um WLAN geht. Nur leider bin ich mir nicht ganz sicher ob es die richtige?! Weißt du das?

https://pve.proxmox.com/wiki/WLAN
 

sb-jw

Active Member
Jan 23, 2018
551
49
28
28
Nur leider bin ich mir nicht ganz sicher ob es die richtige?! Weißt du das?
Die sieht nicht falsch aus, muss aber auch nicht unbedingt noch funktionieren. Ich denke du solltest es einfach mal nach der Anleitung versuchen, mehr als nicht funktionieren kann es ja nicht ;)
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
Aber du kannst im Forum suchen, da gibt es mehrere Threads die das beschreiben.
Ich hab die Suchen Funktion genutzt und einiges zu wlan gefunden, aber nichts mit einer Anleitung oder ähnlichem.

Hast du noch ein Thread im Kopf wo das beschrieben wurde?
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
Die sieht nicht falsch aus, muss aber auch nicht unbedingt noch funktionieren. Ich denke du solltest es einfach mal nach der Anleitung versuchen, mehr als nicht funktionieren kann es ja nicht ;)
Da hast du recht, mal probieren werd ich es auf jeden Fall. Siehst du irgendwo ein Datum wie alt die Anleitung ist, weil du schreibst noch funktionieren?
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
@wolfgang @sb-jw

ich habe nun diese Anleitung versucht, es aber nicht hinbekommen und bräuchte eure Hilfe.
https://pve.proxmox.com/wiki/WLAN

Meine wichtigste Frage ist, was ist in meinem Fall der WLAN_NIC?

ip addr ergiebt folgendes:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master vmbr0 state UP group default qlen 1000
link/ether 1c:69:7a:02:61:91 brd ff:ff:ff:ff:ff:ff
3: wlp0s20f3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether d0:c6:37:cb:4a:12 brd ff:ff:ff:ff:ff:ff
4: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 1c:69:7a:02:61:91 brd ff:ff:ff:ff:ff:ff
inet 192.168.178.110/24 brd 192.168.178.255 scope global vmbr0
valid_lft forever preferred_lft forever
inet6 fe80::1e69:7aff:fe02:6191/64 scope link
valid_lft forever preferred_lft forever

eno1: ist die Netzwerkkarte diese lässt sich aber nicht mit ifdown abschalten
wlp0s20f3: weiß ich nur dass das irgendwas mit WLAN zu tun hat, aber ifdown geht hier auch nicht
vmbr0: mit dieser IP kann ich auf die Weboberfläche zugreifen, diese lässt sich auch mit ifdown ausschalten
 

Shusky

New Member
Feb 19, 2018
6
1
3
21
Munich, Germany
3: wlp0s20f3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether d0:c6:37:cb:4a:12 brd ff:ff:ff:ff:ff:ff
Das sollte die WLAN-Karte sein, die nun noch in der "/etc/network/interfaces" konfiguriert werden muss (sollte dann Methode 1 sein). Dann sollte man auch eine Verbindung mit dem WLAN-Netz aufbauen können: ifup wlp0s20f3

Damit am Ende auch alles über die WLAN-Karte läuft, müsste dann noch eine Änderung am Interface "vmbr0" vorgenommen werden:
iface vmbr0 inet dhcp
[...]
bridge-ports wlp0s20f3
bridge-stp off
bridge-fd 0

Durch diese Änderung wird "eno0" (LAN) nicht mehr verwendet, sondern nur noch "wlp0s20f3" (WLAN). Anschließend neu starten.
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
@Shusky

vielen Dank das du mir hilfst! ja die wlp0s20f3 ist die wlankarte. Diese hat sich auch schon ins WLAN eingelogt, aber leider sehe ich in der fritzbox keine ip. Wenn ich ifconfig eingebe wurde so wie es aussieht die 192.168.178.104 vergeben.

Ist die Änderung des interfaces so richtig? Den das habe ich so versucht und vmbr0 bekommt keine IP (siehe Bild im Anhang).


auto lo
iface lo inet loopback

iface eno1 inet manual

auto vmbr0
iface vmbr0 inet dhcp
bridge-ports wlp0s20f3
bridge-stp off
bridge-fd 0

auto wlp0s20f3
iface wlp0s20f3 inet dhcp
wpa-ssid Krip
wpa-psk c8e8378f
 

Attachments

Last edited:

Shusky

New Member
Feb 19, 2018
6
1
3
21
Munich, Germany
Eigentlich brauchst du der WLAN-Karte keine eigene IP geben, da Proxmox selbst ja die Bridge benutzt. Also ginge auch folgende Konfiguration:

auto lo
iface lo inet loopback

iface eno1 inet manual

auto vmbr0
iface vmbr0 inet dhcp
bridge-ports wlp0s20f3
bridge-stp off
bridge-fd 0

auto wlp0s20f3
iface wlp0s20f3 inet manual
wpa-ssid <SSID>
wpa-psk <PASSWORD>

Ansonsten passt alles soweit. Da du scheinbar noch nicht neu gestartet hast, wird aktuell noch die Bridge mit eno0 verwendet. Sobald du neu startest, sollte die Bridge mit der WLAN-Karte laufen. Wenn die IP-Konfiguration so bleibt, sollte Proxmox dann wahrscheinlich unter 192.168.178.104 erreichbar sein.
 

Shusky

New Member
Feb 19, 2018
6
1
3
21
Munich, Germany
Auf welche der Fehlermeldungen beziehst du dich denn? Die meisten davon können ignoriert werden, da die keinerlei Auswirkungen auf die tatsächliche Funktionalität haben.

Wie sieht denn jetzt die Ausgabe von ifconfig aus?
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
Fehler 81, 69 und 50. Da magst du recht haben, aber die kommen nur wenn ich das interface so eingebe wie du es beschrieben hast.

Bei ifconfig sieht man das nirgendwo eine IP vergeben wurde. Ein Ausschnitt kann ich erst morgen nachliefern...
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
@Shusky

Du hattest recht wenn mit der alten interfaces datei kommen die Fehler 81 69 und 50 auch. Aber „a start job is running for raise network interfaces“ kommt nur wenn ich interfaces so eingebe wie du sagst.

Das steht da ein paar min, dann kommt in rot ein error. Da muss ich heute Abend noch mal schauen was da dann genau steht...

Ich lese im inet immer wieder bei dhcp. Allow-hotplug wlp0s20f3. Kann das sein dass das noch fehlt?
 
Last edited:

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,937
330
83

saeft_3004

Member
Mar 4, 2019
43
1
8
32
@wolfgang

Danke für deine Hilfe! Ich habe jetzt versucht rauszufinden ob der monitore mode unterstützt wird oder nicht und habe diese Anleitung verwendet:

https://www.elektronik-kompendium.de/sites/net/2008051.htm

Ergebnis ist das der Monitore Mode unterstüzt wird und diesen habe ich jetzt aktiviert.

root@pve:~# iwconfig
lo no wireless extensions.
wlp0s20f3 IEEE 802.11 Mode:Monitor Frequency:2.412 GHz Tx-Power=20 dBm
Retry short limit:7 RTS thr:eek:ff Fragment thr:eek:ff
Power Management:eek:n
vmbr0 no wireless extensions.
eno1 no wireless extensions.


aber nach einem reboot steht bei mode wieder managed?

wlp0s20f3 IEEE 802.11 ESSID:"xxxxxxxxxxxxx"
Mode:Managed Frequency:5.18 GHz Access Point: E8:DF:70:79:DD:EB
Bit Rate=780 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:eek:ff Fragment thr:eek:ff
Encryption key:eek:ff
Power Management:eek:n
Link Quality=49/70 Signal level=-61 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:3 Missed beacon:0


Nach der Anleitung aus dem proxmox wiki, soll man die Route checken. Bei mir sieht die so aus leider weiß ich nicht ob die passt oder nicht?

https://pve.proxmox.com/wiki/WLAN

root@pve:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.178.1 0.0.0.0 UG 0 0 0 vmbr0
192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 vmbr0
192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 wlp0s20f3
 
Last edited:

saeft_3004

Member
Mar 4, 2019
43
1
8
32
@wolfgang @Shusky
letzter Stand von heute ist das die fritzbox eine wlan ip von proxmox hat die 192.168.178.104 über die ist die weboberfläche erreichbar und auch putty geht, aber nur wenn das Netzwerkkabel eingesteckt ist (LAN ip ist die 192.168.178.110), soblad ich das Netzwerkkabel rausziehe ist proxmox gar nicht mehr zu erreichen. Woran liegt das jetzt noch? Viel kann es nicht mehr sein...

Mein Interfaces sieht noch so aus, weil alles andere nicht funktioniert hat und laut der Anleitung ( https://pve.proxmox.com/wiki/WLAN ) muss man auch nicht mehr verändern.

auto lo
iface lo inet loopback

iface eno1 inet manual

auto vmbr0
iface vmbr0 inet static
address 192.168.178.110
netmask 255.255.255.0
gateway 192.168.178.1
bridge-ports eno1
bridge-stp off
bridge-fd 0


auto wlp0s20f3
iface wlp0s20f3 inet dhcp
wpa-ssid Krip..........
wpa-psk c8e837...................


Meine große Frage ist jetzt passt die Route oder nicht?

root@pve:~# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.178.1 0.0.0.0 UG 0 0 0 vmbr0
192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 vmbr0
192.168.178.0 0.0.0.0 255.255.255.0 U 0 0 0 wlp0s20f3
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,937
330
83
Du musst den bridge-port von eno1 auf none setzen.
Da sonst die VMBR den Status von der nic bekommt.
 

saeft_3004

Member
Mar 4, 2019
43
1
8
32
@wolfgang

Guten Morgen. Vielen Dank für den Tipp. Mache ich das so richtig?

auto lo
iface lo inet loopback

iface eno1 inet manual
bridge-ports none

auto vmbr0
iface vmbr0 inet static
address 192.168.178.110
netmask 255.255.255.0
gateway 192.168.178.1
bridge-ports eno1
bridge-stp off
bridge-fd 0


auto wlp0s20f3
iface wlp0s20f3 inet dhcp
wpa-ssid Krip..........
wpa-psk c8e837.................
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,937
330
83
Morgen.

Nein
PHP:
auto lo
iface lo inet loopback

iface eno1 inet manual

auto vmbr0
iface vmbr0 inet static
    address 192.168.178.110
    netmask 255.255.255.0
    gateway 192.168.178.1
    bridge-ports none
    bridge-stp off
    bridge-fd 0

auto wlp0s20f3
iface wlp0s20f3 inet dhcp
    wpa-ssid Krip..........
    wpa-psk c8e837.................
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!