proxmox spice - control video and audio compression

rafafell

Well-Known Member
Sep 24, 2016
60
2
48
36
Hello,

We use x2go and chrome remote desktop for VDI on the virtual machines that are on proxmox.

We recently started using spice to access webcam through weaker computers (dualcore processors) that don't support good quality video conferencing.


Everything is working perfectly (audio and image), but I believe there has been a high compression in the spice that causes a slight delay in sending video and audio.

The network has hardly any more significant use even with video sending.

How can I control compression? How do I deduce or disable compression in vm proxmox?

best
 
How can I control compression? How do I deduce or disable compression in vm proxmox?

At the moment, you can't directly.

What works is to copy all SPICE arguments of your current VM, disable all SPICE stuff in the GUI, append the previously copied string to the -args flag inside of your VM configuration and then have a look at the manpage of qemu, especially the options for the -spice option. There are several tweaks you can try.
 
Hello @LnxBil, thanks for the info!

could you tell me how

(1) copy all SPICE arguments of your current VM
(2) disable all SPICE stuff in the GUI (would be deselecting via GUI under "Hardware >> display >> spice" and "hardware >> USB >> spice" ??)

Would I have to include the line below in vm.conf?

args: -spice image-compression=off -spice jpeg-wan-compression=never -spice zlib-glz-wan-compression=never -spice streaming-video=off

#####
#####

my vm.conf

agent: 1
args: -device intel-hda,id=sound5,bus=pci.0,addr=0x18 -device hda-micro,id=sound5-codec0,bus=sound5.0,cad=0 -device hda-duplex,id=sound5-codec1,bus=sound5.0,cad=1
balloon: 0
boot: cdn
bootdisk: scsi0
cores: 12
hotplug: disk,network,usb
ide2: none,media=cdrom
memory: 22528
name: lantrivm01-tarefas
net0: e1000=C6:1D:88:59:12:F7,bridge=vmbr0
numa: 1
onboot: 1
ostype: l26
scsi1: zfs01:vm-100-disk-1,discard=on,size=870G,ssd=1
scsihw: virtio-scsi-pci
smbios1: uuid=50ed4069-97ff-41ed-ae3c-6d06ad2b68e2
sockets: 1
startup: up=25
usb0: spice
usb1: spice
usb2: spice
vga: qxl,memory=32
 
I added the line below in proxmox vm.config

args: -spice image-compression=off -spice jpeg-wan-compression=never -spice zlib-glz-wan-compression=never -spice streaming-video=off



But even with the firewall disabled the following occurs when trying to make a video conference.

The sending of sound and image outside the local network occurs perfectly (the person outside the local network sees and listens perfectly). But receiving the image and sound on the local network is bad.

So, sending the image and sound through the spice is very good! But receiving sound and image does not

The gigabit network has no bottlenecks. Client, guest, and proxmox server processors are also below 50%.

Any suggestions on what I might be doing wrong?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!