[SOLVED] Proxmox + Samba + OpenVPN + PFsense...

zigjack

Member
Sep 3, 2017
13
1
23
42
Hi there!

I am rather new in the proxmox/network world but rather willing to learn! :)
I have set up an infra at home and as a picture is worth thousands words, here is what it looks like:



Of course I am not the creator of this infra, I followed a long tuto on the web and everything worked fine (well... not at the first but attempt, but I finally did it :) )

My second step was to install Samba on the host itself, I followed all the instructions I gathered, I setup the smb.conf file, created the zfs share, allowed samba to access the share, created the user for samba even added the rule in the IPtables (though I am not sure it was needed as I want to access through the VPN...) and surely other things...

But when I am connected through OpenVPN, I can have access to my proxmox Dashboard through the 10.0.0.1 and PF Sense through 10.0.0.2, of course I can ping both, but when I try to connect the network drive \\10.0.0.1\DataServer it always end with the error code "0x80070035 Network path not found" whatever if I try with the W10 laptop or W7 tower... connecting with the samba user/pw of course...

Would you know by any chance what I missed? I haven't tweak anything on PFsense for that, but not sure it is needed as long as I am already connected through the OpenVPN...

So any input will be welcome! Thank you in advance! :)

Cheers!
 

mrE

Member
Apr 21, 2014
17
2
23
Of course I am not the creator of this infra, I followed a long tuto on the web and everything worked fine (well... not at the first but attempt, but I finally did it)
Hello, can you share that tutorial (link or how to)? I too want to create something like that; especially the pfsense + vpn. In my case I'm installing a VM for nethserver; as a domain controller with samba shares.
Regards!
 

zigjack

Member
Sep 3, 2017
13
1
23
42
For those who could face similar issue:
By some magic, when I created my share on the subfolders, the creation of the subfolder failed and just created one folder: DataServer_Share instead of DataServer/Share....
Connection works well with the right name... :oops:
 
Mar 25, 2014
14
0
21
Hi zigjack,

what tool did you use to draw the network scheme? I'm trying to make a similar infrastructure but giving a second public ip to the pfsense internet interface but I haven't found yet a solution
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!