Proxmox-Container mit Debian 11 (bullseye): winbind nachinstallieren?

Dec 19, 2012
478
14
83
Hallo.
Ich habe ein Problem mit einen LXC-Container, den ich aus den Proxmox-Templates aufgesetzt habe. Es handelt sich um das Template
Code:
debian-11-standard-11.6.1.
Innerhalb des Containers funktioniert ein normales apt update/upgrade wunderbar aber wenn ich versuche, das Paket winbind nachzuinstallieren, gibt es ein Problem:

Code:
 apt install winbind
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 winbind : Hängt ab von: samba-common-bin (= 2:4.13.13+dfsg-1~deb11u5) soll aber nicht installiert werden
           Hängt ab von: libwbclient0 (= 2:4.13.13+dfsg-1~deb11u5) aber 2:4.17.8+dfsg-1~bpo11+1 soll installiert werden
           Hängt ab von: samba-libs (= 2:4.13.13+dfsg-1~deb11u5) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Nun weiß ich nicht, ob das daran liegt, dass diese VM ein CT ist oder ob es ein Debian-Problem ist?!
Der CT läuft mit diesen Optionen:
Screenshot_20230617_093817.png
Hat jemand einen guten Tipp? Danke!
 
Hat leider nicht geholfen. Die Abhängigkeiten können nicht aufgelöst werden:

Code:
apt-get install acl attr samba winbind libpam-winbind libnss-winbind krb5-config krb5-user dnsutils python3-setproctitle
liefert:
Code:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libnss-winbind : Hängt ab von: libwbclient0 (= 2:4.13.13+dfsg-1~deb11u5) aber 2:4.17.8+dfsg-1~bpo11+1 soll installiert werden
 libpam-winbind : Hängt ab von: libwbclient0 (= 2:4.13.13+dfsg-1~deb11u5) aber 2:4.17.8+dfsg-1~bpo11+1 soll installiert werden
 samba : Hängt ab von: python3-samba soll aber nicht installiert werden
         Hängt ab von: samba-common-bin (= 2:4.13.13+dfsg-1~deb11u5) soll aber nicht installiert werden
         Hängt ab von: libwbclient0 (= 2:4.13.13+dfsg-1~deb11u5) aber 2:4.17.8+dfsg-1~bpo11+1 soll installiert werden
         Hängt ab von: samba-libs (= 2:4.13.13+dfsg-1~deb11u5) soll aber nicht installiert werden
         Empfiehlt: python3-markdown soll aber nicht installiert werden
         Empfiehlt: samba-dsdb-modules soll aber nicht installiert werden
         Empfiehlt: samba-vfs-modules soll aber nicht installiert werden
 winbind : Hängt ab von: samba-common-bin (= 2:4.13.13+dfsg-1~deb11u5) soll aber nicht installiert werden
           Hängt ab von: libwbclient0 (= 2:4.13.13+dfsg-1~deb11u5) aber 2:4.17.8+dfsg-1~bpo11+1 soll installiert werden
           Hängt ab von: samba-libs (= 2:4.13.13+dfsg-1~deb11u5) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Ich habe diese Quellen aktiviert:
Code:
[root@freeradius-server:/etc/apt]$ cat /etc/apt/sources.list
deb http://deb.debian.org/debian bullseye main contrib non-free
deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb http://security.debian.org bullseye-security main contrib non-free
deb http://deb.debian.org/debian bullseye-backports main contrib non-free

Was ich etwas merkwürdig finde: wenn ich das hier ausführe:
Code:
 apt search winbind
erhalte ich diese Ausgabe:
Code:
samba/oldstable,oldstable-security 2:4.13.13+dfsg-1~deb11u5 amd64
  SMB/CIFS-Datei-, Druck- und Anmeldeserver für Unix

winbind/oldstable,oldstable-security 2:4.13.13+dfsg-1~deb11u5 amd64
  Service zum Auflösen von Benutzer-/Gruppeninformation über NT-Server

Ist das mit dem "oldstable" normal??? Oder steckt da irgendwo der Fehler? Bin leider weiterhin nicht sicher, ob eine "richtige VM" das anders machen würde!?
 
Last edited:
deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free

deb http://deb.debian.org/debian bullseye-updates main contrib non-free
deb-src http://deb.debian.org/debian bullseye-updates main contrib non-free

deb http://deb.debian.org/debian bullseye-backports main contrib non-free
deb-src http://deb.debian.org/debian bullseye-backports main contrib non-free

deb http://security.debian.org/debian-security/ bullseye-security main contrib non-free
deb-src http://security.debian.org/debian-security/ bullseye-security main contrib non-free

Das sind die aktuellen Sourcen. Füge zumindest die BACKPORTS ein.
 
Daran, dass es ein Container ist, liegt's nicht. Ich hab mal auf die Schnelle einen Debian 11 Container aufgesetzt und konnte dort ohne Probleme Winbind installieren.
Bash:
root@dummyCT2:/etc/apt# apt install winbind
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  dirmngr gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm libassuan0
  libavahi-client3 libavahi-common-data libavahi-common3 libcups2 libgpgme11 libksba8 libldb2 libnpth0 libpython3.9
  libtalloc2 libtdb1 libtevent0 libwbclient0 pinentry-curses python3-gpg python3-ldb python3-samba python3-talloc
  python3-tdb samba-common samba-common-bin samba-dsdb-modules samba-libs
Suggested packages:
  dbus-user-session pinentry-gnome3 tor parcimonie xloadimage scdaemon cups-common pinentry-doc heimdal-clients
  python3-markdown python3-dnspython libnss-winbind libpam-winbind
The following NEW packages will be installed:
  dirmngr gnupg gnupg-l10n gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm libassuan0
  libavahi-client3 libavahi-common-data libavahi-common3 libcups2 libgpgme11 libksba8 libldb2 libnpth0 libpython3.9
  libtalloc2 libtdb1 libtevent0 libwbclient0 pinentry-curses python3-gpg python3-ldb python3-samba python3-talloc
  python3-tdb samba-common samba-common-bin samba-dsdb-modules samba-libs winbind
0 upgraded, 35 newly installed, 0 to remove and 0 not upgraded.
Need to get 21.5 MB of archives.
After this operation, 79.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.at.debian.org/debian bullseye/main amd64 libtalloc2 amd64 2.3.1-2+b1 [29.3 kB]
Get:2 http://ftp.at.debian.org/debian bullseye/main amd64 libtevent0 amd64 0.10.2-1 [37.1 kB]
Get:3 http://ftp.at.debian.org/debian bullseye/main amd64 libwbclient0 amd64 2:4.13.13+dfsg-1~deb11u5 [313 kB]
Get:4 http://ftp.at.debian.org/debian bullseye/main amd64 samba-common all 2:4.13.13+dfsg-1~deb11u5 [171 kB]
Get:5 http://ftp.at.debian.org/debian bullseye/main amd64 libtdb1 amd64 1.4.3-1+b1 [49.9 kB]
Get:6 http://ftp.at.debian.org/debian bullseye/main amd64 libldb2 amd64 2:2.2.3-2~deb11u2 [148 kB]
Get:7 http://ftp.at.debian.org/debian bullseye/main amd64 libpython3.9 amd64 3.9.2-1 [1,691 kB]
Get:8 http://ftp.at.debian.org/debian bullseye/main amd64 python3-ldb amd64 2:2.2.3-2~deb11u2 [46.4 kB]
Get:9 http://ftp.at.debian.org/debian bullseye/main amd64 python3-tdb amd64 1.4.3-1+b1 [20.6 kB]
Get:10 http://ftp.at.debian.org/debian bullseye/main amd64 libavahi-common-data amd64 0.8-5+deb11u2 [124 kB]
Setting up dirmngr (2.2.27-2+deb11u2) ...
Created symlink /etc/systemd/user/sockets.target.wants/dirmngr.socket → /usr/lib/systemd/user/dirmngr.socket.
Setting up python3-gpg (1.14.0-1+b2) ...
Setting up python3-ldb (2:2.2.3-2~deb11u2) ...
Setting up gpg-wks-server (2.2.27-2+deb11u2) ...
Setting up libavahi-client3:amd64 (0.8-5+deb11u2) ...
Setting up gpg-wks-client (2.2.27-2+deb11u2) ...
Setting up libcups2:amd64 (2.3.3op2-3+deb11u2) ...
Setting up gnupg (2.2.27-2+deb11u2) ...
Setting up samba-libs:amd64 (2:4.13.13+dfsg-1~deb11u5) ...
Setting up samba-dsdb-modules:amd64 (2:4.13.13+dfsg-1~deb11u5) ...
Setting up python3-samba (2:4.13.13+dfsg-1~deb11u5) ...
Setting up samba-common-bin (2:4.13.13+dfsg-1~deb11u5) ...
Checking smb.conf with testparm
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Weak crypto is allowed
Server role: ROLE_STANDALONE

Done
Setting up winbind (2:4.13.13+dfsg-1~deb11u5) ...
mkdir: created directory '/var/lib/samba/winbindd_privileged'
changed group of '/var/lib/samba/winbindd_privileged' from root to winbindd_priv
mode of '/var/lib/samba/winbindd_privileged' changed from 0755 (rwxr-xr-x) to 0750 (rwxr-x---)
Created symlink /etc/systemd/system/multi-user.target.wants/winbind.service → /lib/systemd/system/winbind.service.
Processing triggers for libc-bin (2.31-13+deb11u6) ...
Processing triggers for man-db (2.9.4-2) ...
root@dummyCT2:/etc/apt#
 
Last edited:
Verstehe ich nicht ... ich habe die sources.list wie oben angepasst und alles nochmal versucht -- und es bleibt dabei. Kann das wieder irgendwas mit "privilegierter" / "unprivilegierter Container" sein??
 
mein Test-Container war unprivilegiert.
Wenn ich's richtig sehe, hast Du einen privilegierten - gibt's dafür Gründe?
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!