proxmox adds localhost ipv6 entries to /etc/hosts inside the containers

Discussion in 'Proxmox VE: Networking and Firewall' started by eth, Oct 9, 2018.

  1. eth

    eth Member

    Joined:
    Feb 24, 2016
    Messages:
    50
    Likes Received:
    1
    I've just noticed that after rebooting a proxmox server, there are new lines added to /etc/hosts inside Centos containers. They look like this:

    ::1 localhost​

    This is undesirable, since my containers have no ipv6 support (and I don't need them to have it).

    How can I disable this?
     
  2. Klaus Steinberger

    Klaus Steinberger Active Member
    Proxmox VE Subscriber

    Joined:
    Jan 16, 2018
    Messages:
    161
    Likes Received:
    26
    There is no need to disable this. There is no harm by this entry
     
  3. eth

    eth Member

    Joined:
    Feb 24, 2016
    Messages:
    50
    Likes Received:
    1
    For some reason it breaks my nginx - php-fpm connection. I get tonns of "Cannot connect to ::1" errors in my nginx logs (probably due to it looking up localhost through /etc/hosts)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice