proxmox 7.1, unable to access render128 in lxc with vainfo

Jul 28, 2017
140
2
38
So i've followed guides
https://forum.proxmox.com/threads/a...pu-pass-thru-to-windows-10-guest.84849/page-3
https://emby.media/community/index.php?/topic/49680-howto-vaapi-transcoding-inside-lxc-container/

and runinng vainfo on the host shows the list of "Supported profile and entrypoints" however running vainfo in a container just gives me
error: XDG_RUNTIME_DIR not set in the environment.
error: can't connect to X server!
error: failed to initialize display

following the guide on my 6.4 allows me to access it fine in a container, any one got any hints ?
 
Jul 28, 2017
140
2
38
Got a little further, seems jellyfin guide had an update to include proxmox.

https://jellyfin.org/docs/general/administration/hardware-acceleration.html#lxc-container-on-proxmox

Now getting what i think are DRM or power issues.

Code:
 [4287.669230] amdgpu 0000:07:00.0: amdgpu: [mmhub0] retry page fault (src_id:0 ring:0 vmid:1 pasid:32769, for process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922)
[ 4287.669737] amdgpu 0000:07:00.0: amdgpu:   in page starting at address 0x0000800124df4000 from IH client 0x12 (VMC)
[ 4287.670241] amdgpu 0000:07:00.0: amdgpu: VM_L2_PROTECTION_FAULT_STATUS:0x00143851
[ 4287.670683] amdgpu 0000:07:00.0: amdgpu:      Faulty UTCL2 client ID: VCN (0x1c)
[ 4287.671024] amdgpu 0000:07:00.0: amdgpu:      MORE_FAULTS: 0x1
[ 4287.671376] amdgpu 0000:07:00.0: amdgpu:      WALKER_ERROR: 0x0
[ 4287.671741] amdgpu 0000:07:00.0: amdgpu:      PERMISSION_FAULTS: 0x5
[ 4287.672083] amdgpu 0000:07:00.0: amdgpu:      MAPPING_ERROR: 0x0
[ 4287.672400] amdgpu 0000:07:00.0: amdgpu:      RW: 0x1
[ 4287.672719] amdgpu 0000:07:00.0: amdgpu: [mmhub0] retry page fault (src_id:0 ring:0 vmid:1 pasid:32769, for process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922)
[ 4287.673057] amdgpu 0000:07:00.0: amdgpu:   in page starting at address 0x0000800124df5000 from IH client 0x12 (VMC)
[ 4287.673395] amdgpu 0000:07:00.0: amdgpu: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
[ 4287.673732] amdgpu 0000:07:00.0: amdgpu:      Faulty UTCL2 client ID: MP1 (0x0)
[ 4287.674063] amdgpu 0000:07:00.0: amdgpu:      MORE_FAULTS: 0x0
[ 4287.674385] amdgpu 0000:07:00.0: amdgpu:      WALKER_ERROR: 0x0
[ 4287.674708] amdgpu 0000:07:00.0: amdgpu:      PERMISSION_FAULTS: 0x0
[ 4287.675023] amdgpu 0000:07:00.0: amdgpu:      MAPPING_ERROR: 0x0
[ 4287.675349] amdgpu 0000:07:00.0: amdgpu:      RW: 0x0
[ 4287.675675] amdgpu 0000:07:00.0: amdgpu: [mmhub0] retry page fault (src_id:0 ring:0 vmid:1 pasid:32769, for process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922)
[ 4287.676013] amdgpu 0000:07:00.0: amdgpu:   in page starting at address 0x0000800124df6000 from IH client 0x12 (VMC)
[ 4287.676352] amdgpu 0000:07:00.0: amdgpu: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
[ 4287.676687] amdgpu 0000:07:00.0: amdgpu:      Faulty UTCL2 client ID: MP1 (0x0)
[ 4287.677022] amdgpu 0000:07:00.0: amdgpu:      MORE_FAULTS: 0x0
[ 4287.677356] amdgpu 0000:07:00.0: amdgpu:      WALKER_ERROR: 0x0
[ 4287.677689] amdgpu 0000:07:00.0: amdgpu:      PERMISSION_FAULTS: 0x0
[ 4287.678021] amdgpu 0000:07:00.0: amdgpu:      MAPPING_ERROR: 0x0
[ 4287.678353] amdgpu 0000:07:00.0: amdgpu:      RW: 0x0
[ 4287.678686] amdgpu 0000:07:00.0: amdgpu: [mmhub0] retry page fault (src_id:0 ring:0 vmid:1 pasid:32769, for process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922)
[ 4287.679042] amdgpu 0000:07:00.0: amdgpu:   in page starting at address 0x0000800124df7000 from IH client 0x12 (VMC)
[ 4287.679411] amdgpu 0000:07:00.0: amdgpu: VM_L2_PROTECTION_FAULT_STATUS:0x00000000
[ 4287.679823] amdgpu 0000:07:00.0: amdgpu:      Faulty UTCL2 client ID: MP1 (0x0)
[ 4287.680184] amdgpu 0000:07:00.0: amdgpu:      MORE_FAULTS: 0x0
[ 4287.680538] amdgpu 0000:07:00.0: amdgpu:      WALKER_ERROR: 0x0
[ 4287.680890] amdgpu 0000:07:00.0: amdgpu:      PERMISSION_FAULTS: 0x0
[ 4287.681243] amdgpu 0000:07:00.0: amdgpu:      MAPPING_ERROR: 0x0
[ 4287.681591] amdgpu 0000:07:00.0: amdgpu:      RW: 0x0
[ 4297.709401] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring vcn_enc0 timeout, signaled seq=6, emitted seq=7
[ 4297.710112] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922
[ 4297.710703] amdgpu 0000:07:00.0: amdgpu: GPU reset begin!
[ 4297.950262] [drm] Register(0) [mmUVD_POWER_STATUS] failed to reach value 0x00000001 != 0x00000002
[ 4298.138389] [drm] Register(0) [mmUVD_RB_RPTR] failed to reach value 0x000000c0 != 0x00000080
[ 4298.323931] [drm] Register(0) [mmUVD_RBC_RB_RPTR] failed to reach value 0x00000200 != 0x000001a0
[ 4298.509425] [drm] Register(0) [mmUVD_POWER_STATUS] failed to reach value 0x00000001 != 0x00000002
[ 4298.519358] [drm] free PSP TMR buffer
[ 4298.547147] amdgpu 0000:07:00.0: amdgpu: MODE2 reset
[ 4298.547381] amdgpu 0000:07:00.0: amdgpu: GPU reset succeeded, trying to resume
[ 4298.547491] [drm] PCIE GART of 1024M enabled.
[ 4298.547494] [drm] PTB located at 0x000000F400900000
[ 4298.547650] [drm] PSP is resuming...
[ 4298.567383] [drm] reserve 0x400000 from 0xf47f800000 for PSP TMR
[ 4298.840845] amdgpu 0000:07:00.0: amdgpu: RAS: optional ras ta ucode is not available
[ 4298.849020] amdgpu 0000:07:00.0: amdgpu: RAP: optional rap ta ucode is not available
[ 4298.849024] amdgpu 0000:07:00.0: amdgpu: SECUREDISPLAY: securedisplay ta ucode is not available
[ 4298.849027] amdgpu 0000:07:00.0: amdgpu: SMU is resuming...
[ 4298.849238] amdgpu 0000:07:00.0: amdgpu: SMU is resumed successfully!
[ 4299.036736] [drm] kiq ring mec 2 pipe 1 q 0
[ 4299.038187] [drm] DMUB hardware initialized: version=0x0101001C
[ 4299.290790] amdgpu 0000:07:00.0: [drm:amdgpu_ring_test_helper [amdgpu]] *ERROR* ring vcn_enc0 test failed (-110)
[ 4299.290866] [drm:amdgpu_device_ip_resume_phase2 [amdgpu]] *ERROR* resume of IP block <vcn_v2_0> failed -110
[ 4299.290938] amdgpu 0000:07:00.0: amdgpu: GPU reset(1) failed
[ 4299.290987] amdgpu 0000:07:00.0: amdgpu: GPU reset end with ret = -110
[ 4309.404136] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring vcn_enc0 timeout, signaled seq=6, emitted seq=7
[ 4309.404271] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922
[ 4309.404384] amdgpu 0000:07:00.0: amdgpu: GPU reset begin!
 
Last edited:

paulmorabi

Member
Mar 30, 2019
75
8
13
42
@James Crook you replied to my post on Reddit regarding this issue. The thread you refer to above is useful. In my case, I can pass through the iGPU and it works for another container (frigate) but is still dying on Jellyfin. I’ve got an issue open with jellyfin and also the mesa team (see link in Jellyfin issue).

What jellyfin container image are using? I am using linuserver.io with the AMD mod. I did page faults similar to yours but after an update at some point in the last 4-5 months now only get an error (see this). The docs you link to on the jellyfin site are related to intel iGPU and nvidia pass-through though the process is similar.
 
Jul 28, 2017
140
2
38
@James Crook you replied to my post on Reddit regarding this issue. The thread you refer to above is useful. In my case, I can pass through the iGPU and it works for another container (frigate) but is still dying on Jellyfin. I’ve got an issue open with jellyfin and also the mesa team (see link in Jellyfin issue).

What jellyfin container image are using? I am using linuserver.io with the AMD mod. I did page faults similar to yours but after an update at some point in the last 4-5 months now only get an error (see this). The docs you link to on the jellyfin site are related to intel iGPU and nvidia pass-through though the process is similar.
So I'm using a plain debain container and then installing jellyfin.
I get the same errors if I run jellyfin on the host.
I'm just using the mesa-va drivers, might try the proper amd drivers.
 

paulmorabi

Member
Mar 30, 2019
75
8
13
42
So I'm using a plain debain container and then installing jellyfin.
I get the same errors if I run jellyfin on the host.
I'm just using the mesa-va drivers, might try the proper amd drivers.
Let me know how you go with that. Also did you try with a container other than Jellyfin? Because it works for me with frigate.
 

paulmorabi

Member
Mar 30, 2019
75
8
13
42
I tried Ubuntu 18.04 and 21.04 but I couldn't get them to see the hardware (I think cause the mesa was different between host and the container)
I suspected similar but in my case, it didn’t make a difference that I could see. The hardware is being passed through to the container so the mesa libraries in the container should be accessing it directly rather than via the host. I guess its possible the host‘s kernel/mesa is doing something to put the iGPU in a particular state that then makes the pass through misbehave but I never was able to identify any effect/impact.
 
Jul 28, 2017
140
2
38
just tested locking the GPU to 1000Mhz in the BIOS (Asus motherboard), same crash.

Was along shot that the changing of powerstate/speed was causing an issue.
Blown away the host and will try a container with mesa and host with no mesa.
 
Jul 28, 2017
140
2
38
with our mesa on the host i still get the same crash.

Ubuntu 20.04
vainfo: VA-API version: 1.7 (libva 2.6.0)
vainfo: Driver version: Mesa Gallium driver 21.0.3 for AMD RENOIR (DRM 3.41.0, 5.13.19-2-pve, LLVM 12.0.0)
vainfo: Supported profile and entrypoints

Ubunti 21.10
vainfo: VA-API version: 1.12 (libva 2.10.0)
vainfo: Driver version: Mesa Gallium driver 21.2.2 for AMD RENOIR (DRM 3.41.0, 5.13.19-2-pve, LLVM 12.0.1)
vainfo: Supported profile and entrypoints


Gonna install a few other linux distros (desktop and server) to see if they give the same errors.

The board/server is not yet running anything so i can keep testing for a bit longer.
 

paulmorabi

Member
Mar 30, 2019
75
8
13
42
with our mesa on the host i still get the same crash.

Ubuntu 20.04
vainfo: VA-API version: 1.7 (libva 2.6.0)
vainfo: Driver version: Mesa Gallium driver 21.0.3 for AMD RENOIR (DRM 3.41.0, 5.13.19-2-pve, LLVM 12.0.0)
vainfo: Supported profile and entrypoints

Ubunti 21.10
vainfo: VA-API version: 1.12 (libva 2.10.0)
vainfo: Driver version: Mesa Gallium driver 21.2.2 for AMD RENOIR (DRM 3.41.0, 5.13.19-2-pve, LLVM 12.0.1)
vainfo: Supported profile and entrypoints


Gonna install a few other linux distros (desktop and server) to see if they give the same errors.

The board/server is not yet running anything so i can keep testing for a bit longer.
Have you tried to get another app/container working with the passed through GPU? I managed to get it working with frigate so i know its something specific to jellyfin and/or the libraries in the container. Failing that, you could also install docker on the host and try that way. The latter is not ideal but it would be worth validating you can get the pass through working for something or in some way and then trying to do in the your most preferred way.
 
Jul 28, 2017
140
2
38
Have you tried to get another app/container working with the passed through GPU? I managed to get it working with frigate so i know its something specific to jellyfin and/or the libraries in the container. Failing that, you could also install docker on the host and try that way. The latter is not ideal but it would be worth validating you can get the pass through working for something or in some way and then trying to do in the your most preferred way.
That's a good point, think I got to focused on jellyfin.
Just installed normal Ubuntu, same errors.
I'll try again tomorrow with something else (or different ffmpeg)

Just tried the same files with MPV with -hwdec no crash. Now really time to stop
 
Last edited:
Jul 28, 2017
140
2
38
tried
/usr/lib/jellyfin-ffmpeg/ffmpeg
ffmpeg version 4.4.1-Jellyfin Copyright (c) 2000-2021 the FFmpeg developers
built with gcc 11 (Ubuntu 11.2.0-7ubuntu2)

Causes the kernel error

and
/usr/bin/ffmpeg
ffmpeg version 4.4-6ubuntu5 Copyright (c) 2000-2021 the FFmpeg developers
built with gcc 11 (Ubuntu 11.2.0-7ubuntu1)


Exits with
Code:
/videos/740c119c-113c-6ca0-ac66-72ded6894402/hls1/main/7.ts

{"Protocol":0,"Id":"740c119c113c6ca0ac6672ded6894402","Path":"/DEMO/jellyfish-400-mbps-4k-uhd-hevc-10bit.mkv","EncoderPath":null,"EncoderProtocol":null,"Type":0,"Container":"mkv,webm","Size":1504953088,"Name":"jellyfish-400-mbps-4k-uhd-hevc-10bit","IsRemote":false,"ETag":"1c24acd353b3d7dd19523ec9b20ed7c4","RunTimeTicks":300969984,"ReadAtNativeFramerate":false,"IgnoreDts":false,"IgnoreIndex":false,"GenPtsInput":false,"SupportsTranscoding":true,"SupportsDirectStream":true,"SupportsDirectPlay":true,"IsInfiniteStream":false,"RequiresOpening":false,"OpenToken":null,"RequiresClosing":false,"LiveStreamId":null,"BufferMs":null,"RequiresLooping":false,"SupportsProbing":true,"VideoType":0,"IsoType":null,"Video3DFormat":null,"MediaStreams":[{"Codec":"hevc","CodecTag":null,"Language":"und","ColorRange":null,"ColorSpace":null,"ColorTransfer":null,"ColorPrimaries":null,"Comment":null,"TimeBase":"1/1000","CodecTimeBase":null,"Title":null,"VideoRange":"SDR","localizedUndefined":null,"localizedDefault":null,"localizedForced":null,"DisplayTitle":"4K HEVC SDR","NalLengthSize":null,"IsInterlaced":false,"IsAVC":null,"ChannelLayout":null,"BitRate":400027418,"BitDepth":null,"RefFrames":1,"PacketLength":null,"Channels":null,"SampleRate":null,"IsDefault":true,"IsForced":false,"Height":2160,"Width":3840,"AverageFrameRate":29.97,"RealFrameRate":29.97,"Profile":"Main 10","Type":1,"AspectRatio":"16:9","Index":0,"Score":null,"IsExternal":false,"DeliveryMethod":null,"DeliveryUrl":null,"IsExternalUrl":null,"IsTextSubtitleStream":false,"SupportsExternalStream":false,"Path":null,"PixelFormat":"yuv420p10le","Level":183,"IsAnamorphic":null}],"MediaAttachments":[],"Formats":[],"Bitrate":400027418,"Timestamp":null,"RequiredHttpHeaders":{},"TranscodingUrl":null,"TranscodingSubProtocol":null,"TranscodingContainer":null,"AnalyzeDurationMs":null,"DefaultAudioStreamIndex":null,"DefaultSubtitleStreamIndex":null}

/usr/bin/ffmpeg -ss 00:00:21.000 -hwaccel vaapi -noaccurate_seek -hwaccel_output_format vaapi -vaapi_device /dev/dri/renderD128 -i file:"/DEMO/jellyfish-400-mbps-4k-uhd-hevc-10bit.mkv" -map_metadata -1 -map_chapters -1 -threads 0 -map 0:0 -map -0:a -map -0:s -codec:v:0 h264_vaapi -b:v 139808000 -maxrate 139808000 -bufsize 279616000 -profile:v:0 high -level 41  -force_key_frames:0 "expr:gte(t,21+n_forced*3)" -vf "format=nv12|vaapi,hwupload,scale_vaapi=format=nv12" -start_at_zero -vsync -1  -copyts -avoid_negative_ts disabled -max_muxing_queue_size 2048 -f hls -max_delay 5000000 -hls_time 3 -hls_segment_type mpegts -start_number 7 -hls_segment_filename "/var/lib/jellyfin/transcodes/2c4301eb4e3a5595901255883ace826a%d.ts" -hls_playlist_type vod -hls_list_size 0 -y "/var/lib/jellyfin/transcodes/2c4301eb4e3a5595901255883ace826a.m3u8"


ffmpeg version 4.4-6ubuntu5 Copyright (c) 2000-2021 the FFmpeg developers
  built with gcc 11 (Ubuntu 11.2.0-7ubuntu1)
  configuration: --prefix=/usr --extra-version=6ubuntu5 --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --arch=amd64 --enable-gpl --disable-stripping --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libdav1d --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librabbitmq --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libsrt --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzimg --enable-libzmq --enable-libzvbi --enable-lv2 --enable-omx --enable-openal --enable-opencl --enable-opengl --enable-sdl2 --enable-pocketsphinx --enable-librsvg --enable-libmfx --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-nvenc --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared
  libavutil      56. 70.100 / 56. 70.100
  libavcodec     58.134.100 / 58.134.100
  libavformat    58. 76.100 / 58. 76.100
  libavdevice    58. 13.100 / 58. 13.100
  libavfilter     7.110.100 /  7.110.100
  libswscale      5.  9.100 /  5.  9.100
  libswresample   3.  9.100 /  3.  9.100
  libpostproc    55.  9.100 / 55.  9.100
Input #0, matroska,webm, from 'file:/DEMO/jellyfish-400-mbps-4k-uhd-hevc-10bit.mkv':
  Metadata:
    COMPATIBLE_BRANDS: iso4hvc1iso6
    MAJOR_BRAND     : iso4
    MINOR_VERSION   : 1
    ENCODER         : Lavf56.3.100
  Duration: 00:00:30.10, start: 0.067000, bitrate: 400027 kb/s
  Stream #0:0(und): Video: hevc (Main 10), yuv420p10le(tv), 3840x2160 [SAR 1:1 DAR 16:9], 29.97 fps, 29.97 tbr, 1k tbn, 29.97 tbc (default)
    Metadata:
      CREATION_TIME   : 2016-02-05 16:11:30
      LANGUAGE        : und
      HANDLER_NAME    : hevc@GPAC0.5.2-DEV-rev565-g71748d7-ab-suite
Stream mapping:
  Stream #0:0 -> #0:0 (hevc (native) -> h264 (h264_vaapi))
Press [q] to stop, [?] for help
[h264_vaapi @ 0x557fae032a40] Driver does not support some wanted packed headers (wanted 0xd, found 0x1).
Output #0, hls, to '/var/lib/jellyfin/transcodes/2c4301eb4e3a5595901255883ace826a.m3u8':
  Metadata:
    encoder         : Lavf58.76.100
  Stream #0:0: Video: h264 (High), vaapi_vld(tv, progressive), 3840x2160 [SAR 1:1 DAR 16:9], q=2-31, 139808 kb/s, 29.97 fps, 90k tbn (default)
    Metadata:
      encoder         : Lavc58.134.100 h264_vaapi
[mpegts @ 0x557fae474e80] H.264 bitstream malformed, no startcode found, use the video bitstream filter 'h264_mp4toannexb' to fix it ('-bsf:v h264_mp4toannexb' option with ffmpeg)
av_interleaved_write_frame(): Invalid data found when processing input
frame=    1 fps=0.0 q=-0.0 size=N/A time=00:00:00.00 bitrate=N/A speed=   0x   
[hls @ 0x557fae054840] Opening '/var/lib/jellyfin/transcodes/2c4301eb4e3a5595901255883ace826a7.ts' for writing
frame=    1 fps=0.0 q=-0.0 Lsize=N/A time=00:00:00.00 bitrate=N/A speed=   0x   
video:892kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown
Conversion failed!
 
Last edited:

paulmorabi

Member
Mar 30, 2019
75
8
13
42
So i changed back to jellyfin ffmpeg, and it's now working ! (tho only on my test desktop Ubuntu....)
This is crazy.

Maybe you’re onto something with this. Did you use Ubuntu via container or VM?

I’m not surprised different versions of ffmpeg would give different results as they are all complied/built with different options and support library versions. However, if it doesn’t work and then works, it’s very odd.

Does vainfo work and show the encoding/decoding capabilities for your iGPU?

which container image did you use for Jellyfin?
 
Jul 28, 2017
140
2
38
So it worked without crashing yesterday with my testing.
Started testing today, and after 3 tests i got the
[ 4297.709401] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring vcn_enc0 timeout, signaled seq=6, emitted seq=7 [ 4297.710112] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922

O well.
 

paulmorabi

Member
Mar 30, 2019
75
8
13
42
So it worked without crashing yesterday with my testing.
Started testing today, and after 3 tests i got the
[ 4297.709401] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring vcn_enc0 timeout, signaled seq=6, emitted seq=7 [ 4297.710112] [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process ffmpeg pid 47921 thread ffmpeg:cs0 pid 47922

O well.

What jellyfin container image are you using? Via docker or lxc/d? What CPU/iGPU are you using? Did the crashing happen transcoding the same files as the day previously when it worked? (it wouldn’t be unheard of for transcoding to fail on some codecs/nitrates and work on others).
 
Jul 28, 2017
140
2
38
What jellyfin container image are you using? Via docker or lxc/d? What CPU/iGPU are you using? Did the crashing happen transcoding the same files as the day previously when it worked? (it wouldn’t be unheard of for transcoding to fail on some codecs/nitrates and work on others).
I've tried the Ubuntu and Debian stable packages.
Lxc.
So the crashs seems to randomly happen, there is a HDR 10bit file I can get it to always crash on, but it also randomly happens to h264 and h265.
 

paulmorabi

Member
Mar 30, 2019
75
8
13
42
I've tried the Ubuntu and Debian stable packages.
Lxc.
So the crashs seems to randomly happen, there is a HDR 10bit file I can get it to always crash on, but it also randomly happens to h264 and h265.

so you’re using an image of the full distro with Xorg? Or using the base OS image and then jellyfin via container or running ffmpeg directly?

What is your CPU?

Have you tried the latest mesa from here? These don’t work for me but they also don’t crash the system or cause errors in dmesg.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!