Proxmox 7.1 downgrading kernel

kitkat

New Member
Feb 9, 2022
10
0
1
48
Hi All,

new here, first post and new to proxmox. I'm currently looking at moving my EVE-NG infrstructure to proxmox. The server specs are:
Dell R620, 2x E5-2640v2, 128Gb RAM.
I have a small instance of Proxmox 7.1 (running on a QOTOM miniPC) which i used to learn proxmox 7.1 and works really good.

My question is downgrading the Kernel on proxmox. I gave read that EVE-NG Pro can run on proxmox but anyone trying to make it work on 7.1 kernel 5.13 failed with different issues. Some have stated that downgrading to kernel 5.11 works fine.

So my question is how do I downgrade to kernel 5.11?

Thanks
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
677
118
hi,

So my question is how do I downgrade to kernel 5.11?
make sure the package version is installed, then you can edit your bootloader configuration to select the kernel you like. here are some instructions from another thread where this was asked too [0]

and check our wiki too [1]

TLDR: if using GRUB bootloader, you need to edit GRUB_DEFAULT in /etc/default/grub and do an update-grub machen. with systemd-boot just use proxmox-boot-tool as described on our wiki

[0]: https://forum.proxmox.com/threads/a...-passthrough-locks-system.103318/#post-449681
[1]: https://pve.proxmox.com/wiki/Host_Bootloader
 
Last edited:

kitkat

New Member
Feb 9, 2022
10
0
1
48
So I installed the latest 5.11 by doing this:
Code:
apt install pve-kernel-5.11.22-7-pve

then, this is my grub config:
Code:
if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
  menuentry_id_option=""
export menuentry_id_option
menuentry 'Proxmox VE GNU/Linux' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
submenu 'Advanced options for Proxmox VE GNU/Linux' $menuentry_id_option 'gnulinux-advanced-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-4-pve' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-4-pve-advanced-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-4-pve (recovery mode)' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-4-pve-recovery-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-2-pve' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-2-pve-advanced-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-2-pve (recovery mode)' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-2-pve-recovery-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.11.22-7-pve' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.11.22-7-pve-advanced-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.11.22-7-pve (recovery mode)' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.11.22-7-pve-recovery-bd2e0821-2f22-490d-8d64-56a489cbb71d' {
menuentry "Memory test (memtest86+)" {
menuentry "Memory test (memtest86+, serial console 115200)" {
menuentry "Memory test (memtest86+, experimental multiboot)" {
menuentry "Memory test (memtest86+, serial console 115200, experimental multiboot)" {
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {

now, not sure what to do next...?!?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
677
118
now, not sure what to do next...?!?
follow my post, you have to add the part after $menuentry_id_option into your config:

Code:
# for example:
# add first the submenu, then '>' followed by the menuentry for the kernel you want to boot
GRUB_DEFAULT="gnulinux-advanced-62b81a8b-7278-439e-9df2-6c81c2e3441e>gnulinux-5.11.22-6-pve-advanced-62b81a8b-7278-439e-9df2-6c81c2e3441e"

your submenu is gnulinux-advanced-bd2e0821-2f22-490d-8d64-56a489cbb71d and the menuentry you want is probably gnulinux-5.11.22-7-pve-advanced-bd2e0821-2f22-490d-8d64-56a489cbb71d ;)
 
  • Like
Reactions: kitkat

kitkat

New Member
Feb 9, 2022
10
0
1
48
ok im confused, how do I update the grub? my grub looks like:
Code:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""
and when i grep menuentry looks like :
Code:
root@pve:~# grep menuentry /boot/grub/grub.cfg
if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
  menuentry_id_option=""
export menuentry_id_option
menuentry 'Proxmox VE GNU/Linux' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-50de34f2-a8f2-4665-ae84-baf3b786d975' {
submenu 'Advanced options for Proxmox VE GNU/Linux' $menuentry_id_option 'gnulinux-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-4-pve' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-4-pve-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-4-pve (recovery mode)' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-4-pve-recovery-50de34f2-a8f2-4665-ae84-baf3b786d975' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-2-pve' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-2-pve-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.13.19-2-pve (recovery mode)' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.13.19-2-pve-recovery-50de34f2-a8f2-4665-ae84-baf3b786d975' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.11.22-7-pve' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.11.22-7-pve-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975' {
        menuentry 'Proxmox VE GNU/Linux, with Linux 5.11.22-7-pve (recovery mode)' --class proxmox --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-5.11.22-7-pve-recovery-50de34f2-a8f2-4665-ae84-baf3b786d975' {
menuentry "Memory test (memtest86+)" {
menuentry "Memory test (memtest86+, serial console 115200)" {
menuentry "Memory test (memtest86+, experimental multiboot)" {
menuentry "Memory test (memtest86+, serial console 115200, experimental multiboot)" {

not used to playing around with bootloaders so bare with me please...

do I simply change the grub default from :
Code:
GRUB_DEFAULT=0
to
Code:
GRUB_DEFAULT="gnulinux-5.11.22-7-pve-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975"
???


not sure what to change when nano /etc/default/grub
 
Last edited:

kitkat

New Member
Feb 9, 2022
10
0
1
48
Ok, so I went and did as explained earlier in the thread so my grub looks like:

Code:
GRUB_DEFAULT="gnulinux-simple-50de34f2-a8f2-4665-ae84-baf3b786d975>gnulinux-5.11.22-7-pve-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975"
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

then did "update-grub" although the proxmox server is still booting the 5.13 kernel

What am i doing wrong?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
5,207
677
118
then did "update-grub" although the proxmox server is still booting the 5.13 kernel

What am i doing wrong?
could you post the whole /etc/grub/default file here for us to check?
(the GRUB_DEFAULT value shouldn't be duplicated inside the file, but that's just my guess)
 

kitkat

New Member
Feb 9, 2022
10
0
1
48
i got it working now. I had to do the "proxmox-boot-tool kernel add" to add the 5.11 kernel and it worked.
Code:
root@proxmox-dell:~# cat /etc/default/grub


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

#GRUB_DEFAULT=0
GRUB_DEFAULT="gnulinux-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975>gnulinux-5.11.22-7-pve-advanced-50de34f2-a8f2-4665-ae84-baf3b786d975"
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


and this is the boot-tool:
Code:
root@proxmox-dell:~# proxmox-boot-tool kernel list
Manually selected kernels:
5.11.22-7-pve

Automatically selected kernels:
5.13.19-2-pve
5.13.19-4-pve
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!