Proxmox 6 auf Intel NUC Audioausgang nutzen

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo zusammen
Ich möchte auf einer VM unter Proxmox Daphile Musikserver installieren und möchte dazu den analogen Audioausgang vom Intel NUC nutzen.
Ich habe auf der Konsole vom Knoten (pve)

/etc/default/grub

Die Zeile:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

geändern nach:

GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"

dann habe ich

update-grub

gemacht und ein reboot durchgeführt.

Wenn ich dann dmesg | grep -e DMAR -e IOMMU abfrage kommt die Ausgabe siehe Bild Ausgabe.

Wenn ich jetzt in der Maschine den Audiocontroller hinzufügen will kommt der Fehler ,siehe Bild und die Maschine startet nicht mehr.

Was mache ich falsch??

Volker
 

Attachments

Last edited:

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo
Hat keiner eine Idee, wie man die analogen Audioanschlüsse an eine VM durchreicht.
Ich bin wirklich am verzweifeln.
Volker
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,019
365
88
31
Vienna
hast du auch vt-d im bios aktiviert? welcher nuc ist es denn genau?
 

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo
Ja vt-d ist im BIOS aktiviert. Ich habe auch nochmal ein Biosupdate gemacht, brachte aber keinen Erfolg.
Der NUC heißt DN 2820 FYKH.
Usb passthrough funktioniert doch auch , also ein USB Anschluss habe ich an eine andere VM durchgereicht und es funktioniert.
Warum funktioniert das mit den Audioanschlüssen nicht?
Was kann ich noch tun??

Volker
 
Last edited:

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo
Ja ich habe Proxmox über UEFI direkt auf eine SSD gespielt.
Jetzt habe ich GRUB_CMDLINE_LINUX_DEFAULT in die Datei grub eingefügt.
Bei update- grub bekomme ich folgende Fehlermeldung
root@pve:~# update-grub
/usr/sbin/grub-mkconfig: 9: /etc/default/grub: GRUB_CMDLINE_LINUX_DEFAULT: not found
root@pve:~#
Ich habe die grub datei mal mit angehängt habe ich da was falsch gemacht??

Danke schon mal für die Hilfe

Volker
 

Attachments

Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,019
365
88
31
Vienna
die zeile muss
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"
lauten

aber bitte nochmal meinen link lesen, wenn uefi + zfs verwendet wird, ist die Prozedur ein bisschen anders
 

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo
Die Zeile in grub war ursprünglich
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on"
Da hat es nicht funktioniert. Dann habe ich deine Anleitung gelesen .
In deinem Link steht mal soll
GRUB_CMDLINE_LINUX_DEFAULT in die Datei grub einfügen und update-grub machen, das habe ich getan mit der obigen Fehlermeldung.
Was läuft da falsch.
Ich habe Proxmox von einem USB Stick auf eine Formatierte SSD im NUC installiert.
Sonst sind keine Betriebssysteme auf dem NUC installiert.

Volker
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,019
365
88
31
Vienna
nochmal, wenn zfs auf uefi installiert ist (betonung auf zfs), dann muss man was anderes machen, zitat aus der doku:

For EFI Systems installed with ZFS as the root filesystem systemd-boot is used.
und
Systemd-boot
The kernel commandline needs to be placed as line in /etc/kernel/cmdline Running /etc/kernel/postinst.d/zz-pve-efiboot sets it as option line for all config files in loader/entries/proxmox-*.conf.
 

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo
ich habe gerde nochmal nachgeschaut ,ich habe kein ZFS installiert.

Ich habe jetzt die Datei grub wieder geändert in
GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_iommu=on".

Dann stehe ich ja wieder am Anfang, ich hoffe wir finden noch eine Lösung.
Was kann ich jetzt noch tun?

Volker
 
Last edited:

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo
Ich habe Proxmox nochmal neu installiert ,ohne ZFS. Dann habe ich die Grub Datei wie oben schon beschrieben geändert,
update-grub durchgeführt und ein reboot gemacht.
Leider ist der Fehler geblieben. Siehe mein erster Post.

in der '/proc/cmdline' steht 'intel_iommu=on'

Ich hoffe Ihr habt noch eine Idee, ich sage schon mal danke.

Volker
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,019
365
88
31
Vienna
was ist denn der output von:

Code:
ls -l /sys/kernel/iommu_groups
?

auch der ganze dmesg output wäre interessant
 

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Hallo,
danke erstmal für Deine Hilfe,
wenn ich

Code:
ls -l /sys/kernel/iommu_groups
eingebe kommt
" total 0 " heraus .
Wenn ich
Code:
dmesg | grep -e DMAR -e IOMMU
eingebe
kommt
" [ 0.128868] DMAR: IOMMU enabled "
siehe Bild im Anhang.
 

Attachments

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,019
365
88
31
Vienna
" [ 0.128868] DMAR: IOMMU enabled "
bitte den ganzen (also ohne grep) dmesg output posten.... die meldung 'DMAR: IOMMU enabled" alleine ist nämlich noch nicht genug
 

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Ok das heist es wird mit dem PC nicht funktionieren die Soundkarte an eine VM durchzureichen.?
Oder gibt es noch eine andere Möglichkeit Musik über die analogen Anschlüsse zu hören?
Volker
 

Felix.

Member
May 13, 2018
51
1
8
19
Klingt so, als würde das nichts werden, wenn der Prozessor das nicht unterstützt.
Du könntest als Workaround eine günstige USB Audiokarte an die VM durchreichen, falls das eine Option für dich ist.
 

Knusterus

New Member
Aug 9, 2019
16
0
1
52
Ok das ist wirklich schade, aber das läßt sich halt nicht ändern.
Mit der USB Soundkarte ist eine sehr gute Idee, Gibt es da irgendwelche speziellen Anforderungen?
Volker
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!