[SOLVED] Proxmox 5 to 6 upgrade

raj

Active Member
Sep 17, 2011
217
4
38
www.businessparksolutions.com
Hi Team,

I have a server with proxmox 5 installed and when I am trying to do the prechecks to update to version 6 it fails with the following error :

FAIL: proxmox-ve package is too old, please upgrade to >= 5.4-2!

Checking running kernel version..
WARN: unexpected running and installed kernel '4.4.98-2-pve'.

Here is the package version

proxmox-ve: not correctly installed (running kernel: 4.4.98-2-pve)
pve-manager: 5.4-15 (running version: 5.4-15/d0ec33c6)
pve-kernel-4.4.98-2-pve: 4.4.98-101
pve-kernel-4.4.59-1-pve: 4.4.59-87
pve-kernel-4.4.49-1-pve: 4.4.49-86
pve-kernel-4.4.44-1-pve: 4.4.44-84
pve-kernel-4.4.40-1-pve: 4.4.40-82
pve-kernel-4.4.35-2-pve: 4.4.35-79
pve-kernel-4.4.35-1-pve: 4.4.35-77
pve-kernel-4.4.24-1-pve: 4.4.24-72
pve-kernel-4.4.19-1-pve: 4.4.19-66
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-12
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-56
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-14
libpve-storage-perl: 5.0-44
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-7
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
proxmox-widget-toolkit: 1.0-28
pve-cluster: 5.0-38
pve-container: 2.0-42
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-22
pve-firmware: 2.0-7
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-4
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-56
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2


Could someone assist please. I have checked and there is no other updates to install :-(

Rajbps
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
693
118
hi,

i see: proxmox-ve: not correctly installed (running kernel: 4.4.98-2-pve)

so it looks like something isn't installed properly, and that's why it's complaining.

I have checked and there is no other updates to install :-(
can you show your apt lists? find /etc/apt -name '*.list' -exec cat {} \;
 

raj

Active Member
Sep 17, 2011
217
4
38
www.businessparksolutions.com
@oguz here is the infoi requested

find /etc/apt -name '*.list' -exec cat {} \;
#deb https://enterprise.proxmox.com/debian stretch pve-enterprise
deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
deb http://ftp.uk.debian.org/debian stretch main contrib

# PVE pve-no-subscription repository provided by proxmox.com, NOT recommended fo r production use
deb http://ftp.at.debian.org/debian stretch main contrib
deb http://ftp.at.debian.org/debian stretch-updates main contrib
#deb http://download.proxmox.com/debian/pve stretch pve-no-subscription
#deb http://download.proxmox.com/debian stretch pve-no-subscription

# security updates
deb http://security.debian.org stretch/updates main contrib


#hw raid monitoring
#deb http://hwraid.le-vert.net/debian wheezy main
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,618
959
163
Please run

> apt update
> apt install proxmox-ve

and post logs.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!