Proxmox 5 - Spice - Maus und! Tastatur verliert Funktion

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Moin zusammen.

EIne Frage im Zusammenhang mit einer Windows10 VM auf einem 5er VE.

Ich habe die VM zuhause laufen und die Ports 8006 und 3128 weiter geleitet. Das läuft eine
Weile ganz gut. Aber mehrmals am Tag verliere ich die Maus und Tastatur der VM. Das Bild bleibt.
Wenn ich dann über die 8006 die Website und dort eine Console nutze, kann ich normal bedienen und
sehe das auch in der Spice Session. ..!

Beheben kann ich das durch Restart des Spiceviewer... Ich nutze das allseits bekannte Script zum Verbindungsaufbau
der Spicesession. Aber auch wenn ich den Weg über die Webseite nehme, ist das so.

Jemand sowas schonmal gehabt.? Fehlt bei mir eine Port FW.?

Der Viewer läuft unter Debian 10 und der selbe Effekt ist unter Windows10 mit dem dort installierten Virt-Viewer zu beobachten.
Liegt wohl nicht am Viewer OS. Hab den remote-viewer unter Debian auch mal aus der Shell aufgerufen, um zu schauen was da
an Meldungen kommt. Nix.

Was kann das sein.?

Vielen Dank für Tipps
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Hallo,

Welchen Browser benutzt du?
Browser.? In beiden Viewer OS den aktuellen Firefox. Habe aber auch den Spice über ein Script aufgerufen. Von diesem Script gibt es auch drei Varianten. Eine als Linux Shellscript, als Linux Python Script und unter Windows10 gibt es auch ein Programm zum Start. Und auch der Start über den Browser ändert nichts. Das Gast OS ist Windows10 , aber auch ein Windows 7 verliert die Verbindung. Verstehe nicht, warum das Bild weiter läuft, und nur die Bedienung klemmt.
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Update. Der Gast kann auch ein Ubuntu sein. Selber Effekt. Die Maus/Tastatur geht nach einer Zeit nicht, das Bild bleibt aber aktuell. Sieht man an der Uhr, und wenn ich über NoVNC den Gast bediene.

Die Zeit bis Maus/Tastatur ausfällt ist sehr unterschiedlich. Teilweise sind es Stunden...
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Update2:
Hab das Proxmox auf das neueste 6er Release hochgezogen. Fehler bleibt. Ich teste später nochmal, ob das nur passiert, wenn ich via Portweiterleitung die Spiceverbindung aufbaue, oder auch wenn ich aus dem lokalen Netz das nutze.

Sehr kurios.

Stand jetzt habe die 8006 und den Proxyport für Spice als TCP auf meiner Fritzbox weitergeleitet. Sollte doch gehen...

Bei einer älteren 5er Version habe ich bei jemand anders in den .Conf des Gastes einen abweichenden Spiceport eingetragen. Das geht aber wohl nicht mehr, habe ich gelesen. Stimmt das.? Das läuft ohne Probleme.
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Update3:

Wenn der Linux Spiceviewer im selben Netz, also nicht von draussen via Portweiterleitung verbunden ist, passiert das nicht.

Nun könnte ich ein VPN aufsetzen. Das ist aber unnötig komplex.

Jemand ne andere Idee?
Wer nutzt Spice via Portforwarding??
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Das passiert ja auf mehreren Gästen. Auch einem Win7 und einem Ubuntu. Irgendwas ist anders, wenn ich per Portforwarding
auf den Gast über den SpiceProxy zugreife.

Ich habe 3128 und 8006 TCP auf den PM Server umgeleitet. Die 111 TCP hatte ich mal dazu genommen. Hat nichts geändert.
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Es ist zum verzweifeln. Spice über eine Portweiterleitung scheint ein Problem zu machen. Hab jetzt auf dem Gast Windows 10 jetzt den Spice "Treiber" neu installiert. Hab zwecks Test das Spice Enhancements noch eingeschaltet. Hab auf dem Viewer, der auf Debian10 läuft, die Version 8 des Virt-viewer gehoben. Alles egal. Immer nach einer undefinierten Zeitspanne, meist wenn ich länger nichts bedient habe, ist die Maus/Tastatur ohne Funktion. Das Bild bleibt funktional. Hatte das aber auch schon während ich in der VM bedient habe...

Alles sehr ärgerlich.

Weiss jemand noch eine Möglichkeit, wie man da genauer debuggen kann.?

Das Syslog des PM Server hat in dem fraglichen Zeitraum eben nur einmal cron bemüht. Aber in hourly ist nur der placeholder drin.

Feb 27 09:17:00 pve systemd[1]: pvesr.service: Succeeded.
Feb 27 09:17:00 pve systemd[1]: Started Proxmox VE replication runner.
Feb 27 09:17:01 pve CRON[32311]: pam_unix(cron:session): session opened for user root by (uid=0)
Feb 27 09:17:01 pve CRON[32312]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Feb 27 09:17:01 pve CRON[32311]: pam_unix(cron:session): session closed for user root
Feb 27 09:18:00 pve systemd[1]: Starting Proxmox VE replication runner...
Feb 27 09:18:00 pve systemd[1]: pvesr.service: Succeeded.


Hab jetzt an meiner Viewer den verbose Level erhöht.

/usr/bin/remote-viewer -fv "/tmp/spiceproxy" >> /home/user/proxmox.log

Nach dem Start kommt:

Guest (null) has a spice display
Opening connection to display at /tmp/spiceproxy


Mal schauen, ob da was reinkommt wenn die Maus ausfällt..
 

matrix

Member
Jan 24, 2020
89
9
8
26
Hallo,

Benutzt du Maus und Tastatur wireless, Bluetooth oder Kabel?

Versuchst du auch, Maus und Tastatur zu wechseln
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Die remote-viewer Anwendung schreibt nichts in das Log.

> Versuchst du auch, Maus und Tastatur zu wechseln

Kabelgebundene Maus und Tastatur. Der Ausfall passiert auch auf anderen als Viewer genutzten Rechnern. Auch ein Win10 Notebook.

Und es passiert nie, wenn ich die VM aus dem selben Netz mit den selben Viewern nutze. Die Permissions sind auf PVEUser gesetzt. Probiere jetzt nochmal PVEadmin. Allerdings kann das ja alles kaum sein, wenn es im lokalen Netz geht.
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Hab jetzt noch -- debug in den Aufruf des Viewer gesetzt.

Nach dem Start: Da sieht man schon mehr. Interessant mit den Channels...

Code:
Guest (null) has a spice display
Opening connection to display at /tmp/spiceproxy
Guest SMVPN display has disconnected, shutting down
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.342: Opening display to /tmp/spiceproxy
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.342: Guest (null) has a spice display
Guest (null) has a spice display
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.347: ignoring [ovirt] section content as URL, VM GUID are missing from the .vv file
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.347: After open connection callback fd=-1
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.347: Opening connection to display at /tmp/spiceproxy
Opening connection to display at /tmp/spiceproxy
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.350: New spice channel 0x5577fb8c7810 SpiceMainChannel 0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.350: notebook show status 0x5577fb7a63a0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.597: main channel: opened
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.597: notebook show status 0x5577fb7a63a0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.601: virt_viewer_app_set_uuid_string: UUID changed to cc8494af-5976-4b0e-b17a-cb926dd96c16
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.601: No guest-specific fullscreen config, using fallback
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.601: Performing full screen auto-conf, 2 host monitors
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.601: Set SPICE display 0 to (1920,0)-(1920x1200)
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:49.601: Set SPICE display 1 to (0,0)-(1920x1080)
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.660: Already did auto-conf, skipping
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.678: New spice channel 0x5577fb97ba70 SpiceDisplayChannel 0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.679: New spice channel 0x5577fbc2e1c0 SpiceCursorChannel 0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.679: New spice channel 0x5577fbc2d740 SpiceRecordChannel 0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.679: New spice channel 0x5577fbc301d0 SpicePlaybackChannel 0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.679: new audio channel
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.680: New spice channel 0x5577fbc2f700 SpiceInputsChannel 0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.680: new inputs channel
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.869: creating spice display (#:0)
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:51.869: Insert display 0 0x5577fb897350
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:52.109: Found a window without a display, reusing for display #0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:52.109: notebook show display 0x5577fb7a63a0
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:52.118: Allocated 1920x1200
(remote-viewer:7220): virt-viewer-DEBUG: 11:47:52.118: Child allocate 1920x1200
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
So, Bedienung wieder ausgefallen. Im Debug-Log kein Eintrag dazu gekommen. Nun fällt mir nichts mehr ein...

Der Grund, das ich da so hinterher bin. Mein Arbeitgeber beabsichtig diese Virtualisierungslösung im grossen Stil einzusetzen. Ein Testplattform ist auch bereits im Einsatz. Allerdings noch ein 5er Release. Die Funktionalität von Spice als RDP Ersatz habe ich bereits mal vorgeführt. Das fand grossen Anklang... Und klar, die Notwendigkeit, das über eine Portweiterleitung zu nutzen, ist dort nicht gegeben. Wäre trotzdem wichtig zu wissen, wo da der Haken ist...
 
Last edited:

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Sonst niemand sowas gehabt.?

Ich will jetzt nochmal ein VPN probieren. Also von aussen nicht über Portforward auf die PM Maschine. Trotzdem
wäre es sicher interessant zu wissen, woran es scheitert...
 

RudiOnTheAir

Member
Nov 9, 2015
15
0
21
Update.!
Mit einem VPN an den selben Zielserver, also ohne Portforw. des Spice passiert das nicht. Das ist gut zu wissen für die geplante Nutzung, aber nicht so recht zu verstehen.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!