[PROXMOX 5.1] [lpfc] HBA Emulex LPe12000 error

Jan 11, 2018
3
0
6
43
Hi All

Proxmox 5.0 iso install - HBA see disk

Proxmox 5.1 iso install - HBA take error lpfc 0000:05:00.1: 10):0266 Issue NameServer Req x117 err 1 Data: x80000 x0

If Proxmox 5.0 (or clear debian 9) udgrade from pve-no-subscription - take error lpfc 0000:05:00.1: 10):0266 Issue NameServer Req x117 err 1 Data: x80000 x0

Yes i know don`t use pve-no-subscription in production but in 5.0 it's work. Please, who broke it, return it as it was .

Thank you. Have a nice day.
 

Attachments

  • proxmox5.txt
    39.6 KB · Views: 10
  • proxmox51.txt
    31.9 KB · Views: 8

borjamf

New Member
Dec 14, 2017
5
0
1
77
Hi,

I got the same problem. I recently received two cabinets StorageTek, but I could not make it work in our testing node Proxmox 5.1, it shows the same error "Issue Nameserver....".

After I read this thread, I've installed Proxmox v5.0 in our testing node and now IT WORKS! I think something is broken in Proxmox v5.1, so hope anyone make a fix for this.
 
Jan 11, 2018
3
0
6
43
Hi All

4.13.13-5-pve still contains the same error

[ 4.890655] lpfc 0000:05:00.0: 0:(0):0266 Issue NameServer Req x117 err 1 Data: x80000 x0

modinfo lpfc
filename: /lib/modules/4.13.13-5-pve/kernel/drivers/scsi/lpfc/lpfc.ko
version: 0:11.4.0.1
author: Broadcom
description: Emulex LightPulse Fibre Channel SCSI driver 11.4.0.1
 

komspr

New Member
Jan 25, 2018
9
0
1
42
Hi. I can confirm this issue. We have this on our servers.

description: Fibre Channel
product: Saturn-X: LightPulse Fibre Channel Host Adapter
vendor: Emulex Corporation

[ 4.015493] lpfc 0000:04:00.0: 0:1303 Link Up Event x1 received Data: x1 x1 x10 x2 x0 x0 0
[ 4.015570] lpfc 0000:04:00.0: 0:1309 Link Up Event npiv not supported in loop topology
[ 4.016671] lpfc 0000:04:00.0: 0:(0):2858 FLOGI failure Status:x3/x18 TMO:x0 Data x1000 x0
[ 4.017627] lpfc 0000:04:00.0: 0:(0):2858 FLOGI failure Status:x3/x18 TMO:x0 Data x1000 x0
[ 4.018561] lpfc 0000:04:00.0: 0:(0):2858 FLOGI failure Status:x3/x18 TMO:x0 Data x1000 x0
[ 4.018636] lpfc 0000:04:00.0: 0:(0):0100 FLOGI failure Status:x3/x18 TMO:x0
[ 4.019713] lpfc 0000:04:00.0: 0:(0):0266 Issue NameServer Req x117 err 1 Data: x80000 x0

As we have Proxmox cluster we stuck with upgrading from 4.4 to 5.1.
Don't know if this is because of lpfc.ko module or some kernel issue. But Proxmox 5.0 had 4.10 kernel, 11.2.0.2 lpfc and Proxmox 5.1 has 4.13 kernel, 11.4.0.1 lpfc.
I tried to use lpfc.ko 11.0.0.10 which comes with 4.4 kernel, but no luck. Anyway we need update to resolve this issue.

Thank you.
 

mir

Famous Member
Apr 14, 2012
3,559
120
83
Copenhagen, Denmark
Hi. I can confirm this issue. We have this on our servers.

description: Fibre Channel
product: Saturn-X: LightPulse Fibre Channel Host Adapter
vendor: Emulex Corporation

[ 4.015493] lpfc 0000:04:00.0: 0:1303 Link Up Event x1 received Data: x1 x1 x10 x2 x0 x0 0
[ 4.015570] lpfc 0000:04:00.0: 0:1309 Link Up Event npiv not supported in loop topology
[ 4.016671] lpfc 0000:04:00.0: 0:(0):2858 FLOGI failure Status:x3/x18 TMO:x0 Data x1000 x0
[ 4.017627] lpfc 0000:04:00.0: 0:(0):2858 FLOGI failure Status:x3/x18 TMO:x0 Data x1000 x0
[ 4.018561] lpfc 0000:04:00.0: 0:(0):2858 FLOGI failure Status:x3/x18 TMO:x0 Data x1000 x0
[ 4.018636] lpfc 0000:04:00.0: 0:(0):0100 FLOGI failure Status:x3/x18 TMO:x0
[ 4.019713] lpfc 0000:04:00.0: 0:(0):0266 Issue NameServer Req x117 err 1 Data: x80000 x0

As we have Proxmox cluster we stuck with upgrading from 4.4 to 5.1.
Don't know if this is because of lpfc.ko module or some kernel issue. But Proxmox 5.0 had 4.10 kernel, 11.2.0.2 lpfc and Proxmox 5.1 has 4.13 kernel, 11.4.0.1 lpfc.
I tried to use lpfc.ko 11.0.0.10 which comes with 4.4 kernel, but no luck. Anyway we need update to resolve this issue.

Thank you.
Have you tried consulting your hardware supplier?
 

komspr

New Member
Jan 25, 2018
9
0
1
42
No.

I have made a little investigation.

Ubuntu 16.04.3 LTS, kernel 4.10.0-28, lpfc 11.2.0.2 - no issue.
Ubuntu 17.10.1, kernel 4.13.0-21, lpfc 11.4.0.1 - issue.
Debian 9.3, kernel 4.9.0-4, lpfc 11.2.0.0 - no issue.
Fedora 27, kernel 4.13.9-300, lpfc 11.4.0.1 - issue.
Proxmox 5.0, kernel 4.10.15-1, lpfc 11.2.0.2 - no issue (thanks to Oleksii Pechonkin https://forum.proxmox.com/threads/proxmox-5-1-lpfc-hba-emulex-lpe12000-error.39179/).
Proxmox 5.1, kernel 4.13.13-5, lpfc 11.4.0.1 - issue.

So I think it's either kernel 4.13, or lpfc 11.4 problem...
 

mamatov

Member
Jan 16, 2015
35
0
6
Hi,

I got the same problem. I have an old IBM DS3400 with two controllers.
I could not make it work in our testing node Proxmox 5.1 on "direct attach", it shows the same error "Issue Nameserver....".

If I installed proxmox 4.4, I can see my LUN.

With Proxmox 5.1, I found that if I add a fiber switch between the server and the DS3400 it is working as expected. I can see my LUN.

Is it working for you with a switch and not direct attach ?
 

komspr

New Member
Jan 25, 2018
9
0
1
42
Hi.
Unfortunately, I don't have a switch to test this workaround. And yes, I have this problem when using direct attach.
 

Mitterhuemer

New Member
Jan 29, 2018
15
1
1
29
Hello,
we evaluate Proxmox with a HPE MSA2040 SAN, so we have no Subscription.

We also use the Emulex Fibre Channel Card but it does not work.

lpfc 0000:22:00.0:1: 1:1305 Link Down Event x4 received Data: x4 x20 x8011 x0 x0
lpfc 0000:22:00.0:1: 1:1303 Link Up Event x5 received Data: x5 x0 x20 x0 x0 x0 0
...
...
...

I have the same Problem with Proxmox 5.0
 
Last edited:

komspr

New Member
Jan 25, 2018
9
0
1
42
Broadcom support wrote:
"Thanks for the logs, it sounds a valid bug, we will work a fix for it.
As your OS are not major Linux distributions, e.g. Ubuntu, there is only inbox driver support from OS vendor, and inbox driver is old, and the issue is possibly a known issue fixed on later version, but I have no newer driver for these OSes for verification.
If possible, could you please test our latest driver published on our web site on major OSes, such as SLES, RHEL and CentOS?
Driver download link:
https://www.broadcom.com/support/do...Pe12002+FC+Host+Bus+Adapter&po=&pa=Driver&dk="

I tried to adapt source code to Ubuntu kernel and compile it, but I had no success. I opened a ticket on Launchpad, so you may join and confirm this bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1746970
 
Feb 11, 2018
34
1
13
47
In the launchpad item there is a solution: lpfc 11.4.0.4 which is in kernel 4.15 works.
Anybody knows if the pve kernel patches/sources are available so I can fix the module myself?
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
7,846
1,505
164
In the launchpad item there is a solution: lpfc 11.4.0.4 which is in kernel 4.15 works.
Anybody knows if the pve kernel patches/sources are available so I can fix the module myself?

the kernel sources are available (like all the others) via git.proxmox.com . I suggest checking mainline 4.14 and 4.13 next, depending on the outcome we can then further narrow down when the issue was introduced.
 
Feb 11, 2018
34
1
13
47
Hello Fabian,

I did some more research, the last working kernel from the Ubuntu Xenial repository is
linux-image-4.10.0-42-generic_4.10.0-42.46~16.04.1_amd64.deb

The next available image linux-image-4.11.0-14-generic_4.11.0-14.20~16.04.1_amd64.deb is not working, I also tried several Ubuntu 4.13 and mainline kernels, none of them is working.

The first working kernel I found is mainline 4.14.1.

I think this commit is the fix for the problem github.com/torvalds/linux/commit/2877cbffb79ed121a6bcc5edbe629d3aba36cd29

Unfortunately the scsi subsystem was heavily refactored from 4.10 to 4.14 so I am unable to isolate a single patch to fix/reproduce the problem.

Are there any plans to upgrade to a newer kernel soon? I am still evaluating the PVE on my lab but need to bring those boxes in production within the next two weeks, so I need to decide weather to go with 5.0, try to patch myself or move to another solution...

Oliver
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!