Proxmox 3.4 and Ceph Firefly not supported anymore? create xfs error.

felipe

Member
Oct 28, 2013
152
1
18
We are using still proxmox 3.4 (we want to update in 1 month to 4) and ceph firefly.
but we cannot install new osds anymore..

says:
ceph4 pvedaemon[15035]: command 'ceph-disk prepare --zap-disk --fs-type xfs --cluster ceph --cluster-uuid 820e9ff3-7d60-4244-a606-0d11e96b9504 /dev/sdc' failed: exit code 1

we have latest proxmox pve-manager/3.4-13/4c745357 and latest firefly from
deb http://download.ceph.com/debian-firefly wheezy main

by hand:
root@ceph4:~# ceph-disk prepare --zap-disk --fs-type xfs --cluster ceph --cluster-uuid 820e9ff3-7d60-4244-a606-0d11e96b9504 /dev/sdd
Caution: invalid backup GPT header, but valid main header; regenerating
backup header from main header.

****************************************************************************
Caution: Found protective or hybrid MBR and corrupt GPT. Using GPT, but disk
verification and recovery are STRONGLY recommended.
****************************************************************************
GPT data structures destroyed! You may now partition the disk using fdisk or
other utilities.
Creating new GPT entries.
The operation has completed successfully.
Information: Moved requested sector from 34 to 2048 in
order to align on 2048-sector boundaries.
The operation has completed successfully.
Information: Moved requested sector from 31457281 to 31459328 in
order to align on 2048-sector boundaries.
The operation has completed successfully.
-i size option requires a value
Usage: mkfs.xfs
/* blocksize */ [-b log=n|size=num]
/* data subvol */ [-d agcount=n,agsize=n,file,name=xxx,size=num,
(sunit=value,swidth=value|su=num,sw=num),
sectlog=n|sectsize=num
/* inode size */ [-i log=n|perblock=n|size=num,maxpct=n,attr=0|1|2,
projid32bit=0|1]
/* log subvol */ [-l agnum=n,internal,size=num,logdev=xxx,version=n
sunit=value|su=num,sectlog=n|sectsize=num,
lazy-count=0|1]
/* label */ [-L label (maximum 12 characters)]
/* naming */ [-n log=n|size=num,version=2|ci]
/* prototype file */ [-p fname]
/* quiet */ [-q]
/* realtime subvol */ [-r extsize=num,size=num,rtdev=xxx]
/* sectorsize */ [-s log=n|size=num]
/* version */ [-V]
devicename
<devicename> is required unless -d name=xxx is given.
<num> is xxx (bytes), xxxs (sectors), xxxb (fs blocks), xxxk (xxx KiB),
xxxm (xxx MiB), xxxg (xxx GiB), xxxt (xxx TiB) or xxxp (xxx PiB).
<value> is xxx (512 byte blocks).
ceph-disk: Error: Command '['/sbin/mkfs', '-t', 'xfs', '-f', '-i', 'size', '=', '2048', '-f', '--', '/dev/sdd1']' returned non-zero exit status 1



any idea whats wrong?
 

wolfgang

Proxmox Staff Member
Staff member
Oct 1, 2014
4,987
332
83
Hi,
I can't reproduce the error may by you disk is brocken?

Try to format the disk manuell before you use it as osd

parted /dev/sd<X> mktable gpt

and then make an new osd
 

wbumiller

Proxmox Staff Member
Staff member
Jun 23, 2015
645
85
28
Actually that looks like a bug in ceph-disk, they're splitting up the `-i size=2048` into -i, size, =, 2048...
 

felipe

Member
Oct 28, 2013
152
1
18
yes thats right.... its a ceph bug...
before i had
osd mkfs options xfs = "-f -i size = 2048"
and it worked for the old servers. (and not for the newest ceph firefly)
no i changed it to
osd mkfs options xfs = ""
and it works....
 

wbumiller

Proxmox Staff Member
Staff member
Jun 23, 2015
645
85
28
Or try `osd mkfs options xfs = "-f -i size=2048"` (note the lack of spaces around the = sign), maybe they generalized the mkfs option somehow to take be passed as raw command line argument string...
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!