Problems with bridged ethernet in vz-containers after upgrade to pve 1.5

Joe

New Member
Feb 27, 2009
9
0
1
Helsinki, Finland
Hi!

After upgrading to PVE 1.5, kernel 2.6.18 I got a problem with containers using bridged ethernet network. Here is an example from starting from the command line:

Code:
Configure veth devices: veth219.0 
Adding interface veth219.0 to bridge vmbr2 on CT0 for CT219
/usr/sbin/vznetaddbr: line 34: /proc/sys/net/ipv4/conf/veth219.0/proxy_arp: No such file or directory
/usr/sbin/vznetaddbr: line 35: /proc/sys/net/ipv4/conf/veth219.0/forwarding: No such file or directory
At first it didn't seem to affect operation, but I was wrong. Some of the VMs have network issues now, perhaps because of this. At least I haven't found anything else out of the ordinary. These vz-containers were running nicely on 2.6.24 before the installation of pve-2.6.18. Anyone else seen this?

Code:
~# pveversion -v
pve-manager: 1.5-8 (pve-manager/1.5/4674)
running kernel: 2.6.18-2-pve
proxmox-ve-2.6.18: 1.5-5
pve-kernel-2.6.24-7-pve: 2.6.24-11
pve-kernel-2.6.18-2-pve: 2.6.18-5
pve-kernel-2.6.24-9-pve: 2.6.24-18
pve-kernel-2.6.24-8-pve: 2.6.24-16
qemu-server: 1.1-11
pve-firmware: 1.0-3
libpve-storage-perl: 1.0-10
vncterm: 0.9-2
vzctl: 3.0.23-1pve8
vzdump: 1.2-5
vzprocps: 2.0.11-1dso2
vzquota: 3.0.11-1
pve-qemu-kvm-2.6.18: 0.9.1-5
Joe
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!