Problem with GUI on VirtualBox

Discussion in 'Proxmox VE: Installation and configuration' started by YasserHamed, Mar 15, 2019.

  1. YasserHamed

    YasserHamed New Member

    Joined:
    Mar 15, 2019
    Messages:
    3
    Likes Received:
    0
    I try to install Proxmox VE on VirtualBox with following
    https://pve.proxmox.com/wiki/Proxmox_VE_inside_VirtualBox
    but I have the problem with login to GUI from Browser, i don't have any knowledge about networking and i follow some tuts to learn more, but all tuts or resolved threads talk about fix problem on a real server not on VM.
    I hope if someone can help me.
     
  2. oguz

    oguz Proxmox Staff Member
    Staff Member

    Joined:
    Nov 19, 2018
    Messages:
    395
    Likes Received:
    34
    Can you describe your problem more specifically? Where does the problem occur exactly? Are you accessing the GUI on https://ip:8006 ?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. YasserHamed

    YasserHamed New Member

    Joined:
    Mar 15, 2019
    Messages:
    3
    Likes Received:
    0
    Yes i try use https://10.0.3.15:8006/ but give me The connection has timed out.
     
  4. oguz

    oguz Proxmox Staff Member
    Staff Member

    Joined:
    Nov 19, 2018
    Messages:
    395
    Likes Received:
    34
    * Did you configure the networking properly on Virtualbox? Can you reach the guest (ping maybe)?
    * Are the Proxmox services running properly? ('systemctl status pveproxy' and 'systemctl status pvedaemon')
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. YasserHamed

    YasserHamed New Member

    Joined:
    Mar 15, 2019
    Messages:
    3
    Likes Received:
    0
    Hello,

    you can see attachment result command systemctl status pveproxy,systemctl status pvedaemon and ping google.

    and more info about vm
     

    Attached Files:

    • 02.PNG
      02.PNG
      File size:
      18.9 KB
      Views:
      2
    • 03.PNG
      03.PNG
      File size:
      13.7 KB
      Views:
      2
    • 04.PNG
      04.PNG
      File size:
      19 KB
      Views:
      2
    • 01.PNG
      01.PNG
      File size:
      16.4 KB
      Views:
      2
    • 05.PNG
      05.PNG
      File size:
      5.3 KB
      Views:
      2
    • 06.PNG
      06.PNG
      File size:
      19.8 KB
      Views:
      2
  6. BobhWasatch

    BobhWasatch New Member

    Joined:
    Mar 16, 2019
    Messages:
    27
    Likes Received:
    4
    Hi, I´m new to Proxmox but have used Virtualbox quite a bit. So I´ll toss this out.

    You appear to have 10.0.3.15 as the IP address of your Proxmox VM. Where did you get that from? Because normally, 10.0.2.15 is what Virtualbox will hand out by DHCP to a VM that is set up with the default NAT networking. If you are using NAT, then your VM will be able to get to the outside world, but your host won´t be able to connect in to the VM.

    You can do one of two things to allow the host to connect...

    1. Use ¨bridged¨ networking for the VM instead of NAT. That will allow it to connect directly to the host´s Ethernet. You will have to arrange for the VM to get a valid IP for the network your host is on, either by DHCP or static.

    2. Configure a second network using Virtualbox ¨host¨ networking. That will allow your host to talk to the VM on one network, and for the VM to get to the outside on the NAT network. This is the setup the guide you referred to is recommending.

    The various network modes are all documented in the Virtualbox help.

    I should add that when I was playing around with Proxmox on Virtualbox a couple of weeks ago, I was not able to create KVM machines, only containers. Virtualbox was not allowing me to enable nested virtualization. That might have been due to my CPU (an older I7 laptop) but it is worth noting.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice