Problem: web interface not working when installing with options 'linux maxroot'

ronpeled

New Member
Dec 8, 2010
14
0
1
I'm installing the latest proxox (3.1) on a clean server. When I install it as-is there are no issues and the web interface is working once the install process is done and I reboot. However, when I set special parameters 'linux maxroot=20' it goes through the installation successfully but the web interface does not work. Pointing the browser to it will bring a Error code: ERR_EMPTY_RESPONSE message.

Login in via SSH and running the command:
Code:
pveproxy --debug
unable to create socket - IO::Socket::INET: Address already in use

How can this be resolved? or am I stuck with default root partition?

Thank you!
 

tom

Proxmox Staff Member
Staff member
Aug 29, 2006
15,522
908
163
a bit late, but did you manage it already?

if not, post the output of:

> cat /proc/mounts

and

> pveversion -v
 

ronpeled

New Member
Dec 8, 2010
14
0
1
This issue still exists. I was able to trace it better. It relates to SSL certificates and browsers caching it. So, I'm no expert on SSL and how browsers use it but whenever I reinstalled Proxmox - it essentially created new SSL certificates. So when I visit the site again <ip address>:8006 the browser shows a window with an error message:
No data received

if you click the 'More' button (in chrome) you see: Unable to load the webpage because the server sent no data.Error code: ERR_EMPTY_RESPONSE

Initially I thought it was only Chrome but it affects any browser. Clearing the cache and history does not fix the issue.


 

chrism

New Member
Jan 20, 2015
1
3
1
I know this is an old thread and was probably solved ages ago, but I had almost exactly the same problem and google brought me here. I've now fixed it and thought it might help others if I shared.

The problem I found is because of cookies, not SSL certificates. Proxmox uses a cookie called PVEAuthCookie, which is fundamental to the secure connection to Proxmox. I found that Chrome had an old version of this relating to my previous Proxmox installation. Deleting this cookie solved the problem.

For Chrome users there are two ways to find and delete this cookie:
1) Click on the padlock to the left of "https:" in the address bar, in the popup select the "Persmissions" tab, then click on "Show cookies and site data". In the new popup expand the arrow for your Proxmox server address (ie 192.168.1.11 for me) and then the Cookies folder. You should see a PVEAuthCookie cookie which you can select to show the date and then Remove if necessary.
2) Settings, Show Advanced Settings, Privacy/Content Settings..., in popup Cookies/All cookies and site data..., then select your Proxmox server address in the list on the left, or search for it. Click on the cross on the right to remove cookies.
 

JustaGuy

Member
Jan 1, 2010
323
1
18
I know this is an old thread and was probably solved ages ago, but I had almost exactly the same problem and google brought me here. I've now fixed it and thought it might help others if I shared.

The problem I found is because of cookies, not SSL certificates. Proxmox uses a cookie called PVEAuthCookie, which is fundamental to the secure connection to Proxmox. I found that Chrome had an old version of this relating to my previous Proxmox installation. Deleting this cookie solved the problem.

For Chrome users there are two ways to find and delete this cookie:
1) Click on the padlock to the left of "https:" in the address bar, in the popup select the "Persmissions" tab, then click on "Show cookies and site data". In the new popup expand the arrow for your Proxmox server address (ie 192.168.1.11 for me) and then the Cookies folder. You should see a PVEAuthCookie cookie which you can select to show the date and then Remove if necessary.
2) Settings, Show Advanced Settings, Privacy/Content Settings..., in popup Cookies/All cookies and site data..., then select your Proxmox server address in the list on the left, or search for it. Click on the cross on the right to remove cookies.

Thank you _SO_ much for posting this. Apparently when I 'Clear browsing data', even selecting 'cookies', in Chrome, it didn't remove that cookie you mentioned. Manually deleting it solved my problem. Huge relief!
 

daemonizer

New Member
Jul 13, 2016
1
0
1
53
I know this is an old thread and was probably solved ages ago, but I had almost exactly the same problem and google brought me here. I've now fixed it and thought it might help others if I shared.

The problem I found is because of cookies, not SSL certificates. Proxmox uses a cookie called PVEAuthCookie, which is fundamental to the secure connection to Proxmox. I found that Chrome had an old version of this relating to my previous Proxmox installation. Deleting this cookie solved the problem.

For Chrome users there are two ways to find and delete this cookie:
1) Click on the padlock to the left of "https:" in the address bar, in the popup select the "Persmissions" tab, then click on "Show cookies and site data". In the new popup expand the arrow for your Proxmox server address (ie 192.168.1.11 for me) and then the Cookies folder. You should see a PVEAuthCookie cookie which you can select to show the date and then Remove if necessary.
2) Settings, Show Advanced Settings, Privacy/Content Settings..., in popup Cookies/All cookies and site data..., then select your Proxmox server address in the list on the left, or search for it. Click on the cross on the right to remove cookies.

Kudos ChrisM, such a stupid little thing ... you bailed me out.
 

Logan_Rocks

Member
Dec 22, 2016
48
0
11
24
Its getting the same error when i do https. ill delete that screen sho tthanks for letting me know.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
7,880
953
163
33
Vienna
try another browser or delete the cache, and check if the time is correct
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!