Problem Installing Ubuntu VM


Jul 8, 2016
I've never had a problem installing Ubuntu VMs before on Proxmox, but today I tried spinning another one up and it is giving me an error when it comes to the bootloader. Specifically it says: An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Install the GRUB boot loader on a hard disk.

Does anyone know how I can remedy this problem? It's just odd how it randomly started happening and I've tried multiple installations and I'm receiving the same error.
How big is the disk you have set for the VM?

How big did you set the /boot partition during setup?


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!