[SOLVED] Physical2Virtual: Windows Server 2012 R2 UEFI/GPT on PVE 7

pixelpoint

Member
Mar 25, 2021
14
1
8
35
Dear Proxmox Community,

last night I had to migrate a Physical Windows Server 2012 R2 x64 UEFI/GPT Server to Proxmxo VE 7 (for a customer, we already use Proxmox VE Enterprise).
I tried many different things but in the end the virtual Windows did not start.

Here's what I tried
  1. Installed Proxmox VE 7 on new Server (Community Repo for the customer for starters)
  2. Shut down Windows Server 2012 R2
  3. Boot Windows Server via CloneZilla
  4. Created VM in Proxmox VE 7
  5. Cloned 2 Disks (300 GB + 1TB) to new Server via CloneZilla
  6. Tried to boot new Server -> Failed
When starting the server you can see the "Windows is Loading"-Circle at the bottom (see Screenshot of Boot).
It also states the following:

Code:
BdsDxe: failed to load Boot0001 "UEFI QEMU DVD-ROM QM00005 " from PciRoot (0x0) /Pci (0x7, 0x0)/Sata(0x0,0xFFFF,0x0): Not Found
BdsDxe: loading Boot0004 "Microsoft/Boot" from HD(2,GPT,54B26639-AEFF-46A3-9BF0-CF0DDF98EE93,0xAF800,0x32000)/\EFI\Microsoft\Boot\bootmgfw.efi
BdsDxe: starting Boot0004 "Microsoft/Boot" from HD(2,GPT,54B26639-AEFF-46A3-9BF0-CF0DDF98EE93,0xAF800,0x32000)/\EFI\Microsoft\Boot\bootmgfw.efi

As far as I understand this, it means "Booting from DVD not successfull" (that's ok, virtio Drivers ISO is in there).
2nd and 3rd row seems to say "Found Windows UEFI Bootloader, Booting ...", is that right?

Problem being, after this and the circle at the bottom spinning for a litte while, Windows does not Boot but I get a Blue Screen (looks a little like the new Windows 10 BSOD, but it's gone too fast to read it).
Afterwards, Windows boots into Recovery mode (automatically, no ISO inserted, so the disks are recognized as the recovery mode is on the "hidden" first partition).

In Recovery Mode I tried using "automatic startup repair" (doesn't work).
Then I tried the commandline in recovery mode to see if there's something wrong with the disks/partitions, but DISKPART does not see any disks (list disk is empty and list vol only shows the DVD).

I also tried cloning the disks via Microsofts disk2vhd, but that cloned image just booted directly into UEFI shell.

There are only 2 things I could think off the top of my head to try:
  • VMware standalone converter
  • Boot from Windows 2012 R2 ISO and try to restore from Backup (USB Disk Baremetal Backup created via Windows Server Backup)
Windows Server 2012 VM Config
Please disregard the scsi2, that's the disk2vhd image I tried to boot afterwards.
The 300 GB disks is Windows C:\
Code:
agent: 1
bios: ovmf
boot: order=sata0;scsi0
cores: 8
efidisk0: local-lvm:vm-100-disk-1,size=4M
memory: 32768
name: zysrv
net0: virtio=D2:42:AE:C6:E5:7C,bridge=vmbr0
numa: 0
onboot: 1
ostype: win8
parent: disk2vhd_c_unused
sata0: none,media=cdrom
sata1: local:iso/virtio-win-0.1.185.iso,media=cdrom,size=402812K
scsi0: local-lvm:vm-100-disk-0,discard=on,size=300G,ssd=1
scsi1: local-lvm:vm-100-disk-2,discard=on,size=1T,ssd=1
scsi2: local-lvm:vm-100-disk-3,discard=on,size=286072M,ssd=1
scsihw: virtio-scsi-pci
smbios1: uuid=9e0e37f8-5f62-4c26-adf5-2f0ac005a93b
sockets: 1
startup: order=0
vmgenid: 7224cb2a-4ff2-4053-a181-5e420355e77e

Proxmox VE Version Info
Code:
proxmox-ve: 7.0-2 (running kernel: 5.11.22-1-pve)
pve-manager: 7.0-9 (running version: 7.0-9/228c9caa)
pve-kernel-helper: 7.0-4
pve-kernel-5.11: 7.0-3
pve-kernel-5.11.22-1-pve: 5.11.22-2
ceph-fuse: 15.2.13-pve1
corosync: 3.1.2-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown2: 3.0.0-1+pve6
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.21-pve1
libproxmox-acme-perl: 1.1.1
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.0-4
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.0-4
libpve-guest-common-perl: 4.0-2
libpve-http-server-perl: 4.0-2
libpve-storage-perl: 7.0-9
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.9-2
lxcfs: 4.0.8-pve2
novnc-pve: 1.2.0-3
proxmox-backup-client: 2.0.1-1
proxmox-backup-file-restore: 2.0.1-1
proxmox-mini-journalreader: 1.2-1
proxmox-widget-toolkit: 3.2-4
pve-cluster: 7.0-3
pve-container: 4.0-8
pve-docs: 7.0-5
pve-edk2-firmware: 3.20200531-1
pve-firewall: 4.2-2
pve-firmware: 3.2-4
pve-ha-manager: 3.3-1
pve-i18n: 2.4-1
pve-qemu-kvm: 6.0.0-2
pve-xtermjs: 4.12.0-1
qemu-server: 7.0-10
smartmontools: 7.2-1
spiceterm: 3.2-2
vncterm: 1.7-1
zfsutils-linux: 2.0.4-pve1

I hope one of you can point me in the right direction, as I really do not understand why Windows does not boot, even though recovery mode boots (from the disk which DISKPART does not even see).

Thank you very much for your time and help.

Best regards,
Pixelpoint
 

Attachments

  • screenshot.png
    screenshot.png
    94.5 KB · Views: 23
Last edited:
Dear Proxmox Community,

I deleted the VM yesterday, created a new one and booted from Windows 2012 R2 x64 ISO to restore the latest Windows Backup.
This worked and the VM is now up and running!

For the restore to work, I had to change the Disks to IDE.
Even when installing the correct drivers (with virtio-iso) inside the Windows 2012 R2 ISO Recovery Mode, it did not see any disks.

For anyone interested, here is the new VM config:
Code:
agent: 0
bios: ovmf
boot: order=ide2;ide0
cores: 8
efidisk0: local-lvm:vm-100-disk-1,size=4M
ide0: local-lvm:vm-100-disk-0,discard=on,size=310G,ssd=1
ide1: local-lvm:vm-100-disk-2,discard=on,size=1T,ssd=1
ide2: none,media=cdrom
ide3: local:iso/virtio-win-0.1.185.iso,media=cdrom,size=402812K
machine: pc-i440fx-6.0
memory: 32768
name: zysrv
net0: e1000=8E:D4:66:78:A9:E2,bridge=vmbr0
numa: 0
onboot: 1
ostype: win8
parent: prod_ready
scsihw: virtio-scsi-pci
smbios1: uuid=6047f5b2-205f-4163-a963-c76a452c0c63
sockets: 1
startup: order=0
usb0: host=08e6:3438,usb3=1
vmgenid: 863edd91-170a-4daa-a4a6-65720c11ee59
 
Last edited:

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!