PCI / PCIe passthrough

maxprox

Well-Known Member
Aug 23, 2011
398
29
48
Germany - Nordhessen
www.fair-comp.de
... but now getting a message telling me I need to "allow_unsafe_assigned_interrupts=1" in the kvm module options... Does anyone know exactly what that option does?

Hello tin,
are you come forward?
I saw this Blog, and everythin seems easy...
but I ran into the same problem with Proxmox 2.0
Code:
"kvm_iommu_map_guest: No interrupt remapping support, disallowing device assignment. Re-enble with "allow_unsafe_assigned_interrupts=1" module option.
have a look at here
Is there a solution in sight?

regards, maxprox
 

tin

Active Member
Aug 14, 2010
107
2
38
Northwest NSW, Australia
I ended up doing what it said and passing the "allow_unsafe_assigned_interrupts=1" option to the kvm module (create a new file in /etc/modprobe.d/ and add "options kvm allow_unsafe_assigned_interrupts=1" to it.

I've had no issues with it at all since doing that with 2.6.32-6. The VM has been stopped and started about 5 or 6 times, and it's worked great every time.
 

maxprox

Well-Known Member
Aug 23, 2011
398
29
48
Germany - Nordhessen
www.fair-comp.de
I ended up doing what it said and passing the "allow_unsafe_assigned_interrupts=1" option to the kvm module (create a new file in /etc/modprobe.d/ and add "options kvm allow_unsafe_assigned_interrupts=1" to it. ....

Hi tin,
thanks! I will try it.
And the name of the file is not important?
It must not be the name of the module concerned with?
Like: "/etc/modprobe.d/modulename.conf" ?

maxprox
 

tin

Active Member
Aug 14, 2010
107
2
38
Northwest NSW, Australia
The filename doesn't matter at all. All the files in modprobe.d are loaded one by one and treated as if they were in modprobe.conf.
I usually name the file with something that makes it stand out that I created it. That way I can spot ones I made easily, and also avoid the chance of it being overwritten by an update... EG tin-kvm-unsafe
 

maxprox

Well-Known Member
Aug 23, 2011
398
29
48
Germany - Nordhessen
www.fair-comp.de
The filename doesn't matter at all. All the files in modprobe.d are loaded one by one and treated as if they were in modprobe.conf.
I usually name the file with something that makes it stand out that I created it. That way I can spot ones I made easily, and also avoid the chance of it being overwritten by an update... EG tin-kvm-unsafe

Many Thanks!
Thats it!
I have create the file:
Code:
root@fcprox01:/etc/modprobe.d# cat kvm_iommu_map_guest.conf 
options kvm allow_unsafe_assigned_interrupts=1
root@fcprox01:/etc/modprobe.d#
And now my VDR (TV-Video-Recorder) works as it should!

maxprox
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!