Path not found error backing up VM in Proxmox VE

JMM

New Member
Aug 28, 2019
9
0
1
48
Making some tests, but I'm getting an error.
In Proxmox VE, CTs will backup just fine, but VMs will give:

ERROR: Backup of VM 102 failed - VM 102 qmp command 'backup' failed - backup register image failed: command error: HTTP Error 404 Not Found: Path not found.

Am I missing some config?

pveversion -v:
proxmox-ve: 6.2-1 (running kernel: 5.4.41-1-pve)
pve-manager: 6.2-6 (running version: 6.2-6/ee1d7754)
pve-kernel-5.4: 6.2-2
pve-kernel-helper: 6.2-2
pve-kernel-5.3: 6.1-6
pve-kernel-5.4.41-1-pve: 5.4.41-1
pve-kernel-5.4.34-1-pve: 5.4.34-2
pve-kernel-4.15: 5.4-12
pve-kernel-5.3.18-3-pve: 5.3.18-3
pve-kernel-5.3.18-1-pve: 5.3.18-1
pve-kernel-5.3.13-1-pve: 5.3.13-1
pve-kernel-4.15.18-24-pve: 4.15.18-52
pve-kernel-4.15.18-21-pve: 4.15.18-48
pve-kernel-4.15.18-20-pve: 4.15.18-46
pve-kernel-4.15.18-19-pve: 4.15.18-45
pve-kernel-4.15.18-18-pve: 4.15.18-44
pve-kernel-4.15.18-14-pve: 4.15.18-39
pve-kernel-4.15.18-12-pve: 4.15.18-36
pve-kernel-4.15.18-1-pve: 4.15.18-19
pve-kernel-4.15.17-3-pve: 4.15.17-14
pve-kernel-4.15.17-1-pve: 4.15.17-9
pve-kernel-4.13.13-2-pve: 4.13.13-33
ceph-fuse: 12.2.13-pve1
corosync: 3.0.3-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.15-pve1
libproxmox-acme-perl: 1.0.4
libpve-access-control: 6.1-1
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.1-3
libpve-guest-common-perl: 3.0-10
libpve-http-server-perl: 3.0-5
libpve-storage-perl: 6.1-8
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.2-1
lxcfs: 4.0.3-pve2
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.2-7
pve-cluster: 6.1-8
pve-container: 3.1-8
pve-docs: 6.2-4
pve-edk2-firmware: 2.20200229-1
pve-firewall: 4.1-2
pve-firmware: 3.1-1
pve-ha-manager: 3.0-9
pve-i18n: 2.1-3
pve-qemu-kvm: 5.0.0-4
pve-xtermjs: 4.3.0-1
qemu-server: 6.2-3
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.4-pve1


pvesm status:
Name Type Status Total Used Available %
ZFS1 pbs active 201608704 5501312 196107392 2.73%
local dir active 1800695424 853632512 947062912 47.41%
local-zfs zfspool active 1019322661 72259652 947063008 7.09%
nas_akf nfs active 17497222016 10794424704 6702678528 61.69%
usb_backup dir active 1800695424 853632512 947062912 47.41%


proxmox-backup-client version --repository <user>@<realm>@<host>:<datastore>:
client version: 0.8.6
server version: 0.8.6

This is what comes up in PBS:
2020-07-11T19:32:43+01:00: starting new backup on datastore 'ZFS1': "vm/102/2020-07-11T18:32:42Z"
2020-07-11T19:32:43+01:00: GET /fixed_index: 404 Not Found: Path not found.
2020-07-11T19:32:43+01:00: backup ended and finish failed: backup ended but finished flag is not set.
2020-07-11T19:32:43+01:00: removing unfinished backup
2020-07-11T19:32:43+01:00: TASK ERROR: backup ended but finished flag is not set.
 
Last edited:

t.lamprecht

Proxmox Staff Member
Staff member
Jul 28, 2015
5,547
1,817
174
South Tyrol/Italy
shop.proxmox.com
Hi,

proxmox-ve: 6.2-1 (running kernel: 5.4.41-1-pve)
pve-manager: 6.2-6 (running version: 6.2-6/ee1d7754)
pve-qemu-kvm: 5.0.0-4
qemu-server: 6.2-3

Your packages are a bit to old, this can have two reasons if you're on:
* pve-no-subscription or pvetest you're simply missing updates
* pve-enterprise - please wait until early next week, when we'll move the required updates further along if they proved enterprise stability

https://pve.proxmox.com/wiki/Package_Repositories
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!