Ovh Proxmox no bridge private IP and internet

gineta

New Member
May 16, 2012
12
2
3
Hi I try now for many hours and after I read also the OVH guides I not get idea how work this software
The problem I have is my openvz server not get internet and also not get working the Ip from OVH

My Network configuration is like that


Screenshot.png

In the OpenVz container I have That:
Screenshot-1.png

And Inside the Ubuntu Container I configure the /etc/network/interfaces like is here in the picture

Screenshot-2.png

The problem is I never rich internet and not one get the IP I setup from the Fail Over in OVH with also the MAC of OVh
Can any one here post me the correct configuration for a container in DEV or UBUNTU or why my configuration is not working?

Thanks in advance


 

Attachments

mir

Renowned Member
Apr 14, 2012
3,500
99
68
Copenhagen, Denmark
Hi I try now for many hours and after I read also the OVH guides I not get idea how work this software
The problem I have is my openvz server not get internet and also not get working the Ip from OVH

My Network configuration is like that


View attachment 946

In the OpenVz container I have That:
View attachment 948

And Inside the Ubuntu Container I configure the /etc/network/interfaces like is here in the picture

View attachment 949

The problem is I never rich internet and not one get the IP I setup from the Fail Over in OVH with also the MAC of OVh
Can any one here post me the correct configuration for a container in DEV or UBUNTU or why my configuration is not working?

Thanks in advance


You cannot have an IP for your host on a different network than the host unless you use some kind of router. The simplest way is to give your VM an IP on the same network as your host. In your case this would mean 37.x.y.z where x and y are identical to the numbers used in your host's IP address.
 

emanuelebruno

Active Member
May 1, 2012
117
0
36
Catania
emanuelebruno.it
Hi, perhaps I can give you the answer! Taking a look to this link http://guides.ovh.com/Proxmox , you can find two kind of configuration:

if you chose the venet interface card for your container, you can easily assign your ip failover like in this picture:

promox_create_vm_form_routed1.png

Otherwise, you can use the eth interface for your VM or for your CT, but in this case the configuration is more complicated because you need to indicate the followings settings:
mac address of your ip failover
ip address of your server
your new ip fail over address

every operative system has a different manner to insert these settings, so I advice to take a look to this link http://guides.ovh.com/Proxmox for a better explanation.

Speaking about your case, I suppose that you have to do in this way:

/etc/network/interfaces

auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 178.x.x.179
netmask 255.255.255.255
broadcast 178.x.x.179
post-up route add 37.x.x.254 dev eth0
post-up route add default gw 37.x.x.254
post-down route del 37.x.x.254 dev eth0
post-down route del default gw 37.x.x.254

/etc/resolv.conf
nameserver 213.186.33.99

and from proxmox console you have to write the following code:

ip route add 178.x.x.179 dev vmbr0

Please post a message if I helped you!
 
Last edited:

gineta

New Member
May 16, 2012
12
2
3
Hi, perhaps I can give you the answer! Taking a look to this link http://guides.ovh.com/Proxmox , you can find two kind of configuration:

if you chose the venet interface card for your container, you can easily assign your ip failover like in this picture:

View attachment 950

Otherwise, you can use the eth interface for your VM or for your CT, but in this case the configuration is more complicated because you need to indicate the followings settings:
mac address of your ip failover
ip address of your server
your new ip fail over address

every operative system has a different manner to insert these settings, so I advice to take a look to this link http://guides.ovh.com/Proxmox for a better explanation.

Speaking about your case, I suppose that you have to do in this way:

/etc/network/interfaces

auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 178.x.x.179
netmask 255.255.255.255
broadcast 178.x.x.179
post-up route add 37.x.x.254 dev eth0
post-up route add default gw 37.x.x.254
post-down route del 37.x.x.254 dev eth0
post-down route del default gw 37.x.x.254

/etc/resolv.conf
nameserver 213.186.33.99

and from proxmox console you have to write the following code:

ip route add 178.x.x.179 dev vmbr0

Please post a message if I helped you!
I believe I try like that before but I get after ip route add 178.x.x.179 dev vmbr0 --->Cannot find device "vmbr0"
 

emanuelebruno

Active Member
May 1, 2012
117
0
36
Catania
emanuelebruno.it
I believe I try like that before but I get after ip route add 178.x.x.179 dev vmbr0 --->Cannot find device "vmbr0"
Hi Gineta, why don't use venet instead of eth0 ? using the venet interface you don't need to specify any gateway and any mac address; if you create a CT with venet interface, you need only to specify the ovh ip fail over....
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!