OpenvSwitch setup

Discussion in 'Proxmox VE: Installation and configuration' started by snoopel, May 2, 2014.

  1. snoopel

    snoopel New Member

    Joined:
    May 2, 2014
    Messages:
    3
    Likes Received:
    0
    Hi @all,

    Iam a new user of proxmox. I want to configure a OpenvSwitch Setup in a new proxmox installation. I have to network-interface (eth0, eth1), I want to configure these interface as active/backup bonding. I installed the openvswitch-switch package and create a new device over the GUI of proxmox. My currently interfaces looks like this:

    Code:
    # network interface settings
    auto lo
    iface lo inet loopback
    
    allow-vmbr1 eth1
    iface eth1 inet manual
            ovs_type OVSPort
            ovs_bridge vmbr1
    
    allow-vmbr1 eth0
    iface eth0 inet manual
            ovs_type OVSPort
            ovs_bridge vmbr1
    
    allow-vmbr1 bond0
    iface bond0 inet manual
            ovs_type OVSBond
            ovs_bridge vmbr1
            ovs_bonds eth0 eth1
            ovs_options bond_mode=active-backup
    
    iface vmbr0 inet manual
            bridge_ports none
            bridge_stp off
            bridge_fd 0
    
    auto vmbr1
    iface vmbr1 inet static
            address  192.168.0.22
            netmask  255.255.255.0
            gateway  192.168.0.1
            ovs_type OVSBridge
            ovs_ports bond0
    
    proxmox does not find vmbr1. What is wrong?
     
    #1 snoopel, May 2, 2014
    Last edited: May 2, 2014
  2. spirit

    spirit Well-Known Member
    Proxmox VE Subscriber

    Joined:
    Apr 2, 2010
    Messages:
    3,012
    Likes Received:
    81
    do you have reboot your host after update the /etc/network/interfaces ?

    also, can you send the result of the command:

    "ovs-vsctl show"
     
  3. snoopel

    snoopel New Member

    Joined:
    May 2, 2014
    Messages:
    3
    Likes Received:
    0
    Hey spirit,

    yes, I do a reboot after configuration. Now, I do the openvswitch configuration manually, ovs-vsctl add-br and ovs-vsctl add-bond.
    Code:
    root@myserv:~# ovs-vsctl show
    01b0ff45-01e2-4b28-85d5-bc91b916e04d
        Bridge "vmbr1"
            Port "vmbr1"
                Interface "vmbr1"
                    type: internal
            Port "bond0"
                Interface "eth0"
                Interface "eth1"
        ovs_version: "1.4.2"
    root@myserv:~#
    
    but the slave interfaces or bond0 interface won't be started. I can do ifup vmbr1 and ifconfig eth0 up and the vmbr1 will be working. A pure setup by the proxmox gui do not working for me! :(
     
  4. spirit

    spirit Well-Known Member
    Proxmox VE Subscriber

    Joined:
    Apr 2, 2010
    Messages:
    3,012
    Likes Received:
    81
    Try to use classic configuration for ethX interface (as you use bonding, ethX are not managed by openvswitch)


    Code:
    # network interface settings
    auto lo
    iface lo inet loopback
    
    
    auto eth1
    iface eth1 inet manual
    
    
    auto eth0
    iface eth0 inet manual
    
    
    allow-vmbr1 bond0
    iface bond0 inet manual
            ovs_type OVSBond
            ovs_bridge vmbr1
            ovs_bonds eth0 eth1
            ovs_options bond_mode=active-backup
    
    
    
    
    auto vmbr1
    iface vmbr1 inet static
            address  192.168.0.22
            netmask  255.255.255.0
            gateway  192.168.0.1
            ovs_type OVSBridge
            ovs_ports bond0
    
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice