ODROID H2+ Realtek RTL8125B Network Interface Issues

cjmacks

New Member
Jul 1, 2020
7
3
3
40
Good Afternoon,

I recently picked up a ODROID H2+ to install proxmox on for lighter virtualization tasks. I was unable to install directly from the proxmox ISO as there was no network interface detected(I thought that with the new 5.4 kernel it would recognize the NIC, sadly wrong). So I tried loading up Debian Buster and getting that installed. After working though https://wiki.odroid.com/odroid-h2/hardware/install_ethernet_driver_on_h2plus I was able to get the NIC recognized by the fresh Debian install. I followed the instructions https://pve.proxmox.com/wiki/Install_Proxmox_VE_on_Debian_Buster to setup the /etc/hosts file and setup the repository. I am able to install proxmox and load the webpage. When I log in and create a virtual bridge, it fails to apply configuration and I need to reboot to apply changes. Coming back up from a reboot, Debian/PVE has lost the ability to talk to the NIC. It still shows up looking in DMESG as
```
[ 0.265954] pci 0000:02:00.0: [10ec:8125] type 00 class 0x020000
[ 0.265998] pci 0000:02:00.0: reg 0x10: [io 0xe000-0xe0ff]
[ 0.266037] pci 0000:02:00.0: reg 0x18: [mem 0xa1200000-0xa120ffff 64bit]
[ 0.266061] pci 0000:02:00.0: reg 0x20: [mem 0xa1210000-0xa1213fff 64bit]
[ 0.266195] pci 0000:02:00.0: supports D1 D2
[ 0.266197] pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
```


When I try and reinstall drivers within the proxmox console it fails out with the following error


```
root@jrabbit:/home/chris/Downloads/r8125-9.003.05# sudo ./autorun.sh

Check old driver and unload it.
Build the module and install
make[2]: *** /lib/modules/5.4.44-1-pve/build: No such file or directory. Stop.
make[1]: *** [Makefile:147: clean] Error 2
make: *** [Makefile:47: clean] Error 2
```

I am able to access the internet though usb tethering from my phone. Any suggestions on how to get this bad boy up and working?

P.S. Additional output can provide more as requested.
ip a
```
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: vmbr0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
link/ether ee:71:32:4c:7a:cb brd ff:ff:ff:ff:ff:ff
inet 192.168.0.60/23 brd 192.168.1.255 scope global vmbr0
valid_lft forever preferred_lft forever
inet6 fe80::ec71:32ff:fe4c:7acb/64 scope link
valid_lft forever preferred_lft forever
3: enp0s21f0u4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
link/ether ab:91:ae:17:da:0c brd ff:ff:ff:ff:ff:ff
inet 192.168.42.229/24 brd 192.168.42.255 scope global dynamic noprefixroute enp0s21f0u4
```
 
  • Like
Reactions: Tom223

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,994
630
118
hi,

Check old driver and unload it.
Build the module and install
make[2]: *** /lib/modules/5.4.44-1-pve/build: No such file or directory. Stop.
make[1]: *** [Makefile:147: clean] Error 2
make: *** [Makefile:47: clean] Error 2

if you see source of autorun.sh, it's trying to find the headers for the current kernel.

get the headers: apt install pve-headers-$(uname -r)

then run the script again.
 
  • Like
Reactions: Tom223

cjmacks

New Member
Jul 1, 2020
7
3
3
40
That worked like a charm. Thank you. I am planning on creating a guide to get proxmox up and running on the ODROID. I'll defiantly give you a shout out for that fix.
 

PigLover

Well-Known Member
Apr 8, 2013
119
36
48
You might want to install the drivers using the dkms method (from the .deb file) rather than using the direct installer (its described on Odroid's wiki). If you install it directly with the driver compile script then you'll lose the driver and have to re-install any time you do an update that brings in a new kernel build. The dkms install will leave a hook in place to re-install the driver anytime the kernel is updated.
 

ghowse

New Member
Feb 14, 2019
5
0
1
64

Tom223

New Member
Jul 4, 2020
2
1
1
60
hi,



if you see source of autorun.sh, it's trying to find the headers for the current kernel.

get the headers: apt install pve-headers-$(uname -r)

then run the script again.

Unfortunately, this didn't work for me. Same situation, very same Odroid barebone computer. I used the Proxmox image to install and used a usb ethernet card to get over the error (no network) at installation time.
But now I followed your advice and I still get the same error:
Code:
root@engine1:/usr/src/r8125-9.003.05# apt install pve-headers-$(uname -r)
Reading package lists... Done
Building dependency tree
Reading state information... Done
pve-headers-5.4.44-2-pve is already the newest version (5.4.44-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

root@engine1:/usr/src/r8125-9.003.05# ./autorun.sh

Check old driver and unload it.
Build the module and install
make[2]: *** No rule to make target 'clean'.  Stop.
make[1]: *** [Makefile:147: clean] Error 2
make: *** [Makefile:47: clean] Error 2
Maybe you have another hint for me?
Many Thanks!
 
  • Like
Reactions: Sahare

cjmacks

New Member
Jul 1, 2020
7
3
3
40

metalsepp

New Member
Aug 25, 2020
3
1
3
Bad Aibling, Germany
i have the same problem as cjmacks with the network drivers for the Odroid H2+. But when i try to install the pve-headers i get the following error message:

Code:
root@homeserver:/home/download/r8125-9.003.05# apt install pve-headers-$(uname -r)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package pve-headers-5.4.34-1-pve
E: Couldn't find any package by glob 'pve-headers-5.4.34-1-pve'
E: Couldn't find any package by regex 'pve-headers-5.4.34-1-pve'
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,994
630
118
i have the same problem as cjmacks with the network drivers for the Odroid H2+. But when i try to install the pve-headers i get the following error message:

Code:
root@homeserver:/home/download/r8125-9.003.05# apt install pve-headers-$(uname -r)
Reading package lists... Done
Building dependency tree     
Reading state information... Done
E: Unable to locate package pve-headers-5.4.34-1-pve
E: Couldn't find any package by glob 'pve-headers-5.4.34-1-pve'
E: Couldn't find any package by regex 'pve-headers-5.4.34-1-pve'

do you have the pve repositories configured?

what do you get:
Code:
pveversion -v
apt update
 

metalsepp

New Member
Aug 25, 2020
3
1
3
Bad Aibling, Germany
Code:
root@homeserver:~# pveversion -v
proxmox-ve: 6.2-1 (running kernel: 5.4.34-1-pve)
pve-manager: 6.2-4 (running version: 6.2-4/9824574a)
pve-kernel-5.4: 6.2-1
pve-kernel-helper: 6.2-1
pve-kernel-5.4.34-1-pve: 5.4.34-2
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.3-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.15-pve1
libproxmox-acme-perl: 1.0.3
libpve-access-control: 6.1-1
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.1-2
libpve-guest-common-perl: 3.0-10
libpve-http-server-perl: 3.0-5
libpve-storage-perl: 6.1-7
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.2-1
lxcfs: 4.0.3-pve2
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.2-1
pve-cluster: 6.1-8
pve-container: 3.1-5
pve-docs: 6.2-4
pve-edk2-firmware: 2.20200229-1
pve-firewall: 4.1-2
pve-firmware: 3.1-1
pve-ha-manager: 3.0-9
pve-i18n: 2.1-2
pve-qemu-kvm: 5.0.0-2
pve-xtermjs: 4.3.0-1
qemu-server: 6.2-2
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.3-pve1
root@homeserver:~# apt update
Hit:1 http://ftp.de.debian.org/debian buster InRelease
Hit:2 http://ftp.de.debian.org/debian buster-updates InRelease                 
Err:3 https://enterprise.proxmox.com/debian/pve buster InRelease               
  401  Unauthorized [IP: 2a01:7e0:0:424::249 443]
Hit:4 http://security.debian.org buster/updates InRelease                     
Reading package lists... Done
E: Failed to fetch https://enterprise.proxmox.com/debian/pve/dists/buster/InRelease  401  Unauthorized [IP: 2a01:7e0:0:424::249 443]
E: The repository 'https://enterprise.proxmox.com/debian/pve buster InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Hi,
no I have not yet adapted the repository. What is the procedure?
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,994
630
118
Code:
root@homeserver:~# pveversion -v
proxmox-ve: 6.2-1 (running kernel: 5.4.34-1-pve)
pve-manager: 6.2-4 (running version: 6.2-4/9824574a)
pve-kernel-5.4: 6.2-1
pve-kernel-helper: 6.2-1
pve-kernel-5.4.34-1-pve: 5.4.34-2
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.0.3-pve1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.15-pve1
libproxmox-acme-perl: 1.0.3
libpve-access-control: 6.1-1
libpve-apiclient-perl: 3.0-3
libpve-common-perl: 6.1-2
libpve-guest-common-perl: 3.0-10
libpve-http-server-perl: 3.0-5
libpve-storage-perl: 6.1-7
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.2-1
lxcfs: 4.0.3-pve2
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.2-1
pve-cluster: 6.1-8
pve-container: 3.1-5
pve-docs: 6.2-4
pve-edk2-firmware: 2.20200229-1
pve-firewall: 4.1-2
pve-firmware: 3.1-1
pve-ha-manager: 3.0-9
pve-i18n: 2.1-2
pve-qemu-kvm: 5.0.0-2
pve-xtermjs: 4.3.0-1
qemu-server: 6.2-2
smartmontools: 7.1-pve2
spiceterm: 3.1-1
vncterm: 1.6-1
zfsutils-linux: 0.8.3-pve1
root@homeserver:~# apt update
Hit:1 http://ftp.de.debian.org/debian buster InRelease
Hit:2 http://ftp.de.debian.org/debian buster-updates InRelease                
Err:3 https://enterprise.proxmox.com/debian/pve buster InRelease              
  401  Unauthorized [IP: 2a01:7e0:0:424::249 443]
Hit:4 http://security.debian.org buster/updates InRelease                    
Reading package lists... Done
E: Failed to fetch https://enterprise.proxmox.com/debian/pve/dists/buster/InRelease  401  Unauthorized [IP: 2a01:7e0:0:424::249 443]
E: The repository 'https://enterprise.proxmox.com/debian/pve buster InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Hi,
no I have not yet adapted the repository. What is the procedure?



if you don't have a subscription you need to change the repository to pve-no-subscription.

see here[0]

[0]: https://pve.proxmox.com/wiki/Package_Repositories
 
  • Like
Reactions: metalsepp

metalsepp

New Member
Aug 25, 2020
3
1
3
Bad Aibling, Germany
Many thanks for your help. With this setting I was able to install the pve-headers and then the network drivers. I'm a bloody beginner with PVE and want to install with a private homeserver. I'm also not necessarily a Linux-professional, so I'm glad for any help. I am absolutely thrilled how fast one is helped here.
 
  • Like
Reactions: oguz

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!