[SOLVED] No VGA during installation on HP Z230 SFF

costis

New Member
Dec 31, 2021
3
1
3
40
Installer (Proxmox VE 7.1 ISO Installer) does not load on an old but working HP Z230 SFF. I've tried different vga=791 type of modes combined with or without nomodeset but nothing seems to work. I see the grub menu and then either nothing or X does not start.
When I try to configure a custom xorg.conf I end up with a No Screens fatal error. The best I could get was a screen being flooded with message:
"fb: trapped write at ... on channel ... engine ... client .. subclient PAGE_NOT_PRESENT" - I think this is a nouveau error (screenshot here).

Are there any recommendations so as I can run the installer?
Alternatively, installing Proxmox on top of Debian Bullseye gives an (almost?) identical environment, right?
 
Last edited:

leesteken

Famous Member
May 31, 2020
2,379
509
118
Alternatively, installing Proxmox on top of Debian Bullseye gives an (almost?) identical environment, right?
Yes, except that is more difficult to make it boot from ZFS. Also Debian installs a little more software by default (sudo for example, I think), but that should not be a problem.
 

costis

New Member
Dec 31, 2021
3
1
3
40
Yes, except that is more difficult to make it boot from ZFS. Also Debian installs a little more software by default (sudo for example, I think), but that should not be a problem.
This is my take, too. I stayed up until early morning to do it. I consider this solved and hope the installer provides support for older video hardware. So far, I've superficially tested it with pihole/plex/pfsense and the machine is OK, but it's too early to say.
 

costis

New Member
Dec 31, 2021
3
1
3
40
Just for network stumblers, today I tried to installed Proxmox in another identical machine but in the meantime I found a DVI cable. The proxmox installer worked with DVI setting nomodeset as a kernel parameter in GRUB, although the image quality was really really bad and barely visible. Perhaps the cable was not good, or even the video card itself. Anyway, It didn't work with the VGA or Display Port and I'm glad it was installed directly from the proxmox installer through DVI.
 
  • Like
Reactions: leesteken

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!