1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no network interface on NetBSD 5.1.2 guest

Discussion in 'Proxmox VE: Installation and configuration' started by hazuki, Feb 20, 2012.

  1. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    [FIXED] no network interface on NetBSD 5.1.2 guest

    Hi all !

    My problème is quite simple :

    Whatever the network adapter I choose, the NetBSD guest doesn't detect it. Is it normal ?

    I run it with kvm
     
    #1 hazuki, Feb 20, 2012
    Last edited: Jun 25, 2013
  2. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    10,829
    Likes Received:
    35
  3. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    I tried only three model in the GUI because I use LVM as storage.
    I don't know how to access to the vm's data.
     
  4. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    I modified the network adapter in the conf file (/etc/pve/qemu-server/102.conf for me).
    I replaced the net driver by "ne2k_pci" and reboot the installation and still no network card.
    I'll search any other solution by my side.
     
  5. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    I tried pcnet too and nothing work for the moment ...
     
  6. tom

    tom Proxmox Staff Member
    Staff Member

    Joined:
    Aug 29, 2006
    Messages:
    10,829
    Likes Received:
    35
    I just tried it here, I can´t even install it. can you instruct me? (iso, settings, etc.)
     
  7. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    For the installation on pve-proxmox, I use the iso for the i386 arch.

    I tried with amd64 and it didn't find /dev/console and for the moment I didn't search why.

    And NetBSD doesn't seem to recognize virtIO hard drive. (I don't why for the moment)

    All isos can be finded in : ftp://iso.fr.netbsd.org/pub/NetBSD/iso/5.1.2/ (french mirror)

    At boot, we lanch the installer without acpi neither smp (it makes NetBSD slow)

    The first part of the installation is identifying of drive and partitioning.

    after that is the installation of the system and you have plural choice :

    -> from CD
    -> from HTTP or FTP
    -> from NFS

    For testing network card, I use FTP.

    The first step is configuring network (in our case, it's here that NetBSD says that there are no usable network adapter) dhcp or static as you want.

    The second one is set the FTP parameters, I use

    host : ftp.fr.netbsd.org (still french mirror)
    base directory : pub/NetBSD/NetBSD-5.1.2
    sets directory : i386/binary/sets/

    The others field can keep their value.

    After that, the installer will download and extract all it need and ask you question about root password, password storage, login shell etc...


    Sorry for my poor English, I'm french

    Post scriptum :
    I found an article which may interess
    -> http://www.ezunix.org/index.php?title=NetBSD_5_on_KVM
     
    #7 hazuki, Feb 21, 2012
    Last edited: Feb 21, 2012
  8. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    Hi,

    NetBSD 6.0 Beta is now out, I'll test this evening to see if it have some improvement for my problem in the guest side.
     
  9. ashes

    ashes Member

    Joined:
    Feb 1, 2010
    Messages:
    33
    Likes Received:
    0
  10. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    but without network it's quite difficult to download from git

    p.s : I solved this problem but downloading on the host and creating ISO from the directory
     
    #10 hazuki, Mar 22, 2012
    Last edited: Mar 22, 2012
  11. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    This virtio drivers doesn't compile.
     
  12. udo

    udo Active Member

    Joined:
    Apr 22, 2009
    Messages:
    4,467
    Likes Received:
    21
    Hi,
    I don't know NetBSD, but pfsense (also bsd-based) work well with the driver rtl8139.

    Udo
     
  13. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    I think that NetBSD can be considered as incompatible with KVM and the version 6.0_BETA doesn't boot at all
     
  14. SalokcinX

    SalokcinX New Member

    Joined:
    Oct 2, 2012
    Messages:
    1
    Likes Received:
    0
  15. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
  16. hazuki

    hazuki New Member

    Joined:
    Feb 20, 2012
    Messages:
    15
    Likes Received:
    0
    It works for NetBSD 6.0_RC2 with arch AMD64 and I386.

    But It need E1000 for network interfaces and CD need the option "NO ACPI and NO SMP" to boot.

    After the installation, the system boot normaly with his network interfaces.

    P.S. : Have I to add a "[FIXED]" prefix on the title of this topic ?
     

Share This Page