No management after upgrade to 6.x

desperate250

New Member
Aug 22, 2019
2
0
1
58
Hello,

I'm new here so please forgive me if I missed to give some information.

I have a standalone Proxmox server which I just upgraded from 5.4 to 6.x (latest of today). Upgrade went without issues. After the last reboot, my (autostart) VMs came up and clients can work just as before.

However, I cannot reach the Web interface for management. I cannot even ping the interfaces which are not VM interfaces.
I have two interfaces for management (both via USB NIC, since the 2 built-ins are for VMs) . Both are not reachable, but they are UP and the command "ip address" shows that. I can even ping these IPs from the console (direct attached keyboard and monitor), which is now my only chance of management.

What can be wrong here? Is there a new kind of firewall now, which I missed in the docs?
 
first guess: check your '/etc/hosts' - you need to make sure that you can resolve the name that's reported when you type `uname -n`

else - please log into the node via ssh and check the journal for more hints to what went wrong (`journalctl -u pveproxy` (for the webfacing proxy) or `journalctl -b` for the whole log since booting))
 
Before upgrading to version 6, I was able to manage Proxmox using all IP addresses I have configured on several interfaces. After migration, it did accept none.
You were right with the /etc/hosts. It was set to an old USB LAN interface IP which did not exist anymore. I reinserted this USB interface, rebootet and now I can access management on this interface only. Why is ist impossible to ping or access management on other interfaces like this one, which worked on 5.4:

11: vmbr3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 00:e0:4c:84:02:6a brd ff:ff:ff:ff:ff:ff
inet 192.168.1.13/24 brd 192.168.1.255 scope global vmbr3
valid_lft forever preferred_lft forever
inet6 fe80::2e0:4cff:fe84:26a/64 scope link
valid_lft forever preferred_lft forever
 
* pveproxy usually listens to all interfaces configured
* do you have a firewall enabled? (in that case the default is to only let the local-network (which again depends on the entry in '/etc/hosts' connect to the GUI)
* change the '/etc/hosts' entry to reflect your current management ip

Hope this helps!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!