No Internet connection on Windows Server 2008 R2 Enterprise

phongtnit

New Member
Apr 4, 2012
18
0
1
Hi,

I installed Windows Server 2008 R2 Enterprise on Proxmox 2.0. I installed VirtIO and Realtek network drivers on the server. However, I see there are no Internet connections.

Please help me to fix it. Thanks a lot,


Image on Windows Server 2008 R2 Enterprise:

Image of server's hardware:



The server had 5 network cards.
 

mmenaz

Member
Jun 25, 2009
736
5
18
Northern east Italy
How is your network like? IP of your gateway, dns, proxmox IP. Does Proxmox reach internet? i.e. ping www.google.com ?
If so, how is the setting of one of your Win2k8 guest? Let's use only one (disable i.e. realteck) and set it's network parameters properly (IP address, netmask, gateway, dns...)
best regards
 

phongtnit

New Member
Apr 4, 2012
18
0
1
How is your network like? IP of your gateway, dns, proxmox IP. Does Proxmox reach internet? i.e. ping www.google.com ?
If so, how is the setting of one of your Win2k8 guest? Let's use only one (disable i.e. realteck) and set it's network parameters properly (IP address, netmask, gateway, dns...)
best regards
Thanks,

My proxmox and other Linux guest OS can access Internet. I'm using DHCP to assign IP address automatically on Windows guest machine. I tried to disable RealTeck and used only VirtIO network card, but it didn't work too.
 

WRE-LLC

New Member
Jan 18, 2010
5
0
1
Try using the e1000 network card, generally it is the only card that I can enable for Windows without having to load drivers
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!