No access after update

May 15, 2022
7
0
1
Hi, i can't access to the GUI after update (apt-get update && apt-get upgrade && apt-get dist-upgrade). i have SSH access.

pveversion -v

proxmox-ve: 6.4-1 (running kernel: 5.4.174-2-pve)
pve-manager: 6.2-4 (running version: 6.2-4/9824574a)
pve-kernel-5.4: 6.4-15
pve-kernel-helper: 6.4-15
pve-kernel-5.4.174-2-pve: 5.4.174-2
pve-kernel-5.4.34-1-pve: 5.4.34-2
ceph-fuse: 12.2.11+dfsg1-2.1+b1
corosync: 3.1.5-pve2~bpo10+1
criu: 3.11-3
glusterfs-client: 5.5-3
ifupdown: 0.8.35+pve1
ksm-control-daemon: 1.3-1
libjs-extjs: 6.0.1-10
libknet1: 1.22-pve2~bpo10+1
libproxmox-acme-perl: 1.1.0
libpve-access-control: 6.4-3
libpve-apiclient-perl: 3.1-3
libpve-common-perl: 6.1-2
libpve-guest-common-perl: 3.1-5
libpve-http-server-perl: 3.2-3
libpve-storage-perl: 6.1-7
libqb0: 1.0.5-1
libspice-server1: 0.14.2-4~pve6+1
lvm2: 2.03.02-pve4
lxc-pve: 4.0.6-2
lxcfs: 4.0.6-pve1
novnc-pve: 1.1.0-1
proxmox-mini-journalreader: 1.1-1
proxmox-widget-toolkit: 2.6-2
pve-cluster: 6.4-1
pve-container: 3.1-5
pve-docs: 6.4-2
pve-edk2-firmware: 2.20200531-1
pve-firewall: 4.1-4
pve-firmware: 3.3-2
pve-ha-manager: 3.1-1
pve-i18n: 2.3-1
pve-qemu-kvm: 5.2.0-6
pve-xtermjs: 4.7.0-3
qemu-server: 6.2-2
smartmontools: 7.2-pve2
spiceterm: 3.1-1
vncterm: 1.6-2
zfsutils-linux: 2.0.7-pve1
 
May 15, 2022
7
0
1
I see this:

systemctl status pvedaemon

● pvedaemon.service - PVE API Daemon
Loaded: loaded (/lib/systemd/system/pvedaemon.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2022-05-15 19:52:20 CEST; 3s ago
Process: 7337 ExecStart=/usr/bin/pvedaemon start (code=exited, status=255/EXCEPTION)

May 15 19:52:20 nodo2 systemd[1]: pvedaemon.service: Service RestartSec=100ms expired, scheduling restart.
May 15 19:52:20 nodo2 systemd[1]: pvedaemon.service: Scheduled restart job, restart counter is at 5.
May 15 19:52:20 nodo2 systemd[1]: Stopped PVE API Daemon.
May 15 19:52:20 nodo2 systemd[1]: pvedaemon.service: Start request repeated too quickly.
May 15 19:52:20 nodo2 systemd[1]: pvedaemon.service: Failed with result 'exit-code'.
May 15 19:52:20 nodo2 systemd[1]: Failed to start PVE API Daemon.
May 15 19:52:22 nodo2 systemd[1]: pvedaemon.service: Start request repeated too quickly.
May 15 19:52:22 nodo2 systemd[1]: pvedaemon.service: Failed with result 'exit-code'.
May 15 19:52:22 nodo2 systemd[1]: Failed to start PVE API Daemon.

Some ideas? I'm desperate.
 
May 15, 2022
7
0
1
I keep researching, I add all the information I find to get help

apt-get dist-upgrade


Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
libpve-storage-perl pve-container pve-manager
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.


apt-get install libpve-storage-perl


Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpve-storage-perl : Depends: libpve-common-perl (>= 6.4-1) but 6.1-2 is to be installed
Depends: proxmox-backup-client (>= 0.8.2~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


apt remove libpve-storage-perl


Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
proxmox-archive-keyring
Use 'apt autoremove' to remove it.
The following packages will be REMOVED:
libpve-guest-common-perl libpve-storage-perl proxmox-ve pve-container pve-ha-manager pve-manager qemu-server
0 upgraded, 0 newly installed, 7 to remove and 1 not upgraded.
After this operation, 12.0 MB disk space will be freed.
Do you want to continue? [Y/n] y
W: (pve-apt-hook) !! WARNING !!
W: (pve-apt-hook) You are attempting to remove the meta-package 'proxmox-ve'!
W: (pve-apt-hook)
W: (pve-apt-hook) If you really want to permanently remove 'proxmox-ve' from your system, run the following command
W: (pve-apt-hook) touch '/please-remove-proxmox-ve'
W: (pve-apt-hook) run apt purge proxmox-ve to remove the meta-package
W: (pve-apt-hook) and repeat your apt invocation.
W: (pve-apt-hook)
W: (pve-apt-hook) If you are unsure why 'proxmox-ve' would be removed, please verify
W: (pve-apt-hook) - your APT repository settings
W: (pve-apt-hook) - that you are using 'apt full-upgrade' to upgrade your system
E: Sub-process /usr/share/proxmox-ve/pve-apt-hook returned an error code (1)
E: Failure running script /usr/share/proxmox-ve/pve-apt-hook

apt-get install libpve-storage-perl


Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libpve-storage-perl : Depends: libpve-common-perl (>= 6.4-1) but 6.1-2 is to be installed
Depends: proxmox-backup-client (>= 0.8.2~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
 
Last edited:

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,052
989
163
34
Vienna
can you post the complete output of
Code:
apt-get update

as well as
Code:
journalctl -b -u pveproxy -u pvedaemon
 
May 15, 2022
7
0
1
thanks for your answer

I managed to update the distribution and everything started working.

The problem I have now is that the performance is worse than before.
 
May 15, 2022
7
0
1
journalctl -b -u pveproxy -u pvedaemon

Code:
-- Logs begin at Sun 2022-05-15 20:34:29 CEST, end at Mon 2022-05-16 12:53:54 CE
May 15 20:34:34 nodo2 systemd[1]: Starting PVE API Daemon...
May 15 20:34:35 nodo2 pvedaemon[1816]: no such standard option 'prune-backups'
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/sha
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/sha
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/sha
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/sha
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/sha
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/sha
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/sha
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/bin
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr
May 15 20:34:35 nodo2 systemd[1]: pvedaemon.service: Control process exited, cod
May 15 20:34:35 nodo2 systemd[1]: pvedaemon.service: Failed with result 'exit-co
May 15 20:34:35 nodo2 systemd[1]: Failed to start PVE API Daemon.
May 15 20:34:35 nodo2 systemd[1]: Starting PVE API Proxy Server...
lines 1-23...skipping...
-- Logs begin at Sun 2022-05-15 20:34:29 CEST, end at Mon 2022-05-16 12:53:54 CEST. --
May 15 20:34:34 nodo2 systemd[1]: Starting PVE API Daemon...
May 15 20:34:35 nodo2 pvedaemon[1816]: no such standard option 'prune-backups'
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/share/perl5/PVE/VZDump/Plugin.pm line 11.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/VZDump/Plugin.pm line 11.
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/share/perl5/PVE/API2/Qemu.pm line 34.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2/Qemu.pm line 34.
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/share/perl5/PVE/HA/Resources/PVEVM.pm line 16.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/HA/Resources/PVEVM.pm line 19.
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/share/perl5/PVE/HA/Env/PVE2.pm line 21.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/HA/Env/PVE2.pm line 21.
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/share/perl5/PVE/API2/Cluster.pm line 14.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2/Cluster.pm line 14.
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/share/perl5/PVE/API2.pm line 14.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2.pm line 14.
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/share/perl5/PVE/Service/pvedaemon.pm line 8.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/Service/pvedaemon.pm line 8.
May 15 20:34:35 nodo2 pvedaemon[1816]: Compilation failed in require at /usr/bin/pvedaemon line 11.
May 15 20:34:35 nodo2 pvedaemon[1816]: BEGIN failed--compilation aborted at /usr/bin/pvedaemon line 11.
May 15 20:34:35 nodo2 systemd[1]: pvedaemon.service: Control process exited, code=exited, status=255/EXCEPTION
May 15 20:34:35 nodo2 systemd[1]: pvedaemon.service: Failed with result 'exit-code'.
May 15 20:34:35 nodo2 systemd[1]: Failed to start PVE API Daemon.
May 15 20:34:35 nodo2 systemd[1]: Starting PVE API Proxy Server...
May 15 20:34:35 nodo2 systemd[1]: pvedaemon.service: Service RestartSec=100ms expired, scheduling restart.
May 15 20:34:35 nodo2 systemd[1]: pvedaemon.service: Scheduled restart job, restart counter is at 1.
May 15 20:34:35 nodo2 systemd[1]: Stopped PVE API Daemon.
May 15 20:34:35 nodo2 systemd[1]: Starting PVE API Daemon...
May 15 20:34:36 nodo2 pvedaemon[1851]: no such standard option 'prune-backups'
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/share/perl5/PVE/VZDump/Plugin.pm line 11.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/VZDump/Plugin.pm line 11.
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/share/perl5/PVE/API2/Qemu.pm line 34.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2/Qemu.pm line 34.
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/share/perl5/PVE/HA/Resources/PVEVM.pm line 16.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/HA/Resources/PVEVM.pm line 19.
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/share/perl5/PVE/HA/Env/PVE2.pm line 21.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/HA/Env/PVE2.pm line 21.
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/share/perl5/PVE/API2/Cluster.pm line 14.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2/Cluster.pm line 14.
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/share/perl5/PVE/API2.pm line 14.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2.pm line 14.
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/share/perl5/PVE/Service/pvedaemon.pm line 8.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/Service/pvedaemon.pm line 8.
May 15 20:34:36 nodo2 pvedaemon[1851]: Compilation failed in require at /usr/bin/pvedaemon line 11.
May 15 20:34:36 nodo2 pvedaemon[1851]: BEGIN failed--compilation aborted at /usr/bin/pvedaemon line 11.
May 15 20:34:36 nodo2 systemd[1]: pvedaemon.service: Control process exited, code=exited, status=255/EXCEPTION
May 15 20:34:36 nodo2 systemd[1]: pvedaemon.service: Failed with result 'exit-code'.
May 15 20:34:36 nodo2 systemd[1]: Failed to start PVE API Daemon.
May 15 20:34:36 nodo2 systemd[1]: pvedaemon.service: Service RestartSec=100ms expired, scheduling restart.
May 15 20:34:36 nodo2 systemd[1]: pvedaemon.service: Scheduled restart job, restart counter is at 2.
May 15 20:34:36 nodo2 systemd[1]: Stopped PVE API Daemon.
May 15 20:34:36 nodo2 systemd[1]: Starting PVE API Daemon...
May 15 20:34:37 nodo2 pveproxy[1853]: no such standard option 'prune-backups'
May 15 20:34:37 nodo2 pveproxy[1853]: Compilation failed in require at /usr/share/perl5/PVE/VZDump/Plugin.pm line 11.
May 15 20:34:37 nodo2 pveproxy[1853]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/VZDump/Plugin.pm line 11.
May 15 20:34:37 nodo2 pveproxy[1853]: Compilation failed in require at /usr/share/perl5/PVE/API2/Qemu.pm line 34.
May 15 20:34:37 nodo2 pveproxy[1853]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2/Qemu.pm line 34.
May 15 20:34:37 nodo2 pveproxy[1853]: Compilation failed in require at /usr/share/perl5/PVE/HA/Resources/PVEVM.pm line 16.
May 15 20:34:37 nodo2 pveproxy[1853]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/HA/Resources/PVEVM.pm line 19.
May 15 20:34:37 nodo2 pveproxy[1853]: Compilation failed in require at /usr/share/perl5/PVE/HA/Env/PVE2.pm line 21.
May 15 20:34:37 nodo2 pveproxy[1853]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/HA/Env/PVE2.pm line 21.
May 15 20:34:37 nodo2 pveproxy[1853]: Compilation failed in require at /usr/share/perl5/PVE/API2/Cluster.pm line 14.
May 15 20:34:37 nodo2 pveproxy[1853]: BEGIN failed--compilation aborted at /usr/share/perl5/PVE/API2/Cluster.pm line 14.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
8,052
989
163
34
Vienna
All. Vms haven´t performance.

I discovered that after the update
Code:
cat /sys/devices/system/cpu/smt/active
1

When the total os CPUs is 56
that just says that "smt" (or "hyperthreading" on intel) is active

what do you mean exactly with the performance? what exactly is slower? is anything heavy running? what is your hardware? how many vms are running? memory? disk ?
 
May 15, 2022
7
0
1
Yesterday 14 VM running OK.

Today 3 VM and all is slower. Windows VM, TS logging is very slow or almost impossible.

My hardware is:

56 x Intel(R) Xeon(R) CPU E5-2680 v4 @ 2.40GHz (2 Socket)
512GB RAM
RAID5 SSD 2.30TB
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!