proxmpadawan

New Member
Jan 20, 2021
5
0
1
35
Hello,

I am trying to change the port speed of my server port to 100baseT/Full. The port is part of a supermicro motherboard. The port is being used as a Linux bridge.

The ethtool output:
root@pve:~# ethtool eno1
Settings for eno1:
Supported ports: [ TP ]
Supported link modes: 1000baseT/Full
Supported pause frame use: Symmetric
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: g
Wake-on: g
Current message level: 0x00000007 (7)
drv probe link
Link detected: yes


root@pve:~# ethtool vmbr0
Settings for vmbr0:
Link detected: yes

I have tried variations of:
ethtool -s eno1 autoneg off speed 100 duplex full

ethtool -s eno1 speed 100 ...etc.

none seem to work.

Correct me if I am wrong please, but vmbr0 would not need to be changed as it inherits from eno1 settings?

I want to reduce to 100 because I am connecting it to an old cisco switch 2960 and the port will not come up with it since the supermicro server seems to have its port speed hardcoded as I see no other supported link modes in the ethtool output of eno1.

Any ideas if this port speed change is even possible?

Thank you for any guidance.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!