New install force MBR not GPT

daros

Active Member
Jul 22, 2014
50
1
33
Hello,

I'm setting up a test environment because currently we only host hyper-v based servers.
The installations goes well but after the installations I found out the servers are installed with the GPT partion table.

I tried the installation with a 250GB,320GB and 500GB disk. All the times it's GPT and not MBR.
Is there a way to force MBR?
 

Inten

Active Member
Mar 17, 2015
6
0
26
Wow, I hope that ProxmoxVE will allow an MBR install at some point. I do understand the logic as to why moving to GPT is important but I don't believe removing the MBR install option entirely is a good choice. Here is why. All organizations I have worked in generally follow this path when moving a product/technology into a production environment. Skunk works LAB => LAB => TEST => PRODUCTION. In my experience, the Skunk works LAB phase almost always has older hardware from "hand me downs". This older hardware may not have the newer BIOS to support GPT. Thus ProxmoxVE may not even get into the pipeline towards production.
For example, Vmware still supports MBR installs with the following procedure: during early CD load press "Shift+O" (not zero). You will wee ">runweasel" then press space and type in formatwithmbr and press enter. Install normally.
I believe this is a very smart move.
I am trying to initiate a project in the "Skunk works LAB" however the hardware (while still quite powerful) does not support GPT. :-( From what I understand my only option would be to install ProxmoxVE 3.1 (which will install using MBR) then upgrade up to current. Only thing is I can't seem to find a download link to v3.1. Sigh.
 

Inten

Active Member
Mar 17, 2015
6
0
26
Found one! Not sure if it is the best v3.1 version but I will give it a try. :)
http://www.proxmox.com/images/download/pve/iso/proxmox-ve_3.1-93bf03d4-8.iso
 

Inten

Active Member
Mar 17, 2015
6
0
26
Ok, I installed v3.1 and then upgraded to v3.4. Only thing is it appears the zpool command is not available. Any help would be appreciated as to how I can properly get zpool installed?
 

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
17,145
541
143
Austria
www.proxmox.com

sHAsHiLx

Member
May 17, 2015
10
0
21
so you want to know, why someone need mbr? Take my answer please - My laptop support VT-X and other things to do virtualization but don't support boot from GPT. It's Dell Inspiron N411Z. I don't need it anymore but why dont make it to host some VMs? So I've tried to install then boot another linux disro, run gdisk and convert my partition scheme to MBR. And of course I get grub error telling that it cant found UUD XXXXXXX. So I assing to request - please allow to choose what partition scheme will be - GPT or MBR. Or this is SO F*CKING HARD TO DO?
 

krynos

New Member
May 22, 2021
1
0
1
42
MBR is useful for legacy hardware like my Gen8 HP server that refuses to boot from GPT disks. While I would love to use GPT if it supported it, I am limited by the BIOS.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!