New Cluster - IP question

Aug 14, 2022
3
1
1
Belgium
I'm new to PMG. Managed to start up two instances and put them into cluster. Cluster sync was successful.
But I noticed a difference in listing of the two nodes.
1660478266318.png
Indeed, both nodes have two NICs. One with private and one with public IP.
At install time of the second node I used the public nic, while when installing the first node I specified the private nic. So, that must be the reason.
But how do I normalize this? Or should I ignore it?
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
7,203
1,134
164
But how do I normalize this?
* make a backup
* remove the one node you want to change - with `pmgcm delete <nodeid>`
* setup a fresh pmg
* join it using the correct address

Or should I ignore it?
that depends on your setup and needs - in general pmg's cluster stack works over ssh (and a few utilities on top) - so if this works reliably you could leave it - then again - in my experience such inconsistencies in config have a tendency to cause trouble when you don't expect it

I hope this helps!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!