Network stopped working

Patrik Stenfeldt

New Member
Jan 6, 2019
I have the strangest issue.

I installed an old i5 computer to be an experimental proxmox host. I have been using it for a couple of months now and everything have worked like a charm.
Then suddenly one day the network on the host stopped working. There was a kink on the network cable so i figured the cable was damaged, so i replaced it. Still no network.
Switched reinstalled the whole host. Still no network. Now i have bought a new network card (accidently the exact same chip as the one integrated on the mobo). I installed it, disabled the integrated nic and reinstalled the host.
And still no network. DHCP doesnt work. Static doesnt work.
The interface is up. Leds on card and on switch is green. But no connectivity.

I have resetted the bios too just to make sure there was no strange conflict or setting.

I have no clue where to go from here.
Any ideas?

Oh and the rest of the network is fine and works without any trouble whatsoever.
No i didnt try that, but i will once i get home.
But the thing is that i have reinstalled the host from the same media as i installed it originally.

It seems to me that for some reason the nic have been changed into some persistent mode that does not allow the network to function properly. I have read similar problems with linux system dual booting with windows (which is not the case here) and the windows host have set the nic into wake on lan.

The most odd thing about the whole deal is that im not even using the same nic, but a new one installed today (but with the same broadcom chip version).
I ran linux mint from live usb and the nic worked perfectly. so i removed the new nic, enabled the old and tried mint again. ran perfectly. so i reinstalled proxmox and now it works perfectly. I have no idea what may have happened. but since the error war persistent over several network cards and several reinstalls of proxmox it must have been something hardware related, most likely the nics entered some state which disabled them in proxmox.
There might be a bug involved. if it happens again i will do more research before reinstalling.
glad you solved it, could be really a NIC firmware, or similar issue, maybe also just a problem with the specific kernel which forced the NIC into this state...
If something like this happens again you could try to see if there's a firmware update available for those NICs.


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!