Nested Virtualization not working anymore

proximoxi

New Member
Aug 24, 2018
5
0
1
33
Hello there

i Upgraded my Proxmox and now my Nested Virtual Windows Server 2016 do not start anymore..

Come to the Windows Logo and then the Machine does a reset...

if i change the CPU to the Default (kvm64) then it starts, but the hyper-v machines can not run...

Code:
cat /etc/modprobe.d/kvm-intel.conf
options kvm-intel nested=Y
Code:
cat /sys/module/kvm_intel/parameters/nested
Y
Can you please help me?
 

proximoxi

New Member
Aug 24, 2018
5
0
1
33
Hi Dominik

What for Info do you need?
This?

Code:
cat 120.conf
bootdisk: ide0
cores: 2
cpu: host
ide0: HS-Only:120/vm-120-disk-0.qcow2,backup=0,replicate=0,size=80G
ide1: WinServerDisks:120/vm-120-disk-0.qcow2,size=5G
ide2: WinServerDisks:120/vm-120-disk-1.qcow2,size=5G
ide3: WinServerDisks:120/vm-120-disk-2.qcow2,size=10G
memory: 3072
name: WinServer2016EVAL1
net0: e1000=6A:DE:DF:14:C5:E3,bridge=vmbr0
numa: 0
ostype: win10
scsihw: virtio-scsi-pci
smbios1: uuid=1ae02cb2-0b86-4171-935f-7b5adee398d5
sockets: 1
virtio0: WinServerDisks:120/vm-120-disk-3.qcow2,size=10G
vmgenid: ce194491-f1f7-4b7d-9b8f-b7959dbc0d67
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,706
338
83
31
Vienna
whats you pveversion and did you try a different version of windows server already?
 

proximoxi

New Member
Aug 24, 2018
5
0
1
33
Code:
pveversion
pve-manager/5.3-5/97ae681d (running kernel: 4.15.18-9-pve)
What do you mean with different Version?

I Try a New Test Install from Windows Server (Same ISO), and the reinstall works... But i need the current installation, there are my configuration on it.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,706
338
83
31
Vienna
you could try to see if using an older machine type works, e.g. 2.11
Code:
qm set VMID -machine pc-i44fx-2.11
 

proximoxi

New Member
Aug 24, 2018
5
0
1
33
Hi, get an Error with this command:

Code:
qm set 120 -machine pc-i44fx-2.11
400 Parameter verification failed.
machine: value does not match the regex pattern
qm set <vmid> [OPTIONS]
 

proximoxi

New Member
Aug 24, 2018
5
0
1
33
That's working thank you. Can you explain me what we did with this command?
thank you!
regards
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
3,706
338
83
31
Vienna
it sets the qemu machine type to the version which is used in qemu 2.11, maybe there were some changes which are incompatible with hyper-v
 
  • Like
Reactions: 188pilas

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!