Need help with Cluster


Active Member
May 3, 2019
Hi all,
I have a problem with my server running proxmox.
Some months ago I created a cluster with my server (HP proliand DL380 G7) and a laptop (HP Elitebook 6930p) just to see how that worked and the purpose was to learn how to migrate VMs directly.

But as the laptop had bad specs i waned to move it. So I followed the guide to delete a computer from a cluster with errors. Nothing changed so booted up the computer once again as I got "cluster not ready - no quorum? (500)" error. Some weeks ago I tried again as school ended and I now have time and thought I deleted the other node (the laptop) but i still get the "cluster not ready - no quorum? (500)" errors.
I do not know how to proceed and would like to keep a minimal downtime on the VMs on my server. (If possible)
Both times I followed the wiki without success.

The web server is also broken, I get a blank page while loading it. The pvecm command also broken and gives me some Language errors.
This happend between 1h and 8h of publishing this post.

pvecm output:
"root@pve:~# pvecm
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_PAPER = "sv_SE.UTF-8",
LC_NAME = "sv_SE.UTF-8",
LC_TIME = "sv_SE.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
ERROR: no command specified

pvecm addnode <node> [OPTIONS]
pvecm create <clustername> [OPTIONS]
pvecm delnode <node>

pvecm add <hostname> [OPTIONS]
pvecm expected <expected>
pvecm keygen <filename>
pvecm mtunnel [<extra-args>] [OPTIONS]
pvecm nodes
pvecm status
pvecm updatecerts [OPTIONS]

pvecm help [<extra-args>] [OPTIONS]
root@pve:~# "

I hope anyone can help, I'm not that familliar with proxmox and pretty nooby on linux system. I'm also 15 years old so without much experience. I'm from Sweden so might have different timezone then most here.

Oh, forgot to write that the servers name was "pve" and the laptop was "superpve"

The laptop was gone from the "pvecm status" with only the server showing up.
I still has SSH access to the server and am currently connected.
That locale errors can be ignored.
If cluster won't start VMs or allow operations because it has no quorum and you know you have only one node, you can define quorm to be just one node with:
pvecm expected 1
  • Like
Reactions: SpiderQubit


The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!