Need help set it up after a month of trying

Discussion in 'Proxmox VE: Installation and configuration' started by ieronymous, Apr 12, 2019.

  1. ieronymous

    ieronymous New Member

    Joined:
    Apr 1, 2019
    Messages:
    21
    Likes Received:
    0
    Hello

    New at posting but veteran in reading. Actually I ve read so much info in defferent places that lost control and a confusion cloud is up on my head. So...
    Let me start by the hardware specs which for testing purposes (I ll have a Dell Precision T7600 pending for installtion) I have a plain i3 8100 with an Asrock motherboard (6 sata ports/2 intel gig nics) with 8gb ram no ECC and I have installed the OS in a 32gb stick several times trying to figure out if it would be best to use zfs or native combination of ext4 and lvm / lvm-thin file system (since its on a usb stick and not some kind of raid 1 mirror ssd's I think no point using nfs for now).
    As for storage I tried using lvm and lvm thin in a 1TB raid with no success and 2 days now after several tries configured 2x1TB drives as mirror from sli with zfs file system and setting max memory use for zfs 4gb. First question goes here. I set the number in bytes. Could I just type 4gb and it would understandable by zfs?
    So having added the storage in zfs first thing to do was trying after selecting the prxmxstorage (how I called it) to press the upload button and add an OS ISO.That of course can't happen since the upload tab stays for 3-4secs and then greys out. As many times I managed to press it and giving me the option to select an ISO from the laptop I m using to manage Proxmox I end up with time connection at different percentage each time (7%, 22% 48% ...etc) If I aboard the upload of course the button greys out and even if I try to upload the ISO from the default storage (which is ISO - holder proven ahah) end up with same syslog messages...Connection timed out. Why is that goes to second question (I connect to the job network with ethernet cable not wifi).
    Only one time tried to upload the linux ISO image, selected the appropriate options (I think) and went through the installation ok until next boot which froze all webui of proxmox and through vnc noticed the message booting from hdd....... Probably is because I selected the virtio0 option for disk? Used no cache and no enabling IO threads. What can I do to make it boot again and how my third question. Also tried lsi contoller but I dont know if that is an option into considerartion since its an alredy installed VM. (Just finished a fresh intallation of the VM with sata controller instead of virtio same result.....booting from hdd and freezes there) Also thought of changing the bios from seaBIOS to UVMF but then again remembered having somewhere read that that is not supported by ZFS (True?)
    Finally I ve read somewhere (for not being able to upload iso to the zfs storage issue) that a directory ahs to be created from data center. How can I do that (already did but probably wrong as you may see below in the code tha will follow in a while) meaning ID (whatever I want as name or the name of zfs pool??) and afterwards in Directory: option which is the path I have to type (for instance since I called my zfspool prxmpool) I typed /prxmpool/dirdata. Is the way typed correct?
    The directory shows up at my node with the upload tab active but have the issue of not uploading the file 3 days now as from the local lvm storage.

    Follows some outputs from commands noticed that you need to trace the issue if possible
    Code:
    root@hamilton:~# zfs list -r[/COLOR][/COLOR][/COLOR][/COLOR]
    [COLOR=#ffa64d][COLOR=#000000][COLOR=#ffa64d][COLOR=#000000]NAME                      USED  AVAIL  REFER  MOUNTPOINT
    prxmxpool                5.16G   894G    96K  /prxmxpool
    prxmxpool/vm-100-disk-0  5.16G   894G  5.16G  -
    


    Code:
    root@hamilton:~# pveversion -v[/COLOR][/COLOR][/COLOR][/COLOR]
    [COLOR=#ffa64d][COLOR=#000000][COLOR=#ffa64d][COLOR=#000000]proxmox-ve: 5.3-1 (running kernel: 4.15.18-12-pve)
    pve-manager: 5.3-12 (running version: 5.3-12/5fbbbaf6)
    pve-kernel-4.15: 5.3-3
    pve-kernel-4.15.18-12-pve: 4.15.18-35
    pve-kernel-4.15.18-10-pve: 4.15.18-32
    corosync: 2.4.4-pve1
    criu: 2.11.1-1~bpo90
    glusterfs-client: 3.8.8-1
    ksm-control-daemon: 1.2-2
    libjs-extjs: 6.0.1-2
    libpve-access-control: 5.1-3
    libpve-apiclient-perl: 2.0-5
    libpve-common-perl: 5.0-48
    libpve-guest-common-perl: 2.0-20
    libpve-http-server-perl: 2.0-12
    libpve-storage-perl: 5.0-39
    libqb0: 1.0.3-1~bpo9
    lvm2: 2.02.168-pve6
    lxc-pve: 3.1.0-3
    lxcfs: 3.0.3-pve1
    novnc-pve: 1.0.0-3
    proxmox-widget-toolkit: 1.0-24
    pve-cluster: 5.0-34
    pve-container: 2.0-35
    pve-docs: 5.3-3
    pve-edk2-firmware: 1.20190312-1
    pve-firewall: 3.0-18
    pve-firmware: 2.0-6
    pve-ha-manager: 2.0-8
    pve-i18n: 1.0-9
    pve-libspice-server1: 0.14.1-2
    pve-qemu-kvm: 2.12.1-2
    pve-xtermjs: 3.10.1-2
    qemu-server: 5.0-47
    smartmontools: 6.5+svn4324-1
    spiceterm: 3.0-5
    vncterm: 1.5-3
    zfsutils-linux: 0.7.13-pve1~bpo2


    Code:
    root@hamilton:~# cat /etc/pve/storage.cfg[/COLOR][/COLOR][/COLOR][/COLOR]
    [COLOR=#ffa64d][COLOR=#000000][COLOR=#ffa64d][COLOR=#000000]dir: local
            path /var/lib/vz
            content iso,vztmpl,backup
    
    lvmthin: local-lvm
            thinpool data
            vgname pve
            content images,rootdir
    
    zfspool: prxmxstorage
            pool prxmxpool
            content images,rootdir
            sparse 1
    
    dir: strdata
            path /prxmpool/dirdata
            content rootdir,snippets,backup,vztmpl,images,iso
            maxfiles 1
            shared 1


    Code:
    root@hamilton:~# blkid[/COLOR][/COLOR][/COLOR][/COLOR]
    [COLOR=#ffa64d][COLOR=#000000][COLOR=#ffa64d][COLOR=#000000]/dev/sda1: LABEL="prxmxpool" UUID="3939584211979922624" UUID_SUB="7697325025094749167" TYPE="zfs_member" PARTLABEL="zfs-395e5d17afcccb80" PARTUUID="fc2859ba-f89d-5f45-b2ed-64765809c837"
    /dev/sdb1: LABEL="prxmxpool" UUID="3939584211979922624" UUID_SUB="17303901863141987744" TYPE="zfs_member" PARTLABEL="zfs-07bd80eddde6d7cd" PARTUUID="5334b67d-e2c1-4d47-a68b-9dbb60551685"
    /dev/sda9: PARTUUID="41ef8404-a426-2348-8d1c-e72d6f0bb8e3"
    /dev/sdb9: PARTUUID="1fe080e6-60e2-5d4a-bec7-3cc799daf321"
    /dev/sdc1: PARTUUID="bc250307-1a43-4a73-8123-ee074b60eced"
    /dev/sdc2: UUID="6693-7B18" TYPE="vfat" PARTUUID="6a3f946e-6cb4-42a1-8cff-10e30b0fda68"
    /dev/sdc3: UUID="0iOjth-Csob-XlHG-6KbI-Sk4y-4Xhs-0fyQa2" TYPE="LVM2_member" PARTUUID="f738522d-0820-4414-9bda-603bb7db2e6d"
    /dev/mapper/pve-root: UUID="0d4a9634-7445-4ece-bc1c-5813ffefa7de" TYPE="ext4"
    /dev/mapper/pve-swap: UUID="6cbb9ea1-c163-43c0-8b9b-67b9acecaee6" TYPE="swap"
    /dev/zd0: PTUUID="5d8df332" PTTYPE="dos"
    /dev/zd0p1: LABEL="rootMX18.2" UUID="d5dca1ac-37a1-4f71-ab63-2738ae768be6" TYPE="ext4" PARTUUID="5d8df332-01"
    /dev/zd0p2: LABEL="swapMX" UUID="6a52639b-4abd-4cf8-8559-06b758a433cb" TYPE="swap" PARTUUID="5d8df332-02"


    I wont go on with further question since I need to sort out first the basics and then I dont want to scare readers off with the length of the post if I already didn't.

    Thank you in advance!!!!
     
    #1 ieronymous, Apr 12, 2019
    Last edited: Apr 12, 2019
  2. Andrew Hart

    Andrew Hart Member

    Joined:
    Dec 1, 2017
    Messages:
    68
    Likes Received:
    9
    Hi,
    You have provided lots of info, which is good, but, as you admit, there is a lot to process there...

    At the start I think you are saying that you are installing proxmox onto a 32GB usb stick. This is not a good idea, install proxmox on a SATA hdd or on a sdd. If you accept the default storage options you will end up with a working lvmthin for your VMs.

    A normal 32GB usb stick is far too slow at writing for you to even test things out.
     
  3. ieronymous

    ieronymous New Member

    Joined:
    Apr 1, 2019
    Messages:
    21
    Likes Received:
    0
    Yes I mentioned that but it is for testing purposes only. Do you thing that has to do with the upload problem. Because the I/O is between the 1tb drives and the network card (not the usb stick)

    Thank you for taking the time to read my post . Any thoughts about any of all my other issues??
     
  4. Andrew Hart

    Andrew Hart Member

    Joined:
    Dec 1, 2017
    Messages:
    68
    Likes Received:
    9
    I can't help with zfs but your iso upload problems sound like you are hitting the USB drive hence the grey outs and timeouts.

    To re-enable boot from CD /iso you can look in options boot order and hardware cddrive image choice in the proxmox gui. Or if you are quick you can choose the boot in the vms bios as it boots.

    Please just install proxmox direct on one of your hdd until you get an idea of the features.
     
  5. ieronymous

    ieronymous New Member

    Joined:
    Apr 1, 2019
    Messages:
    21
    Likes Received:
    0
    Not the issue because I have managed to upload the iso days before just once though

    I dis that also today..nothing happened
     
    #5 ieronymous, Apr 12, 2019
    Last edited: Apr 17, 2019
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice