Nach Neuinstallation PBS: wie kann ich den alten Datastore wieder integrieren?

anderl1969

Member
Jul 10, 2022
74
11
13
Hallo,

ich musste mein PBS komplett neu installieren.

Das OS ist auf einem ZFS-Mirror aus 2 NVME-SSDs.
Der ursprüngliche Datastore liegt auf einem separaten ZFS-Mirror aus 2 HDDs.

Nach der Installation des OS habe ich den alten ZFS-Speicher-Pool wieder importiert:

Bash:
> zpool import -f bkp_pool

> zpool list
NAME       SIZE  ALLOC   FREE  CKPOINT  EXPANDSZ   FRAG    CAP  DEDUP    HEALTH  ALTROOT
bkp_pool  1.81T   284G  1.53T        -         -    14%    15%  1.00x    ONLINE  -
rpool      230G  1.06G   229G  

>zpool status bkp_pool
  pool: bkp_pool
 state: ONLINE
  scan: scrub repaired 0B in 01:02:27 with 0 errors on Sun Jun  9 01:26:29 2024
config:

        NAME                        STATE     READ WRITE CKSUM
        bkp_pool                    ONLINE       0     0     0
          mirror-0                  ONLINE       0     0     0
            wwn-0x5000cca369ce966e  ONLINE       0     0     0
            wwn-0x5000cca369ec6c27  ONLINE       0     0     0

errors: No known data errors

So weit, so gut.

Aber wie bekommte ich die alten Datastores in PBS wieder importiert?
 
Du legst einfach den Eintrag wieder in der /etc/proxmox-backup/datastore.cfg an. Wenn die Syntax nicht bekannt ist, dann erstelle einfach einen Dummy-Datastore unter /mnt/teststore oder ähnliches.
 
  • Like
Reactions: anderl1969
Danke, der Hinweis hat weitergeholfen!

Die Suche nach datastore.cfg hat mich hierhin geführt:
https://pbs.proxmox.com/docs/configuration-files.html

Die Syntax ist ja relativ einfach:

Code:
datastore: bkp_pool
   path /mnt/datastore/bkp_pool

Scheint zu funktionieren, zumindest taucht der Datastore wieder auf :)

Noch eine Frage: ich hatte innerhalb des Datastores mit Namespaces gearbeitet. Die scheinen auch wieder da zu sein. Nur um sicher zu sein: die müssen nicht extra konfiguriert werden?
 
Danke für Deine Bestätigung. Sieht tatsächlich so aus, als hätte ich die Kiste wieder up & running.

Fürs nächste mal aber trotzdem mal die config Dateien aufs NAS wegsichern…
 
Danke, der Hinweis hat weitergeholfen!

Die Suche nach datastore.cfg hat mich hierhin geführt:
https://pbs.proxmox.com/docs/configuration-files.html

Die Syntax ist ja relativ einfach:

Code:
datastore: bkp_pool
   path /mnt/datastore/bkp_pool

Scheint zu funktionieren, zumindest taucht der Datastore wieder auf :)

Noch eine Frage: ich hatte innerhalb des Datastores mit Namespaces gearbeitet. Die scheinen auch wieder da zu sein. Nur um sicher zu sein: die müssen nicht extra konfiguriert werden?
Hallo,
noch ergänzend: Eventuell vorher vorhandene jobs und settings wie garbage collection, notifications, verify und sync ecc. müssen auch wieder neu angelegt werden.

Bitte dies zu beachten!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!