Method GET not implemented 501

Nov 13, 2013
8
0
21
Argentina
Hello:

I've updated PVE 3.1 to 3.4.
I can not access the properties of Hardware and options for each virtual machine.
I get the following message: Method 'GET /nodes/proxmox/quemu/102/pending ' not implemented (501)
No visualize any log indicating the problem.
That may be happening?

Thx.
 
Nov 13, 2013
8
0
21
Argentina
Hello dietmar:
root@proxmox01:~# pveversion -v
proxmox-ve-2.6.32: 3.3-147 (running kernel: 2.6.32-37-pve)
pve-manager: 3.4-1 (running version: 3.4-1/3f2d890e)
pve-kernel-2.6.32-20-pve: 2.6.32-100
pve-kernel-2.6.32-37-pve: 2.6.32-147
pve-kernel-2.6.32-23-pve: 2.6.32-109
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.7-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.10-2
pve-cluster: 3.0-7
qemu-server: 3.1-1
pve-firmware: 1.1-3
libpve-common-perl: 3.0-24
libpve-access-control: 3.0-16
libpve-storage-perl: 3.0-31
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-8
vzctl: 4.0-1pve6
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 1.4-17
ksm-control-daemon: 1.1-1
glusterfs-client: 3.5.2-1

I found this log /var/log/pveproxy/access.log

root@pam [03/Mar/2015:12:29:31 -0300] "GET /api2/json/nodes/proxmox/qemu/102/status/current HTTP/1.1" 200 321
root@pam [03/Mar/2015:12:29:31 -0300] "GET /api2/json/cluster/resources HTTP/1.1" 200 2592
root@pam [03/Mar/2015:12:29:32 -0300] "GET /api2/json/nodes/proxmox/qemu/102/pending HTTP/1.1" 501 13
root@pam [03/Mar/2015:12:29:32 -0300] "GET /api2/json/nodes/proxmox/qemu/102/status/current HTTP/1.1" 200 321

Maybe is relevant to the problem. I'll investigate.
 

dietmar

Proxmox Staff Member
Staff member
Apr 28, 2005
17,124
521
133
Austria
www.proxmox.com
Your packages are not up to date, for example qemu-server is very old (should be > 3.3)
 

agin

New Member
Feb 16, 2017
2
0
1
34
Hi lucasl, how do you solve this problem? i've got same problem.

Thanks,
 

agin

New Member
Feb 16, 2017
2
0
1
34
Here is my pveversion, should i update all of them??

Code:
root@proxmox:/etc/pve/local# pveversion -v
proxmox-ve-2.6.32: 3.2-136 (running kernel: 2.6.32-32-pve)
pve-manager: 3.4-16 (running version: 3.4-16/40ccc11c)
pve-kernel-2.6.32-32-pve: 2.6.32-136
lvm2: 2.02.98-pve4
clvm: 2.02.98-pve4
corosync-pve: 1.4.7-1
openais-pve: 1.1.4-3
libqb0: 0.11.1-2
redhat-cluster-pve: 3.2.0-2
resource-agents-pve: 3.9.2-4
fence-agents-pve: 4.0.10-1
pve-cluster: 3.0-20
qemu-server: 3.1-34
pve-firmware: 1.1-3
libpve-common-perl: 3.0-27
libpve-access-control: 3.0-15
libpve-storage-perl: 3.0-23
pve-libspice-server1: 0.12.4-3
vncterm: 1.1-8
vzctl: 4.0-1pve6
vzprocps: 2.0.11-2
vzquota: 3.1-2
pve-qemu-kvm: 2.1-5
ksm-control-daemon: 1.1-1
glusterfs-client: 3.5.2-1

Thanks,
 

pavlos

Member
Dec 17, 2017
7
1
23
63
I have the same issue ... although the error is a bit different.

pve6: pve-manager/7.1-10/6ddebafe (running kernel: 5.13.19-6-pve)

pve5: pve-manager/6.4-14/15e2bf61 (running kernel: 5.4.174-2-pve)

I made pve6 a cluster and pve5 joined the cluster.

pve6 reports: Method 'GET /nodes/pve5/apt/repositories' not implemented (501)

Both pve6 and pve5 are up to date.
 

fabian

Proxmox Staff Member
Staff member
Jan 7, 2016
7,619
1,432
164
1.) this is totally not the same issue ;)
2.) mixed clusters are only supported for the (short!) duration of a cluster-wide upgrade and features introduced in the new version obviously won't work for the outdated cluster members..
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!