Mailgateway einrichten

umutkuepeli

New Member
Dec 8, 2019
15
0
1
26
Guten Morgen,
da ich echt begeistert bin von den Proxmox Produkten wollte ich mal das Mailgateway testen und hab es mir auf mein Proxmox Host als lxc Container installiert.
Jedoch hab ich das Problem das das Proxmox mailgateway den dns server automatisch irgendwie als hostname nimmt und ich somit keine mails über das Gateway kriege oder gefiltert bekomme oder es könnte auch sein das ich Probleme damit habe bei der Einrichtung wenn mir jemand dabei behilflich sein könnte wäre ich sehr dankbar dafür.
Ich häng mal den /var/log/mail.log hier an da sieht man es am besten:

Dec 8 09:25:16 mailgateway001 postfix[195]: Postfix is running with backwards-compatible default settings

Dec 8 09:25:16 mailgateway001 postfix[195]: See http://www.postfix.org/COMPATIBILITY_README.html for details

Dec 8 09:25:16 mailgateway001 postfix[195]: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"

Dec 8 09:25:17 mailgateway001 postfix/postfix-script[270]: warning: symlink leaves directory: /etc/postfix/./makedefs.out

Dec 8 09:25:17 mailgateway001 postfix/postfix-script[306]: starting the Postfix mail system

Dec 8 09:25:17 mailgateway001 postfix/master[308]: daemon started -- version 3.4.5, configuration /etc/postfix

Dec 8 09:25:34 mailgateway001 postfix/postmap[929]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:34 mailgateway001 postfix/postmap[929]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:35 mailgateway001 postfix/postmap[930]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:35 mailgateway001 postfix/postmap[930]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:36 mailgateway001 postfix/postmap[931]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:36 mailgateway001 postfix/postmap[931]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:37 mailgateway001 postfix/postmap[932]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:37 mailgateway001 postfix/postmap[932]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:38 mailgateway001 postfix/postmap[933]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:38 mailgateway001 postfix/postmap[933]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:39 mailgateway001 postfix/postmap[934]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:39 mailgateway001 postfix/postmap[934]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:40 mailgateway001 postfix/postmap[935]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:40 mailgateway001 postfix/postmap[935]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:41 mailgateway001 postfix/sendmail[936]: warning: valid_hostname: numeric hostname: 8.8.8.8

Dec 8 09:25:41 mailgateway001 postfix/sendmail[936]: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 8.8.8.8

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: Process Backgrounded

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: 2019/12/08-09:25:56 main (type Net::Server::preForkSimple) starting! pid(1040)

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: Binding to TCP port 10022 on host 127.0.0.1 with IPv4

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: Group Not Defined. Defaulting to EGID '0'

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: User Not Defined. Defaulting to EUID '0'

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: Setting up serialization via flock

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: Policy daemon (re)started

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: Beginning prefork (5 processes)

Dec 8 09:25:56 mailgateway001 pmgpolicy[1040]: Starting "5" children

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: Process Backgrounded

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: 2019/12/08-09:25:57 main (type Net::Server::preFork) starting! pid(1051)

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: Binding to TCP port 10023 on host 127.0.0.1 with IPv4

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: Binding to TCP port 10024 on host 127.0.0.1 with IPv4

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: Group Not Defined. Defaulting to EGID '0'

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: User Not Defined. Defaulting to EUID '0'

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: Setting up serialization via flock

Dec 8 09:25:57 mailgateway001 pmg-smtp-filter[1051]: Filter daemon (re)started (max. 17 processes)

Dec 8 09:26:06 mailgateway001 pmg-smtp-filter[1051]: Beginning prefork (2 processes)

Dec 8 09:26:06 mailgateway001 pmg-smtp-filter[1051]: Starting "2" children

Dec 8 09:26:36 mailgateway001 pmg-smtp-filter[1051]: starting database maintainance

Dec 8 09:26:36 mailgateway001 pmg-smtp-filter[1051]: end database maintainance (121 ms)

Dec 8 09:28:06 mailgateway001 pmgpolicy[1040]: starting policy database maintainance (greylist, rbl)





Mit Freundlichen Grüßen
Umut Küpeli
 
wie sehen denn /etc/resolv.conf /etc/hosts und /etc/hostname aus?
 
ich hab das Problem lösen können das lxc image hat irgendein Problem hab es jetzt als kam und es läuft. Nur der Spamfilter filtert fast garnicht gibt es da Empfehlungen ? hab mir 270 Spam mails schicken lassen alle sind leider durch gegangen.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get yours easily in our online shop.

Buy now!