mail problem

Oct 1, 2020
55
3
8
41
hi,
We have NVR (netwrok video recorder) in our location.we want to arrange smtp setting on NVR.NVR did not send email.We fill all email setting on NVR but it did not send email.Our DNS at outside.NVR could send email when we use DNS at internal location.
We did not write fgdn name when we setup pmg.(please check picture attached)
can we write our mail fqdn name ?
What we can do ?
Do you have any idea ?
 

Attachments

  • 1643205480437.png
    1643205480437.png
    333.1 KB · Views: 18

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
6,690
992
163
Sorry but I do not understand your question or there are too little details - please provide:
* the settings of your NVR
* the logs of PMG showing that the NVR tries to connect
* the logs of the NVR
 
Oct 1, 2020
55
3
8
41
Hi,
NVR ip address:192.168.0.18
Pmg ip adress: 192.168.53.251

OUR PMG TLS setting: Enable TLS:yes


I am sending log on PMG.

Feb 08 14:06:26 mailgateway postfix/postscreen[1847]: CONNECT from [192.168.0.18]:46065 to [192.168.53.251]:25
Feb 08 14:06:26 mailgateway postfix/postscreen[1847]: PREGREET 16 after 0.01 from [192.168.0.18]:46065: EHLO localhost\r\n
Feb 08 14:06:26 mailgateway postfix/tlsproxy[1991]: CONNECT from [192.168.0.18]:46065
Feb 08 14:06:26 mailgateway postfix/tlsproxy[1991]: warning: TLS library problem: error:14209175:SSL routines:tls_early_post_process_client_hello:inappropriate fallback:../ssl/statem/statem_srvr.c:1742:
Feb 08 14:06:26 mailgateway postfix/tlsproxy[1991]: TLS handshake failed for service=smtpd peer=[192.168.0.18]:46065
Feb 08 14:06:26 mailgateway postfix/postscreen[1847]: HANGUP after 0.02 from [192.168.0.18]:46065 in tests after SMTP handshake
Feb 08 14:06:26 mailgateway postfix/postscreen[1847]: DISCONNECT [192.168.0.18]:46065
Feb 08 14:06:26 mailgateway postfix/tlsproxy[1991]: DISCONNECT [192.168.0.18]:46065
 

Stoiko Ivanov

Proxmox Staff Member
Staff member
May 2, 2018
6,690
992
163
Feb 08 14:06:26 mailgateway postfix/tlsproxy[1991]: warning: TLS library problem: error:14209175:SSL routines:tls_early_post_process_client_hello:inappropriate fallback:../ssl/statem/statem_srvr.c:1742:
This looks like there is a problem with the TLS implementation (of the SMTP submodule) of your NVR

to verify this temporarily disable TLS in PMG and try if you can send mails that way

if this is the case you'd need to update/modify your NVR (to either support a more modern version of TLS) - or to not try to use TLS when communicating with PMG

I hope this helps!
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!