LXC Nextcloud startet nicht

LeSchurke

New Member
Feb 28, 2021
22
2
3
26
Hey Leute :)

ich möchte gerne mein LXC mit Nextcloud starten, bekomme aber diese Meldung.

run_buffer: 321 Script exited with status 32
lxc_init: 846 Failed to run lxc.hook.pre-start for container "102"
__lxc_start: 2002 Failed to initialize container "102"
TASK ERROR: startup for container '102' failed

Gleiche Problem auch mit LXC mit PiHole drauf.

run_buffer: 321 Script exited with status 32
lxc_init: 846 Failed to run lxc.hook.pre-start for container "100"
__lxc_start: 2002 Failed to initialize container "100"
TASK ERROR: startup for container '100' failed

Weiß jemand was da los ist?
100 = Ubuntu
102 = Debian
 

oguz

Proxmox Retired Staff
Retired Staff
Nov 19, 2018
5,207
680
118
hi,

* welche pveversion -v hast du?
* container configs:pct config CTID (e.g. pct config 102, pct config 100 usw.)
* und noch dazu kannst du die debug logs posten: pct start 102 --debug
 

LeSchurke

New Member
Feb 28, 2021
22
2
3
26
hi,

* welche pveversion -v hast du?
* container configs:pct config CTID (e.g. pct config 102, pct config 100 usw.)
* und noch dazu kannst du die debug logs posten: pct start 102 --debug
Code:
proxmox-ve: 7.1-1 (running kernel: 5.13.19-4-pve)
pve-manager: 7.1-10 (running version: 7.1-10/6ddebafe)
pve-kernel-helper: 7.1-12
pve-kernel-5.13: 7.1-7
pve-kernel-5.4: 6.4-7
pve-kernel-5.13.19-4-pve: 5.13.19-9
pve-kernel-5.13.19-2-pve: 5.13.19-4
pve-kernel-5.4.143-1-pve: 5.4.143-1
pve-kernel-5.4.73-1-pve: 5.4.73-1
ceph: 15.2.15-pve1
ceph-fuse: 15.2.15-pve1
corosync: 3.1.5-pve2
criu: 3.15-1+pve-1
glusterfs-client: 9.2-1
ifupdown: 0.8.36+pve1
ksm-control-daemon: 1.4-1
libjs-extjs: 7.0.0-1
libknet1: 1.22-pve2
libproxmox-acme-perl: 1.4.1
libproxmox-backup-qemu0: 1.2.0-1
libpve-access-control: 7.1-6
libpve-apiclient-perl: 3.2-1
libpve-common-perl: 7.1-3
libpve-guest-common-perl: 4.1-1
libpve-http-server-perl: 4.1-1
libpve-storage-perl: 7.1-1
libqb0: 1.0.5-1
libspice-server1: 0.14.3-2.1
lvm2: 2.03.11-2.1
lxc-pve: 4.0.11-1
lxcfs: 4.0.11-pve1
novnc-pve: 1.3.0-2
proxmox-backup-client: 2.1.5-1
proxmox-backup-file-restore: 2.1.5-1
proxmox-mini-journalreader: 1.3-1
proxmox-widget-toolkit: 3.4-6
pve-cluster: 7.1-3
pve-container: 4.1-4
pve-docs: 7.1-2
pve-edk2-firmware: 3.20210831-2
pve-firewall: 4.2-5
pve-firmware: 3.3-5
pve-ha-manager: 3.3-3
pve-i18n: 2.6-2
pve-qemu-kvm: 6.1.1-2
pve-xtermjs: 4.16.0-1
qemu-server: 7.1-4
smartmontools: 7.2-pve2
spiceterm: 3.2-2
swtpm: 0.7.0~rc1+2
vncterm: 1.7-1
zfsutils-linux: 2.1.2-pve1


Code:
arch: amd64
cores: 1
hostname: DataCloud
memory: 550
mp0: local-lvm:vm-102-disk-2,mp=/mnt/hdd,size=625G
net0: name=eth0,bridge=vmbr0,firewall=1,gw=192.168.2.1,hwaddr=32:7B:94:75:4E:1E,ip=192.168.2.245/24,ip6=dhcp,type=veth
onboot: 1
ostype: debian
rootfs: local-lvm:vm-102-disk-1,size=15G
swap: 550
unprivileged: 1


Code:
run_buffer: 321 Script exited with status 32
lxc_init: 846 Failed to run lxc.hook.pre-start for container "102"
__lxc_start: 2002 Failed to initialize container "102"
type g nsid 0 hostid 100000 range 65536
INFO     lsm - lsm/lsm.c:lsm_init_static:38 - Initialized LSM security driver AppArmor
INFO     conf - conf.c:run_script_argv:337 - Executing script "/usr/share/lxc/hooks/lxc-pve-prestart-hook" for container "102", config section "lxc"
DEBUG    conf - conf.c:run_buffer:310 - Script exec /usr/share/lxc/hooks/lxc-pve-prestart-hook 102 lxc pre-start produced output: mount:
DEBUG    conf - conf.c:run_buffer:310 - Script exec /usr/share/lxc/hooks/lxc-pve-prestart-hook 102 lxc pre-start produced output: /var/lib/lxc/.pve-staged-mounts/rootfs: can't read superblock on /dev/mapper/pve-vm--102--disk--1.
DEBUG    conf - conf.c:run_buffer:310 - Script exec /usr/share/lxc/hooks/lxc-pve-prestart-hook 102 lxc pre-start produced output:

DEBUG    conf - conf.c:run_buffer:310 - Script exec /usr/share/lxc/hooks/lxc-pve-prestart-hook 102 lxc pre-start produced output: command 'mount /dev/dm-7 /var/lib/lxc/.pve-staged-mounts/rootfs' failed: exit code 32

ERROR    conf - conf.c:run_buffer:321 - Script exited with status 32
ERROR    start - start.c:lxc_init:846 - Failed to run lxc.hook.pre-start for container "102"
ERROR    start - start.c:__lxc_start:2002 - Failed to initialize container "102"
startup for container '102' failed
 

LeSchurke

New Member
Feb 28, 2021
22
2
3
26
hi,

* welche pveversion -v hast du?
* container configs:pct config CTID (e.g. pct config 102, pct config 100 usw.)
* und noch dazu kannst du die debug logs posten: pct start 102 --debug
habe das Problem gefunden
es ist local-lvm (pve)
Der Speicher war voll
1645177210708.png
habe jetzt ein paar disks auf ein andern Datenträger verschoben

habe jetzt noch lediglich unter CT Volumes folgende 2
1645177297669.png

Ich verstehe aber nicht, woher die 145,12 GB belegter Speicher her kommt.
Es ist ja kein Container mehr auf dem Datenträger.

Kann man den Datenträger irgendwie leeren?
 

Dunuin

Famous Member
Jun 30, 2020
7,261
1,743
149
Germany
Guck mal ob da noch Snapshots vorhanden sind, die das bereinigen verhindern.
Ein fstrim -a sowie pct fstrim 100 und pct fstrim 102 kann auch helfen damit manuell ein discard ausgeführt wird um Gelöschtes für ein LVM-Thin wirklich als gelöscht zu markieren.
Ansonsten kannst du noch mal gucken ob vielleicht versehentlich etwas in einen ungemounteten Mountpunkt geschrieben wurde. Dann landen Daten auf deiner System-Disk anstatt auf einem anderen Storage wie NAS/interne Disk/externe Disk.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!