LXC Debian 9.9 takes two IPs even if he has static configuration

supermario87

Member
Mar 19, 2012
28
0
21
Hi, I have this strage behaviour on only this container.

He has a static IPconfigured but it also take a dhcp lease without any specific configuration
This problem appears only on this LXC.

Do you have some infos on how to debug and solve this problem?

I have already tried to remove network interface with not success.


Thanks


ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
33: eth0@if34: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether da:99:f2:62:b4:90 brd ff:ff:ff:ff:ff:ff link-netnsid 0
inet 192.168.10.8/24 brd 192.168.10.255 scope global eth0
valid_lft forever preferred_lft forever
inet 192.168.10.99/24 brd 192.168.10.255 scope global secondary eth0
valid_lft forever preferred_lft forever
inet6 fe80::463e:9b47:1a59:c2da/64 scope link
valid_lft forever preferred_lft forever
cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.10.8
netmask 255.255.255.0
gateway 192.168.10.1


cat /etc/pve/lxc/102.conf
arch: amd64
cores: 1
hostname: vpn
memory: 512
net0: name=eth0,bridge=vmbr1,firewall=1,gw=192.168.10.1,hwaddr=DA:99:F2:62:B4:90,ip=192.168.10.8/24,type=veth
onboot: 1
ostype: debian
rootfs: local-lvm:vm-102-disk-0,size=16G
swap: 0
unprivileged: 1
lxc.mount.entry: /dev/net dev/net none bind,create=dir


pveversion -v
proxmox-ve: 5.4-1 (running kernel: 4.15.18-14-pve)
pve-manager: 5.4-5 (running version: 5.4-5/c6fdb264)
pve-kernel-4.15: 5.4-2
pve-kernel-4.15.18-14-pve: 4.15.18-39
pve-kernel-4.15.18-13-pve: 4.15.18-37
pve-kernel-4.15.18-12-pve: 4.15.18-36
pve-kernel-4.15.18-11-pve: 4.15.18-34
pve-kernel-4.15.18-10-pve: 4.15.18-32
corosync: 2.4.4-pve1
criu: 2.11.1-1~bpo90
glusterfs-client: 3.8.8-1
ksm-control-daemon: 1.2-2
libjs-extjs: 6.0.1-2
libpve-access-control: 5.1-9
libpve-apiclient-perl: 2.0-5
libpve-common-perl: 5.0-51
libpve-guest-common-perl: 2.0-20
libpve-http-server-perl: 2.0-13
libpve-storage-perl: 5.0-42
libqb0: 1.0.3-1~bpo9
lvm2: 2.02.168-pve6
lxc-pve: 3.1.0-3
lxcfs: 3.0.3-pve1
novnc-pve: 1.0.0-3
openvswitch-switch: 2.7.0-3
proxmox-widget-toolkit: 1.0-26
pve-cluster: 5.0-37
pve-container: 2.0-37
pve-docs: 5.4-2
pve-edk2-firmware: 1.20190312-1
pve-firewall: 3.0-20
pve-firmware: 2.0-6
pve-ha-manager: 2.0-9
pve-i18n: 1.1-4
pve-libspice-server1: 0.14.1-2
pve-qemu-kvm: 3.0.1-2
pve-xtermjs: 3.12.0-1
qemu-server: 5.0-51
smartmontools: 6.5+svn4324-1
spiceterm: 3.0-5
vncterm: 1.5-3
zfsutils-linux: 0.7.13-pve1~bpo2
 

oguz

Proxmox Staff Member
Staff member
Nov 19, 2018
4,990
630
118
hi.

check if you have a dhcp service running.

Code:
ps aux | grep dhc

if you see `dhcpcd` or similar daemon in the output:

Code:
systemctl stop dhcpcd
systemctl disable dhcpcd

and reboot should fix it.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE, Proxmox Backup Server, and Proxmox Mail Gateway.
We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!