[SOLVED] LXC centOS 7 Locale changes with reboot

lodperera

New Member
Jan 28, 2016
15
0
1
I'm running CentOS 7 LXC container on proxmox 5.1

Issue is that the LANG= changes to empty after reboot.
I have to run
Code:
export LANG=en_US.UTF-8
to change it back after the reboot.

Is there a way to persistently set this up for LXC?


Code:
proxmox-ve: 5.1-36 (running kernel: 4.13.13-5-pve)

pve-manager: 5.1-42 (running version: 5.1-42/724a6cb3)
pve-kernel-4.13.4-1-pve: 4.13.4-26
pve-kernel-4.13.13-5-pve: 4.13.13-36
libpve-http-server-perl: 2.0-8
lvm2: 2.02.168-pve6
corosync: 2.4.2-pve3
libqb0: 1.0.1-1
pve-cluster: 5.0-19
qemu-server: 5.0-19
pve-firmware: 2.0-3
libpve-common-perl: 5.0-25
libpve-guest-common-perl: 2.0-14
libpve-access-control: 5.0-7
libpve-storage-perl: 5.0-17
pve-libspice-server1: 0.12.8-3
vncterm: 1.5-3
pve-docs: 5.1-16
pve-qemu-kvm: 2.9.1-6
pve-container: 2.0-18
pve-firewall: 3.0-5
pve-ha-manager: 2.0-4
ksm-control-daemon: 1.2-2
glusterfs-client: 3.8.8-1
lxc-pve: 2.1.1-2
lxcfs: 2.0.8-1
criu: 2.11.1-1~bpo90
novnc-pve: 0.6-4
smartmontools: 6.5+svn4324-1
zfsutils-linux: 0.7.3-pve1~bpo9
ceph: 12.2.2-pve1
Code:
[root@helpdesk ~]# locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
[root@helpdesk ~]# export LANG=en_US.UTF-8
[root@helpdesk ~]# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
[root@helpdesk ~]#
 

lodperera

New Member
Jan 28, 2016
15
0
1
I tried the following

1. Using crontab to run this command at reboot

Code:
@reboot export LANG=en_US.UTF-8
It didn't seem to work.

2. Then I tried to add it to the boot time script /etc/rc.d/rc.local

Code:
export LANG=en_US.UTF-8
It didn't work as well.

I had to manually run the command both times.
 

dcsapak

Proxmox Staff Member
Staff member
Feb 1, 2016
4,275
389
103
31
Vienna
this is a guest os setting, so i believe on centos you have to set your locale in /etc/locale.conf
 
  • Like
Reactions: lodperera

lodperera

New Member
Jan 28, 2016
15
0
1
That did the trick.

I added the locale setting on my centos container as follows.

# cat /etc/locale.conf
LANG=en_US.utf8

Then rebooted, it was all good.
Thanks.
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!