libssl1.0.2 update trying to rebuild initrd and failing

Jan 12, 2015
93
2
28
Hi,
I've tried applying the latest libssl1.0.2 update on several of my Proxmox 5.4 hosts and this is failing with "/usr/sbin/grub-mkconfig: 7: /etc/default/grub: GRUB: not found"
Any thoughts? Sample output is below.


Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
libssl1.0.2
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
Need to get 1,304 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Get:1 http://security.debian.org stretch/updates/main amd64 libssl1.0.2 amd64 1.0.2u-1~deb9u1 [1,304 kB]
Fetched 1,304 kB in 0s (7,568 kB/s)
apt-listchanges: Reading changelogs...
Preconfiguring packages ...
(Reading database ... 181655 files and directories currently installed.)
Preparing to unpack .../libssl1.0.2_1.0.2u-1~deb9u1_amd64.deb ...
Unpacking libssl1.0.2:amd64 (1.0.2u-1~deb9u1) over (1.0.2t-1~deb9u1) ...
Setting up pve-kernel-4.15.18-23-pve (4.15.18-51) ...
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.15.18-23-pve /boot/vmlinuz-4.15.18-23-pve
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.15.18-23-pve /boot/vmlinuz-4.15.18-23-pve
update-initramfs: Generating /boot/initrd.img-4.15.18-23-pve
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.15.18-23-pve /boot/vmlinuz-4.15.18-23-pve
/usr/sbin/grub-mkconfig: 7: /etc/default/grub: GRUB: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/pve-kernel-4.15.18-23-pve.postinst line 19.
dpkg: error processing package pve-kernel-4.15.18-23-pve (--configure):
subprocess installed post-installation script returned error exit status 2
Setting up pve-kernel-4.15.18-24-pve (4.15.18-52) ...
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.15.18-24-pve /boot/vmlinuz-4.15.18-24-pve
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.15.18-24-pve /boot/vmlinuz-4.15.18-24-pve
update-initramfs: Generating /boot/initrd.img-4.15.18-24-pve
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.15.18-24-pve /boot/vmlinuz-4.15.18-24-pve
/usr/sbin/grub-mkconfig: 7: /etc/default/grub: GRUB: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/pve-kernel-4.15.18-24-pve.postinst line 19.
dpkg: error processing package pve-kernel-4.15.18-24-pve (--configure):
subprocess installed post-installation script returned error exit status 2
Setting up pve-kernel-4.15.18-21-pve (4.15.18-48) ...
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.15.18-21-pve /boot/vmlinuz-4.15.18-21-pve
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.15.18-21-pve /boot/vmlinuz-4.15.18-21-pve
update-initramfs: Generating /boot/initrd.img-4.15.18-21-pve
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.15.18-21-pve /boot/vmlinuz-4.15.18-21-pve
/usr/sbin/grub-mkconfig: 7: /etc/default/grub: GRUB: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/pve-kernel-4.15.18-21-pve.postinst line 19.
dpkg: error processing package pve-kernel-4.15.18-21-pve (--configure):
subprocess installed post-installation script returned error exit status 2
Setting up libssl1.0.2:amd64 (1.0.2u-1~deb9u1) ...

Processing triggers for libc-bin (2.24-11+deb9u4) ...
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!