kworker 100% cpu

Odys001kn

New Member
Oct 30, 2017
6
0
1
59
Hallo,

ich habe mit Hilfe des WIKI und diesem Beitrag
https://forum.proxmox.com/threads/guide-intel-intergrated-graphic-passthrough.30451/
erfolgreich das passthrough der on Board Grafikkarte einrichten können. Die VM funktioniert mit den Einstellungen und der durchgereichten intel GPU perfekt.
Dann ist ein ständig unter Vollast laufender CPU Lüfter aufgefallen, im Web-Frontend wurde eine CPU Auslastung von Proxmox von 25% gezeigt, (ohne sonst passthrough 1-2%) und die Konsole liefert Informationen zu einem Prozess "kworker 1/1" mit 100% CPU Last.
Unabhängig ob die VM läuft oder nicht, wenn das passthrough wieder deaktiviert wird, ist die CPU Last wieder normal.
Informationen aus dem Netz weisen unter anderem auf einen Zusammenhang mit acpi hin, ein hinzufügen der Option "acpi=off" über das Grub File deaktiviert passthrough komplett. Auch verschiedene andere Optionen im Grub File bringen keine Erfolg oder deaktivieren passthrough.
Ein "cat /proc/PID/stack" liefert keine Ergebnisse zum kworker Prozess
Ein "grep . -r /sys/firmware/acpi/interrupts/" liefert keine Informationen zur betreffenden Komponente
Hat jemand eine Idee zur Lösung?

Mein System:
CPU Intel i5-2500 3.30GHz
Mainboard: Z68 pro3 Gen3 last Bios

proxmox-ve: 5.1-25 (running kernel: 4.13.4-1-pve)
pve-manager: 5.1-36 (running version: 5.1-36/131401db)
pve-kernel-4.10.1-2-pve: 4.10.1-2
pve-kernel-4.13.4-1-pve: 4.13.4-25
pve-kernel-4.10.17-4-pve: 4.10.17-24
pve-kernel-4.10.17-2-pve: 4.10.17-20
pve-kernel-4.10.15-1-pve: 4.10.15-15
pve-kernel-4.10.8-1-pve: 4.10.8-7
pve-kernel-4.10.17-3-pve: 4.10.17-23
pve-kernel-4.10.11-1-pve: 4.10.11-9
pve-kernel-4.10.17-1-pve: 4.10.17-18
libpve-http-server-perl: 2.0-6
lvm2: 2.02.168-pve6
corosync: 2.4.2-pve3
libqb0: 1.0.1-1
pve-cluster: 5.0-15
qemu-server: 5.0-17
pve-firmware: 2.0-3
libpve-common-perl: 5.0-20
libpve-guest-common-perl: 2.0-13
libpve-access-control: 5.0-7
libpve-storage-perl: 5.0-16
pve-libspice-server1: 0.12.8-3
vncterm: 1.5-2
pve-docs: 5.1-12
pve-qemu-kvm: 2.9.1-2
pve-container: 2.0-17
pve-firewall: 3.0-3
pve-ha-manager: 2.0-3
ksm-control-daemon: 1.2-2
glusterfs-client: 3.8.8-1
lxc-pve: 2.1.0-2
lxcfs: 2.0.7-pve4
criu: 2.11.1-1~bpo90
novnc-pve: 0.6-4
smartmontools: 6.5+svn4324-1
zfsutils-linux: 0.7.2-pve1~bpo90
 

About

The Proxmox community has been around for many years and offers help and support for Proxmox VE and Proxmox Mail Gateway. We think our community is one of the best thanks to people like you!

Get your subscription!

The Proxmox team works very hard to make sure you are running the best software and getting stable updates and security enhancements, as well as quick enterprise support. Tens of thousands of happy customers have a Proxmox subscription. Get your own in 60 seconds.

Buy now!