[SOLVED] Kann NFS Share nicht mounten

Discussion in 'Proxmox VE (Deutsch)' started by NexorProject, Oct 11, 2018.

  1. NexorProject

    NexorProject New Member

    Joined:
    Oct 11, 2018
    Messages:
    2
    Likes Received:
    0
    Hallo Zusammen

    Nach langem Suchen über Google und im Forum bin ich leider zu keinem Ergebnis gekommen.

    Ich habe auf einer Node einen NFS Server installiert und zwei Partitionen unter /mnt/backup und /mnt/isos für die Dementsprechenden Zwecke erstellt und Freigegeben. Die Shares werden auch ohne weiteren Kommentar von jeder Node aus mit pvesm nfsscan <ip-adresse der nfs node>, angezeigt:
    Code:
    pvesm nfsscan 192.168.203.159
    /mnt/isos   192.168.203.159
    /mnt/backup 192.168.203.159
    Und Inhalt der /etc/exports Datei:
    Code:
    /mnt/backup 192.168.203.159(rw,sync,no_subtree_check)
    /mnt/isos 192.168.203.159(rw,sync,no_subtree_check)
    Zuerst hatte ich zwei spezielle Benutzer "backup_snapshots" und "iso_access" welche ich mit chown den entsprechenden /mnt Verzeichnissen zugewiesen habe. Als ich jedoch beim hinzufügen von NFS Shares übers WebUI von Rechte Problemen lass, habe ich zuerst versucht root zur jeweiligen Benutzergruppe hinzuzufügen und dann mit z.B. chown backup_snapshots:backup_snapshots /mnt/backup ebenfalls der Gruppe rechte zu erteilen. Als dies ebenfalls Fehlschlug habe ich chown root:root /mnt/backup probiert aber weiterhin ohne erfolg. chmod 755 ist auf beide Verzeichnisse angewandt und der NFS Server mehrfach (nach jedem Neuversuch) ohne Fehlermeldung neugestartet.

    Der Fehler den ich vom WebUI erhalte lautet:
    Code:
    mkdir /mnt/pve/Backup/dump: Permission denied at /usr/share/perl5/PVE/Storage/Plugin.pm line 882. (500)
    "Backup" ist die ID des zu erstellenden NFS Shares das ich im UI angegeben habe.

    Der Fehler klingt nicht nach einem Mount Problem sondern nach einem reinem Rechte Problem, jedoch verstehe ich nicht wieso.

    Das sind übrigens die Rechte von ls -l /mnt (nach letztem versuch mit Zuweisung von chown root:root):
    Code:
    drwxr-xr-x 3 root root 4096 Oct 11 14:31 backup
    drwxr-xr-x 3 root root 4096 Oct 11 14:32 isos
    drwxr-xr-x 5 root root 4096 Oct 11 14:46 pve
    Die NFS Shares sind übrigens mit NFSv3 gemounted:
    Code:
    /mnt/pve/Backup from 192.168.203.159:/mnt/backup
     Flags: rw,relatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.203.159,mountvers=3,mountport=48938,mountproto=udp,local_lock=none,addr=192.168.203.159
    
    /mnt/pve/Backups from 192.168.203.159:/mnt/backup
     Flags: rw,relatime,vers=3,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.203.159,mountvers=3,mountport=48938,mountproto=udp,local_lock=none,addr=192.168.203.159
    Jemand eine Idee was da los ist?

    Freundliche Grüsse
    NexorProject
     
  2. hec

    hec Member

    Joined:
    Jan 8, 2009
    Messages:
    198
    Likes Received:
    5
    Das Problem heißt root_squash bzw no_root_squash. Du musst mehr oder weniger den NFS Server so konfigurieren, dass root auf Lokalen Server == root auf remote Server. Dann sollte alles funktionieren.

    Alternativ chown nobody:nogroup dann sollte es auch funktionieren.
     
  3. NexorProject

    NexorProject New Member

    Joined:
    Oct 11, 2018
    Messages:
    2
    Likes Received:
    0
    Wenn man nur manchmal wüsste wonach man sucht.. Über root_squash und no_root_squash bin ich bei meiner suche mehrfach gestossen, konnte jedoch nicht wirklich was damit anfangen. Das hinzufügen von "root_squash" als Option bei den eingebundenen Partitionen unter: /etc/exports hat den Trick getan.

    Vielen Dank nochmals ;)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice